Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-11-2007, 12:58 PM   #1
bagelicious
Scooby Newbie
 
Member#: 141030
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Lake Oswego
Vehicle:
98 Legacy GT
Spruce Pearl

Default Leak from Clutch Master Cyl?

So I was driving to work today on 205 and a truck rolled, leaving me stuck in stop and go traffic for 30 minutes.

Towards the end of this, the clutch pedal in my 98 Legacy GT was starting to stick to the floor.

Heres what happens:

Depress clutch to shift gear
Shift into 1st
give it gas
at this point, the clutch starts engaging even though the pedal is all the way down.
lift up foot
pedal stays down.

I can finagle it and drive it around, but I need to fix it obviously.

The fluid in the clutch cylinder on the firewall looks a bit low on fluid. There was also liquid all over half of the transmition, that was actually smoking a little. The liquid wasn't just on the tranny though, there were a few places where it was on the motor too.

I Think the leak is coming from the tube that goes between the master and slave cylinders, both those cylinders are only ~8 months old, I replaced them, but none of the hoses in between.

Thanks for any input
* Registered users of the site do not see these ads.
bagelicious is offline   Reply With Quote
Old 09-11-2007, 02:12 PM   #2
flanders
Scooby Specialist
 
Member#: 76382
Join Date: Dec 2004
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2000 BH
BP Wannabe

Default

The BE/Bh had a similar problem, there is a TSB about it. Probably the same problem. Something was replaced on my car but can't remember what it was.
flanders is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sti Clutch master cyl vs WRX Vlad Transmission (AT/MT) & Driveline 0 04-07-2006 03:55 PM
WTB: 02 Wrx/RS pedal assembly and clutch master cyl LiquidForce Private 'Wanted' Classifieds 5 01-24-2006 01:20 PM
Need a Vaccum Brake Booster for WRX Clutch Master Cyl stewgod Brakes, Steering & Suspension 1 06-01-2005 10:02 PM
clutch master cyl. problems trbowrx Transmission (AT/MT) & Driveline 5 03-26-2005 03:04 PM
WTB clutch master cyl for WRX Subaruski Private 'Wanted' Classifieds 3 08-29-2004 11:54 PM


All times are GMT -4. The time now is 01:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.