Welcome to the North American Subaru Impreza Owners Club Friday February 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-16-2007, 05:16 AM   #1
reddevil
Scooby Guru
 
Member#: 64673
Join Date: Jun 2004
Chapter/Region: NWIC
Location: portland
Vehicle:
1990 Legacy wagon
goes 12.387 @ 116.5

Default 13.1 @ 105 but only 14 psi!

Was breaking the motor in untuned (runned rich across the map) and the new motor seems to be monster in the making.

13.6 @ 100 @ 11 psi
13.4 @ 102 @ 13 psi
13.1 @ 105 @ 14 psi.

Then I ate 1st gear. haha


The motor in question is
Phase 1 block 2.5 pinned cylinders
100 mm Mahle pistons
Stock STI crank and rods
820 cc injectors, modded STI sidefeeds
Twin turbo DOHC heads and intake manifold


Using a PerfectPower6 piggyback on the stock 1990 NA ECU.
* Registered users of the site do not see these ads.
reddevil is offline   Reply With Quote
Old 09-16-2007, 10:45 AM   #2
Paul
Scooby Guru
 
Member#: 56203
Join Date: Feb 2004
Chapter/Region: Tri-State
Location: south nj
Vehicle:
00 RSTI Coupe
Twin Scroll 2.5XTR EJ207

Default

isnt running rich to break a motor a bad thing to do?
any idea on CR?
Paul is offline   Reply With Quote
Old 09-16-2007, 01:50 PM   #3
reddevil
Scooby Guru
 
Member#: 64673
Join Date: Jun 2004
Chapter/Region: NWIC
Location: portland
Vehicle:
1990 Legacy wagon
goes 12.387 @ 116.5

Default

Safe rich, not black smoke rich.

Compression should be 8.2-1 or somewhere close.
reddevil is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.