Welcome to the North American Subaru Impreza Owners Club Monday June 27, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-16-2007, 11:54 AM   #1
puffer
Scooby Newbie
 
Member#: 152437
Join Date: Jun 2007
Default potential oil leak

after oil change I was ready to put back the bottom cover then I noticed oily areas on the engine block near the bottom of the coolant spillover tank. Upon closer examination I found that the oil slowly drips through the spongy gasket under the black cover attached to the engine block (timing belt cover?).

My car does not seem to have excessive oil consumtion, but dripping oil worries me. Can you guys comment is this a serious issue. Here is a couple of pictures I took today.



this is the cover from above


* Registered users of the site do not see these ads.
puffer is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-16-2007, 09:35 PM   #2
Ironmansixx
Scooby Newbie
 
Member#: 117003
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: louisville, Ky
Vehicle:
02 Bugeye
WRB

Default

Are you sure its just not oil that missed the oil fill tube and it's running down the side of the block?
Ironmansixx is offline   Reply With Quote
Old 09-16-2007, 10:06 PM   #3
whateverwrx
Scooby Newbie
 
Member#: 99653
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
05 WRX
silver

Default

peek inside the t-belt cover and see if the belt is wet. looks like some spillage from a whoopsy pouring it in the last time. but maybe a cam seal? i dont think it would be on top like that if it were a cam seal :S
whateverwrx is offline   Reply With Quote
Old 09-19-2007, 09:09 PM   #4
puffer
Scooby Newbie
 
Member#: 152437
Join Date: Jun 2007
Default

I'm sure I did not spill oil during a previous oil change, since I always use funnel.

how difficult is to remove t-belt cover? and how to check camshaft seals?I'm thinking the oil comes from the area under the black t-belt cover.
puffer is offline   Reply With Quote
Old 10-27-2007, 09:18 PM   #5
anthonyrb98
Scooby Guru
 
Member#: 48307
Join Date: Nov 2003
Chapter/Region: SCIC
Location: san diego
Vehicle:
02 bugeye
hbspeed tuned 18g sleeper

Default

did you fix your problem? if so, what did you do?
anthonyrb98 is offline   Reply With Quote
Old 10-28-2007, 09:34 AM   #6
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Cam seal or oil pump seal maybe
quazimoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP with possibly compressor oil leak? TWR3CKS Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 06-04-2010 02:00 PM
Expert advice needed: potential air leak/starting problem bulletSTI Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 04-20-2009 04:29 PM
Another Potential Vacuum Leak Issue STi.CC. Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 11-13-2008 02:43 PM
Potential Boost leak on my04 nyngbld Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 04-28-2005 11:32 AM
weird oil leak/AC leak? NateDogg Service & Maintenance 2 05-03-2004 04:23 PM

All times are GMT -4. The time now is 02:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.