Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-19-2001, 05:22 AM   #1
GooseMan
Scooby Specialist
 
Member#: 2462
Join Date: Sep 2000
Chapter/Region: SCIC
Location: Los Angeles/Montreal
Vehicle:
2012 Volvo S60 T5
2005 Triumph Sprint ST

Exclamation Aaaaahhhhh!!! CE light??!!

About 10 minutes into my drive to work my CE light came one. WHY???? I havent done anything different to my car in the last 24 hours. All I did recently was pull off the snorkus/silencer thingy (I have a MY00), but that was last weekend. Why would the light come on now? Is it because I didn't reset the ECU? I have to make a little trip this weekend, so I hope it's safe. AND, if I do have to reset the ECU, which battery lead do I disconnect? The red one?? I know I know, pahtetic...I HATE BATTERIES, OK??

Jon
* Registered users of the site do not see these ads.
GooseMan is offline   Reply With Quote
Old 04-19-2001, 05:54 AM   #2
SkToBe
Ghost Mod
Moderator
 
Member#: 1278
Join Date: Apr 2000
Chapter/Region: MAIC
Location: Manassas, VA
Vehicle:
2001 RS
Aspen White

Post

The black one. (Gas cap on tight?)
SkToBe is offline   Reply With Quote
Old 04-19-2001, 05:57 AM   #3
Mike Smith
Scooby Specialist
 
Member#: 744
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: Middlesex, NY USA
Vehicle:
00 BRP RS Coupe
02 Forester, 00 S-10,

Post

O2 sensor, I'm betting.
Mike Smith is offline   Reply With Quote
Old 04-19-2001, 06:04 AM   #4
GooseMan
Scooby Specialist
 
Member#: 2462
Join Date: Sep 2000
Chapter/Region: SCIC
Location: Los Angeles/Montreal
Vehicle:
2012 Volvo S60 T5
2005 Triumph Sprint ST

Question

Mike- O2 sensor? Can you explain why you think its that? Not that I'm doubting you at all, I just want to know if its related to my snorkus removal. Or is that a common problem with MY00 RS's?

Also, when a CE light goes on, does that mean that something is wrong with the electronics and/or emissions systems of the car? So usually it isn't something major, right? If I was losing oil or something would I get some kind of other light (besides the obvious)? Thanks guys!

Jon
GooseMan is offline   Reply With Quote
Old 04-19-2001, 06:34 AM   #5
tmat3
Scooby Specialist
 
Member#: 2817
Join Date: Nov 2000
Location: NYC and Troy, NY
Vehicle:
2001 Impreza 2.5RS
BRP

Post

I would also think it's the o2 sensor, unless it's only caused by a loose gas cap. It may be the O2 sensor because Subaru had a bunch of defective O2 sensors on MY00 and some MY01 cars.

CE light is triggered by almost anything from loose gas cap, misfire, faulty sensors, or broken MAF sensor (which you don't have). It can be either minor or major. You don't know until you get the code scanned at the dealer or any other service shops.
tmat3 is offline   Reply With Quote
Old 04-19-2001, 06:38 AM   #6
Mike Smith
Scooby Specialist
 
Member#: 744
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: Middlesex, NY USA
Vehicle:
00 BRP RS Coupe
02 Forester, 00 S-10,

Post

MY00 RSs have been recalled to replace the O2 sensors. When they fail, the check engine light comes on. Basically, the check engine light is an indicator that something is not right in the emissions system - it's almost never anything that will cause damage to your engine. And often it's only a temporary condition that requires nothing more than a reset of the light.
Mike Smith is offline   Reply With Quote
Old 04-19-2001, 08:02 AM   #7
GooseMan
Scooby Specialist
 
Member#: 2462
Join Date: Sep 2000
Chapter/Region: SCIC
Location: Los Angeles/Montreal
Vehicle:
2012 Volvo S60 T5
2005 Triumph Sprint ST

Post

Loose gas cap? Really? How does it know? Come to think of it, I just filled up and I might not have tightened it. Hmm.....I'll check the O2 sensor too. Thanks guys! Man, this Forum business is soooooooo useful!

Jon
GooseMan is offline   Reply With Quote
Old 04-19-2001, 08:05 AM   #8
Mike Smith
Scooby Specialist
 
Member#: 744
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: Middlesex, NY USA
Vehicle:
00 BRP RS Coupe
02 Forester, 00 S-10,

Post

Yeah, my salesperson at VanBortel's told me she would slap me if I ever came in for a "check engine" and the gas cap was loose. She musta reminded me about it ten times

There's some kinda vapor recirculation system that gets screwed up if the cap isn't tight. Make sure it clicks when you tighten it.
Mike Smith is offline   Reply With Quote
Old 04-19-2001, 08:30 AM   #9
pleiades
Scooby Specialist
 
Member#: 2491
Join Date: Sep 2000
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
06 Miata
81 Fiat Spider

Wink

Your initiation is complete! Subaru's are supposed to have a constant CE light, right?
pleiades is offline   Reply With Quote
Old 04-19-2001, 08:41 AM   #10
Yotsuya
Scooby Guru
 
Member#: 935
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: ಠ_ಠ
Vehicle:
Jack Soo Fan Club

Post

No, you're confused with taxis, which have a little peice of plastic to cover the CE light so as not to alarm passengers.
Yotsuya is offline   Reply With Quote
Old 04-19-2001, 05:05 PM   #11
GooseMan
Scooby Specialist
 
Member#: 2462
Join Date: Sep 2000
Chapter/Region: SCIC
Location: Los Angeles/Montreal
Vehicle:
2012 Volvo S60 T5
2005 Triumph Sprint ST

Post

Thanks guys! I checked my gas cap and it was MISSING! Either I left it on the pump or someone stole it, I dunno....So I went out and bought a NICE locking one. Why subie doesnt make a locking door, I dunno. But the CE is still on...I guess I have to reset it now, eh?

Jon
GooseMan is offline   Reply With Quote
Old 04-19-2001, 06:40 PM   #12
SkToBe
Ghost Mod
Moderator
 
Member#: 1278
Join Date: Apr 2000
Chapter/Region: MAIC
Location: Manassas, VA
Vehicle:
2001 RS
Aspen White

Post

Reset. Remove black battery lead for about 30-45 minutes (or more?). Make sure you have the key fob handy when you re-connect the battery (alarm will go off). Start engine without touching the gas (it should stall). Re-start and allow to idle until warm. (I wait until the electric fans kick on.) Drive car BRISKLY...
SkToBe is offline   Reply With Quote
Old 04-19-2001, 08:39 PM   #13
Tobias_Ostapchuk
Scooby Newbie
 
Member#: 554
Join Date: Nov 1999
Location: Darien, CT, USA
Vehicle:
2002 Subaru WRX S/W
Aspen White

Post

....and if the CEL doesn't go off, just put a piece of electrical tape over it, and voila....you're CEL free!
Tobias_Ostapchuk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) 1500 miles and CE light comes on. Rubik Impreza Forum 9 06-09-2001 04:15 PM
('93-'01) CE light - crazy fuel gauge Captain Ding Impreza Forum 3 06-08-2001 08:15 AM
('93-'01) Engine Overheat, CE light problem Piusma Impreza Forum 11 06-04-2001 05:35 PM
('93-'01) Green Plug...........CE light? XROLLER Impreza Forum 10 04-10-2001 12:57 AM
('93-'01) CE Light Fyxtion Impreza Forum 3 04-07-2001 07:10 PM


All times are GMT -4. The time now is 07:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.