Welcome to the North American Subaru Impreza Owners Club Tuesday September 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2002, 08:54 PM   #1
mywrx2002
Scooby Newbie
 
Member#: 4613
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: Lou.,Ky. & Van. BC
Vehicle:
2002 wrx sedan
SRP

Unhappy have new turbo in car

Well I have posted most of my grief in the Forced Induction part of here, but in a nutshell my car was @ dealer for almost 3 weeks, 2.5 of that while the dealers "super tech" couldn't figure out that the turbo was squealing excessivly and it took a SOA rep., and the rep calling the tech line( like the dealership sholuld have done ) to rectify the problem.
Of course after all the questions I posed to them( i'm ASE master Tech, and work for a major tire and rubber company in a management role) they are very tired of my face and wouldn't give me a straight answer as to why it failed with only 6500 miles and only being 11 months old.
So anyone else out there with turbo problems currently, or behind them, please feel free to post and add to my ammo as i feel my up pipe is starting to come apart and the "super tech" doesn't even know there is a catalist pre turbo.

Thanks
Jamey
* Registered users of the site do not see these ads.
mywrx2002 is offline   Reply With Quote
Old 01-15-2002, 02:22 PM   #2
speedbuggy67
Scooby Specialist
 
Member#: 9041
Join Date: Aug 2001
Chapter/Region: Tri-State
Location: Jersey Shore
Vehicle:
2002 WRX
blaze yellow 1-450

Default

My WRX is in the shop now and squeels like a pig when its cold and my radiator just cracked so it is really making me mad after 8500 miles. Oh and my boost bounces all around when accelerating.

Scott
speedbuggy67 is offline   Reply With Quote
Old 01-15-2002, 02:38 PM   #3
NJ WRX 63
*** Banned ***
 
Member#: 13996
Join Date: Jan 2002
Location: nj
Vehicle:
2002 ExperimentalWRX
WHITE

Default

Let me tell you the freekin problems i had..
baught the car over the phone...everything was ok until i took the car for the A/D mirror ( not to mention my car was supposed to have every option) Get the car it is stripped (no options) get the car because the price is right. while getting the mirror put in they tell me i have to resign a new contract..almost left the car there after 2 months of haveing it...no phoen calls nothing. SOA customer service cant help me. Salesman gets fired. car isnt clean. rt 22 never again. called subaru rep...head of distibution for the north east ..very nice guy. send me 100$ tells me to call him if anything else happens..called him ..never returned call after 3 weeks.
Jenn gets her car...put the wing on and they forget the helper spring for the truck and they scratch her car...not to mention she had warantee issues with scratched sstuff in her car...never wants to go back.
SOLO ABM brings his car like 5 time because of CEL problems cant fix it...they find a mouse nest (or they say) in his car and they eat the wires. I find out this week that it is the dealers problem that there are mice in the car ..almost all subs and jeeps are having this problem from the factory.
I ask to put a wing on since i work at sub dealer now. they wont put the wing on because they say it will me up the car. maybe they cant do it...
Im finding probs everywhere with these dealers...i think its time for SOA to restructure their organization before the EVO get here or they are in big trouble...
Question for you just to ponder....the people were ready for this car but was subaru!?
Nick
NJ WRX 63 is offline   Reply With Quote
Old 01-15-2002, 03:10 PM   #4
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Woolley
Vehicle:
1998 Ram 2500
Green.

Default

Care to rephrase that in modern English, so it makes a little sense?
CosmoTheCat is offline   Reply With Quote
Old 01-16-2002, 10:08 AM   #5
Willman67
Scooby Specialist
 
Member#: 3439
Join Date: Jan 2001
Location: Houston,Texas (state and count
Vehicle:
2001 Chevy 2500HD
Mean Green Machine

Default my car makes a "cricket" sound when cold or upon any restart

My car started making a "cricket" sound from the turbo side of the engine compartment when you go to medium-full boost when the motor is cold or if you restart after letting the car sit for 5-10 minutes (and its fully warmed, as in after driving for awhile). After 5-10 min of driving it dissapears. The dealer replaced my turbo two weeks ago and the sound is still there in its exact form. I have heard some suggestion that it could be the pre-cat catalyst being loose. My problem is still there and it worries me. I have heard at least two other owners on the board complain of this exact thing (megatron and the other I can't remember).

Any info or other remedies would be greatly appreciated!

Willman
Willman67 is offline   Reply With Quote
Old 01-17-2002, 05:09 PM   #6
Stanley
Scooby Guru
 
Member#: 7374
Join Date: Jun 2001
Location: North Bay, SFCA
Vehicle:
2007 Grandpamobile
BlingBlingBlue

Lightbulb

Quote:
when you go to medium-full boost when the motor is cold
You should really try to stay off boost until the engine is fully warm. If I had to guess what the noise was I'd say it is the tumble generator valve. If you do a search for "cricket exhaust" you will get some interesting and informative hits.

Back on topic...Jamey, please be sure to keep us posted if you get to the root cause. The "Pre-Cat" makes me a little nervous too...
Stanley is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone still have the T2 In-car Runoff video? Impreza01 Motorsports 0 08-25-2006 02:35 AM
Need help on turbo in car? josh04 Factory 2.0L Turbo Powertrain 13 01-08-2006 07:44 PM
Some girls just have no taste in cars chrisdeaner Off-Topic 11 08-10-2003 03:36 PM
I have a turbo in my car ... blaster88 Mid Atlantic Impreza Club -- MAIC 4 04-03-2001 07:30 AM
Old WRX vs New WRX in Car Mag. HomerJay General Forum Archive 1 12-20-2000 07:26 PM


All times are GMT -4. The time now is 06:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.