Welcome to the North American Subaru Impreza Owners Club Thursday July 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-26-2007, 08:00 PM   #1
spoolinred
Scooby Specialist
 
Member#: 117017
Join Date: Jun 2006
Location: somewhere in the 10's....
Vehicle:
03 2.0fpred wrx!!
blue

Default perrin 3" intake, is this normal?

i was putting the power steering pump back on my motor today and the intake tube was not letting it go back far enough. finally i got it pushed back, but the pump is pushing in on the intake, is this the way it works or did i not do something right?
* Registered users of the site do not see these ads.
spoolinred is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-26-2007, 10:06 PM   #2
spoolinred
Scooby Specialist
 
Member#: 117017
Join Date: Jun 2006
Location: somewhere in the 10's....
Vehicle:
03 2.0fpred wrx!!
blue

Default

come on guys i know someone can anwser this question for me...
spoolinred is offline   Reply With Quote
Old 09-26-2007, 10:14 PM   #3
bigmike25rs
Scooby Specialist
 
Member#: 83924
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: Cleveland, OH
Vehicle:
2005 HTA 86 STi
10.66 @ 136 mph

Default

That's how I've seen it on a few cars..
bigmike25rs is offline   Reply With Quote
Old 09-27-2007, 10:10 PM   #4
nsucdm_wrx
Scooby Newbie
 
Member#: 39771
Join Date: Jul 2003
Chapter/Region: MWSOC
Location: cincinnati
Vehicle:
02 FPRed 2.5l WGN
Built heads ;)

Default

I had the same issue...that inlet is a PITA
nsucdm_wrx is offline   Reply With Quote
Old 09-27-2007, 10:22 PM   #5
spoolinred
Scooby Specialist
 
Member#: 117017
Join Date: Jun 2006
Location: somewhere in the 10's....
Vehicle:
03 2.0fpred wrx!!
blue

Default

Quote:
Originally Posted by nsucdm_wrx View Post
I had the same issue...that inlet is a PITA
yeah i know what you mean, it is super tight against my pump, i hope it doesn't eventually rub a hole in it....plus that takes away from some of the airflow...or so i would think
spoolinred is offline   Reply With Quote
Old 09-28-2007, 10:44 AM   #6
noisycricket
Scooby Newbie
 
Member#: 148043
Join Date: May 2007
Default

The turbo couldn't flow enough for the little kink to cause a noticeable restriction. I wouldn't worry about it.
noisycricket is offline   Reply With Quote
Old 09-28-2007, 12:17 PM   #7
Freon
Scooby Specialist
 
Member#: 88322
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Indianapolis, IN
Vehicle:
2009 BMW 135i

Default

This seems typical. One of the local just installed one on his FP Green and it is loose on the intake manifold side and pushing again the PS pump. It looks like the whole piece should sit farther back, but it was fully seated on the turbo inlet.
Freon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My first TURBO car. Is this normal? Carartist Newbies & FAQs 6 06-03-2010 06:50 PM
FS-> FP Green 3", perrin 3" intake, 70mm APS CAI, APv1 silvergrey05 Engine/Power/Exhaust 9 10-14-2008 11:36 AM
is this normal for the normal headlight sequence for an 07 outback? jawwadh Electrical & Lighting 6 08-08-2008 11:34 PM
Perrin FSB - is this normal? runwrxrun Brakes, Steering & Suspension 7 11-05-2006 01:08 PM
Reserve is hard to engage 3 out of 5 times... Is this normal? MrP0nch0 Technical Forum Archive 23 08-29-2000 05:28 PM

All times are GMT -4. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.