Welcome to the North American Subaru Impreza Owners Club Monday December 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-29-2007, 07:10 PM   #1
Chiefin27
Scooby Newbie
 
Member#: 158682
Join Date: Sep 2007
Default Having trouble installing HID's

pretty much ive been looking at it for the last 2 hours and am still at step one. Ive searched around, but havent really found anything to really help me. If anyone could run me through the procedure, ill buy you some beers.
* Registered users of the site do not see these ads.
Chiefin27 is offline   Reply With Quote
Old 09-29-2007, 07:38 PM   #2
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

hmmm.

model year of car and type of hid kit would def help out anyone attempting to help.
v8eaterWRX is offline   Reply With Quote
Old 09-29-2007, 07:49 PM   #3
Chiefin27
Scooby Newbie
 
Member#: 158682
Join Date: Sep 2007
Default

the car is a 2006 WRX TR...and the hid kit is the xantec i believe
Chiefin27 is offline   Reply With Quote
Old 09-29-2007, 07:53 PM   #4
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

remember to disconnect your drl's
racingfish is offline   Reply With Quote
Old 09-29-2007, 08:56 PM   #5
06AZREX
Scooby Specialist
 
Member#: 132244
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Everett
Vehicle:
2006 OBP WRX
2006 BMW 325i

Default

kinda hard to explain on the here man. guess you could call me and i could walk you through it. check your pm
06AZREX is offline   Reply With Quote
Old 09-29-2007, 09:11 PM   #6
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

usually the HID kit will have a 12v and a ground wire.. So you need to cut the low beam harness (or tap into it) and one of the wires will produce 12v when the lights are on.. you tap that into your hidkit 12v and ground the other wire to the fender. cap off the other wire in the harness you dont use
szeny is offline   Reply With Quote
Old 09-29-2007, 09:12 PM   #7
Hazmat
Scooby Specialist
 
Member#: 94803
Join Date: Aug 2005
Location: AZ HEAT FTW
Default

I would recommend you to mount the ballast underneath the headlights.
Go search the instructions on how to take it out using the from the darkenend headlight threads, and from then on strap on ballast in the open space and everything should become more clear.
Hazmat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone else have trouble installing Whiteline Rear Subframe Bolts? EarlQHan Brakes, Steering & Suspension 12 11-13-2008 02:19 AM
Having trouble installing STi corner bumper splitters TheBaumer Interior & Exterior Modification 19 04-19-2006 08:07 PM
I'm having trouble installing a Walbro fuel pump, need help. porque Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 17 01-14-2006 11:54 PM
having trouble installing up pipe I3oostedScooby Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 07-07-2005 10:16 AM
Anyone have directions installing WRX JDM lights with HID's in them? samwY Interior & Exterior Modification 2 01-08-2004 03:22 AM


All times are GMT -4. The time now is 01:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.