Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-06-2007, 04:48 AM   #1
Loomin
Scooby Guru
 
Member#: 118113
Join Date: Jun 2006
Chapter/Region: VIC
Vehicle:
98' Stagea 260RS
Autech Ver.

Default Oil pressure problems

the issue:

periodically, i need to top up the oil with half a litre of oil. (about every 2 weeks). the engine barely smokes but i do notice a little bit here and there. the other thing is HOW i notice the oil problem. while sitting at a light, my oil pressure gauge bounces between 0.5-3 kg/cm3. (metric sorry)
and when it dips to 0.5 the oil light comes on!! this is clearly a bad thing so i really have no idea whats going on. the light flashes on and off as the gauge goes up and down, but if i give it a blip of the gas and hit it to 3000rpm or so, everything returns to normal

currently running Royal Purple 10w30 w/ fram filter

heres what ive checked:

1)Not the headgasket- no oil in the coolant etc etc
2)oil level drops quite frequently, enough to need to be topped up bi-weekly
3)no visible leaks on the engine at all. (oil pan is in tact, seals seem fine to me, nice and dry)


with a level drop this drastic, you think there would be huge clouds of blue pouring out the exhaust.

Any ideas? could the oil pump be the issue?

* Registered users of the site do not see these ads.
Loomin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 WRX Oil Pressure Problem. HVAAJA21 Newbies & FAQs 5 12-06-2011 06:13 PM
Oil Pressure problem has me stumped, help! St0k3d Factory 2.5L Turbo Powertrain 2 11-18-2008 12:24 AM
oil pressure problem please help me. turboboxer80 'Old School' Subaru Forum 10 06-21-2008 09:16 PM
oil pressure problems 06njsti Factory 2.5L Turbo Powertrain 10 01-03-2008 03:50 PM
Garrett turbo oil pressure problems... 8Complex Normally Aspirated with bolt-on Forced Induction Powertrain 14 07-29-2003 02:28 PM


All times are GMT -4. The time now is 05:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.