Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-12-2007, 12:14 AM   #1
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default rattle noise as boost comes on

Does anyone else have a slightly annoying rattle (turbo heat sheild?) at around 3k to 4k when accelerating? wanted to ask before I mention it to dealer at next oil change...
* Registered users of the site do not see these ads.
dunc_b is offline   Reply With Quote
Old 10-12-2007, 12:51 AM   #2
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

What year / car? Fill out your profile a bit and help us out

... if it's an '07 STi... you need to talk to Travis. And stay off of WOT until you do.

Last edited by r0bman; 10-12-2007 at 12:56 AM.
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:57 AM   #3
sunnyniazi
Scooby Newbie
 
Member#: 136438
Join Date: Jan 2007
Chapter/Region: SWIC
Location: Arizona
Vehicle:
RIP: 2004 WRX STi
WRB/G, 322whp/330wtq

Default

Yeah heat shield will do that or if you have a heat shield for your intake, when I had a heat shield for my intake (K&N typhoon) it made that rattling sound I tightened up the bolts and it went away, is your boost affected?
sunnyniazi is offline   Reply With Quote
Old 10-12-2007, 11:16 AM   #4
boostedsti06
Scooby Newbie
 
Member#: 128677
Join Date: Oct 2006
Chapter/Region: SWIC
Location: arizona
Vehicle:
2006 Subaru WRX STI
obsidian black pearl

Default

this happened to me after i got my downpipe put on cause they cut the stock heat shield so there werent as many mounting points. that was part of it and the o2 sensor wasnt screwed in all the way either
boostedsti06 is offline   Reply With Quote
Old 10-12-2007, 12:50 PM   #5
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

It's an 06 stock STI, boost doesn't seem to be effected - it's juddered a tiny bit once or twice but that was when it was extremely hot outside too...
dunc_b is offline   Reply With Quote
Old 10-12-2007, 12:57 PM   #6
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

OK, if it's an '06 then my previous comment is void. Does it happen no matter what at that engine speed (i.e. doesn't matter if you're flooring it or not, etc)? If so, then you've got a loose heat shield... there's only, oh, about 4 of 'em... good luck figuring out which one it is

If you're in the West Valley, you can swing by my place this weekend and we'll put it up on ramps (as long as it's not lowered) and I'll try to tighten them all down for you.

... And don't take your car to the dealer for an oil change It's the easiest thing in the world, takes all of 30 minutes (and 25 of that is waiting for the oil to drain).
r0bman is offline   Reply With Quote
Old 10-12-2007, 12:57 PM   #7
02WRX06STI
Scooby Newbie
 
Member#: 115023
Join Date: May 2006
Chapter/Region: SWIC
Location: peoria,az
Vehicle:
2006 STI
Aspen White

Default

possible detnation????

cuz i also had this problem, and took it in they told me it was my splash shield, even though it did it only when it was hot out. i would say try mixing gas to get at least a 93 octane rating, that is what i did and it stopped till i filled up with 91 again...
02WRX06STI is offline   Reply With Quote
Old 10-12-2007, 12:59 PM   #8
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

Quote:
Originally Posted by 02WRX06STI View Post
possible detnation????
That's where I was going with my first post... could still possibly be it, but not having the lovely '07 ECU tune is a plus in his case.
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:01 PM   #9
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

It only does it under boost/with my foot down - it used to be sporadically but now it's all the time I'm flooring it...

it could be some turbo system component I'm not used to hearing...
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:03 PM   #10
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

... uh oh. If you're only hearing it at WOT then it could possibly be detonation. Your car is completely stock?
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:05 PM   #11
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

Yeap... What WOT?
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:07 PM   #12
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

WOT = Wide Open Throttle. Gas pedal floored.
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:10 PM   #13
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

d'uh... it does sound like something is literally rattling loose between 3k & 4k then it goes away... I'll get the girl to rev it up this weekend and see if it does it when the hood's open...
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:11 PM   #14
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

I'm in north central phoenix - Where are you on the west side robman?
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:15 PM   #15
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

Quote:
Originally Posted by dunc_b View Post
d'uh... it does sound like something is literally rattling loose between 3k & 4k then it goes away... I'll get the girl to rev it up this weekend and see if it does it when the hood's open...
If it does it w/ the hood open, then I'd say its a heat shield. You're not going to get detonation in Neutral without boost building unless there is something really wrong.

I'm in Goodyear, right off the 10. Let me know if you need any help this weekend, I'll be around.
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:30 PM   #16
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

are you near avondale subaru?
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:32 PM   #17
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

Quote:
Originally Posted by dunc_b View Post
are you near avondale subaru?
5 Exits past it, yeah.
r0bman is offline   Reply With Quote
Old 10-12-2007, 01:34 PM   #18
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

are you in the dealer then Rob? What do you do there?
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:35 PM   #19
dunc_b
Scooby Newbie
 
Member#: 154343
Join Date: Jul 2007
Chapter/Region: SWIC
Default

I might have my boy this weekend but if I can swing by I will...

d
dunc_b is offline   Reply With Quote
Old 10-12-2007, 01:39 PM   #20
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

Haha, no, I don't work there... I just have a garage, and $40 walmart ramps, and hundreds of hours of experience working on turbocharged Subaru exhausts I'm no expert, but it doesn't take much to figure out a heat shield, IF that's your problem.
r0bman is offline   Reply With Quote
Old 10-12-2007, 03:40 PM   #21
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

shoot me a pm and ill see if i can hook ya up
gormonk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rattle noise under boost... 4S-TURBO Factory 2.5L Turbo Powertrain 8 05-24-2007 02:03 PM
rattling noise when boosting WOT generalganja Newbies & FAQs 6 04-23-2007 09:12 PM
Boost coming on late, found bad upppipe gasket roybfr Factory 2.5L Turbo Powertrain 3 07-26-2006 12:11 AM
Boost coming on late? Mzacharski Factory 2.5L Turbo Powertrain 7 11-13-2005 08:28 PM
What's wrong? Boost coming on late. wrxlvr Factory 2.0L Turbo Powertrain 2 06-18-2003 01:57 PM


All times are GMT -4. The time now is 10:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.