Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-17-2007, 09:32 PM   #1
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default HELP!! Header install, now mysterious oil leak from turbo area!!

As title states... wherever it is, its dripping from something above the upipe.... anyone know where this oil leak is??? this happened to a friend as well....

anyone know where to check? how to check it? how to fix it?
* Registered users of the site do not see these ads.
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 09:37 PM   #2
renosubby
Scooby Specialist
 
Member#: 152576
Join Date: Jun 2007
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 STI 10.8@ 129
www.Mayhemtuning.com

Default

Oil drain from the turbo its located directly on the bottom of the turbo and connects to a small black hose! pretty common to com un-done easily!
renosubby is offline   Reply With Quote
Old 10-17-2007, 09:43 PM   #3
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

anything running to the turbo is completely dry.... its leaking on the upipe a little after the 02 sensor going towards the turbo
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 10:02 PM   #4
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Hheeeelllppp!!!
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 10:15 PM   #5
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

my upipe is soaked...
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 10:34 PM   #6
boquag
Scooby Newbie
 
Member#: 133879
Join Date: Dec 2006
Location: cape cod
Vehicle:
2003 impreza wrx
platinum silver

Default

check the back side of the valve cover gasket...
boquag is offline   Reply With Quote
Old 10-17-2007, 10:41 PM   #7
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Quote:
Originally Posted by boquag View Post
check the back side of the valve cover gasket...
has installing a header caused a leak here before?
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 10:47 PM   #8
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

i can kinda see it spraying from somewhere if i look down by the turbo....
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 10:50 PM   #9
boquag
Scooby Newbie
 
Member#: 133879
Join Date: Dec 2006
Location: cape cod
Vehicle:
2003 impreza wrx
platinum silver

Default

no, but this side is under higher temps and is more apt to harden up a gasket espcially now that theres a header with no heat shield, the only other oil source in the area is the oil outlet on the bottom of the turbo wich has a cheesy ring clamp holding it on from the factory...
boquag is offline   Reply With Quote
Old 10-17-2007, 11:04 PM   #10
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Quote:
Originally Posted by boquag View Post
no, but this side is under higher temps and is more apt to harden up a gasket espcially now that theres a header with no heat shield, the only other oil source in the area is the oil outlet on the bottom of the turbo wich has a cheesy ring clamp holding it on from the factory...
it might be by the valve cover
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 11:12 PM   #11
a6n6d6y
Scooby Specialist
 
Member#: 123347
Join Date: Aug 2006
Chapter/Region: NWIC
Location: SEATTLE
Vehicle:
1993 POS
burgandy legacy

Default

maybe turbo oil feed line got shifted during header install ,oil leaking from connection to head then running down the head to that area
a6n6d6y is offline   Reply With Quote
Old 10-17-2007, 11:24 PM   #12
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Quote:
Originally Posted by a6n6d6y View Post
maybe turbo oil feed line got shifted during header install ,oil leaking from connection to head then running down the head to that area
thats a possibility... whatever was spraying oil was on the bottom and somewhere out of sight
All4bSpinnin is offline   Reply With Quote
Old 10-17-2007, 11:52 PM   #13
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

its gotta be something on the oil return line....
All4bSpinnin is offline   Reply With Quote
Old 10-18-2007, 03:37 PM   #14
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

dave..
check the hard line at the back of the head.
then check the half moon...
another person in jax did the same thing when
he tried to install the one piece header by himself.
and if you did this you sir are a dork..
jaxscuby is offline   Reply With Quote
Old 10-18-2007, 05:50 PM   #15
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Quote:
Originally Posted by jaxscuby View Post
dave..
check the hard line at the back of the head.
then check the half moon...
another person in jax did the same thing when
he tried to install the one piece header by himself.
and if you did this you sir are a dork..
lol thanks ben... i'll check it asap

do i have to pull the header back out to get to this line or is it easier to pull the turbo?
All4bSpinnin is offline   Reply With Quote
Old 10-18-2007, 06:17 PM   #16
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

pull the turbo.
this way you will be able to see if the turbo oil drain line or
hard oil line on the back of the head is the culprit..
jaxscuby is offline   Reply With Quote
Old 10-18-2007, 06:25 PM   #17
subaru222
Scooby Guru
 
Member#: 92967
Join Date: Aug 2005
Chapter/Region: SCIC
Location: socal
Vehicle:
2009 wrx hatch
dark grey metallic

Default

ya check that line
subaru222 is offline   Reply With Quote
Old 10-18-2007, 10:19 PM   #18
ur2s2pid
Scooby Newbie
 
Member#: 142104
Join Date: Feb 2007
Default

Quote:
Originally Posted by All4bSpinnin View Post
has installing a header caused a leak here before?
I don't think installing a header has caused a leak there before but thats not to say that something else didn't happen and now the valve cover is leaking.
ur2s2pid is offline   Reply With Quote
Old 10-19-2007, 09:42 PM   #19
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Jaxscuby FTW!!

ben, you called it... the halfmoon on the bottom side of the head was pushed a little into the motor causing an oil leak...

trying to sneak the half moon out so i can put it back in with some silicone....

half moons ftl...
All4bSpinnin is offline   Reply With Quote
Old 10-20-2007, 08:58 AM   #20
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

PWN3D told you so..

Quote:
Originally Posted by jaxscuby View Post
dave..
check the hard line at the back of the head.
then check the half moon...
another person in jax did the same thing when
he tried to install the one piece header by himself.
and if you did this you sir are a dork..
would not have been a problem if you had jacked the passenger
side engine mount. this would have given you enough clearance..

dork...
jaxscuby is offline   Reply With Quote
Old 10-20-2007, 07:09 PM   #21
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

welllllll.... i had done this every time but this time i cut a corner and got burned nasty... we were jacking up the entire motor... but this time we only did one side
All4bSpinnin is offline   Reply With Quote
Old 10-25-2007, 04:22 PM   #22
nperkins
Scooby Specialist
 
Member#: 135812
Join Date: Dec 2006
Chapter/Region: NESIC
Location: Griswold, CT
Vehicle:
90 Miata
04 Evo Rally Car

Default

Had the same thing doing my header... Removed the valve cover & replaced the Cam Seal. Took 30 minutes.
nperkins is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil leaking from turbo due to excessive crankcase pressure? HELP iRace559 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 30 08-21-2009 09:29 AM
oil leaking from turbo!! 07SWPSTi Newbies & FAQs 5 04-12-2008 07:44 PM
oil leak from turbo vvafivv Southern California Impreza Club Forum -- SCIC 0 10-03-2007 04:08 AM
How much oil leak from turbo is normal? VSM EXtasy Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-20-2003 12:52 PM
Antifreeze leaking from turbo area Wrxified Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 10-10-2002 10:12 PM


All times are GMT -4. The time now is 11:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.