Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-28-2007, 09:02 AM   #1
jester696
Scooby Newbie
 
Member#: 135952
Join Date: Dec 2006
Chapter/Region: Tri-State
Location: New York
Vehicle:
04 XTi

Default Rear defroster causing radio static?

So I just got my 07' WRX and went for a little drive. My back window started to fog so I naturally put the rear defroster on. As soon as I did this, my radio went to static??? All stations on FM go to static when I turn on the rear defroster. Have no idea what is going on. Please help if anyone has any idea what it is.

~J
* Registered users of the site do not see these ads.
jester696 is offline   Reply With Quote
Old 10-28-2007, 12:13 PM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

you probably have a break in the rear defogger grid are all of the lines working? Classic symptoms.

auto parts stores sell repair kits for the rear defogger grid, but since its still under warranty, assuming you have under 36k, take it in to the dealer.
munkis is offline   Reply With Quote
Old 10-28-2007, 12:40 PM   #3
jester696
Scooby Newbie
 
Member#: 135952
Join Date: Dec 2006
Chapter/Region: Tri-State
Location: New York
Vehicle:
04 XTi

Default

Yeah...I just plan on taking it back to the dealer. I just wanted to make sure it wasn't a simple fix. Thanks
jester696 is offline   Reply With Quote
Old 10-29-2007, 09:27 AM   #4
traser2g
Scooby Newbie
 
Member#: 152470
Join Date: Jun 2007
Chapter/Region: NESIC
Location: Western MA
Vehicle:
2004 VF43 STI
WRB

Default

this is so common of an issue with so many cars. when i was a mobile installer I always checked to see if the car had this problem w/ the factory radio before swapping it out with a new one. probably 1 out of 10 cars lost a fair amount of reception with rear defrost.
traser2g is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Defroster causing radio problems jrank3792 Car Audio, Video & Security 11 03-19-2010 07:23 AM
Rear defroster grid messed up - causing FM static boston_errol Car Audio, Video & Security 1 11-17-2009 03:06 PM
gauge install caused rear defroster to stay on FeD_bballGT Electrical & Lighting 5 10-06-2007 02:29 PM
Radio goes out when rear defrost is on? ('05 LGT) EarlQHan Car Audio, Video & Security 4 11-08-2005 02:52 AM
Rear defrost kills my FM radio reception adam555 Impreza Forum 5 11-05-2003 02:59 PM


All times are GMT -4. The time now is 01:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.