Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-29-2007, 01:10 AM   #1
pilotstephen
Scooby Newbie
 
Member#: 155145
Join Date: Jul 2007
Chapter/Region: SCIC
Location: Cypress, California
Vehicle:
2004 WRX STI
Bruised

Default Airbag Computer Reset Question

I have two airbag ECUs for an 2004 STI. (both tested on the same car)

On the first I have fault codes:
55 41 42 11 62 65

On the second I have fault codes:
22 11 62 61 12 15

I have replaced the airbags and pretensioners.
Ive tried to reset the codes on each by grounding pin #2 on the diagnostic harness according to the shop manual, but the error codes remain. Im using the fault code reset procedure (Called 'Clear Memory Mode' on page AB-26) Has anyone been able to reset the codes before?

Also, there is a green male and matching female connector next to the SRS diagnostic harness. Can someone tell me what it is for?
* Registered users of the site do not see these ads.
pilotstephen is offline   Reply With Quote
Old 10-29-2007, 07:37 AM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

...leave the green connectors unplugged---they are for ECU diagnostic mode ONLY and NOT to be connected for normal operation.

I would say that either someone f000ked with the SRS wiring and screwed ya on the other.....and/or....airbag controllers are a ONE TIME USE unit and are garbage and can NOT be 're-set' after any airbag deployment of any kind and must be replaced with a NEW unit.
Uncle Scotty is offline   Reply With Quote
Old 10-29-2007, 08:09 AM   #3
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Scotty is correct, once the module records a deployment it must be replaced. Deployment codes can't be reset.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer resetting itself??? Stroke Off-Topic 21 08-24-2006 12:50 PM
Computer reset BMXspears Factory 2.0L Turbo Powertrain 23 01-31-2006 05:59 PM
something wrong with your computer? reset it. alacrity024 Off-Topic 13 04-08-2005 04:45 PM
Zex nitrous computer reset Kevin Thomas Normally Aspirated Powertrain 2 04-16-2002 02:47 AM
Challenge: CEL/computer reset "button" couldnthinkaone Normally Aspirated Powertrain 14 03-21-2002 04:04 PM


All times are GMT -4. The time now is 09:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.