Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-05-2007, 02:50 PM   #1
illegal2.2
Scooby Specialist
 
Member#: 58329
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: MN
Vehicle:
97 Legacy GT
Rio Red

Default brake light issues? 97 gt

like title says, for the last 2 weeks now, my brake light is consistantly turned on even when the e-brake lever is down. i just checked the e-brake shoes this weekend and found them to be at least 75% +/- meat left compared to the new ones purchased. rear brake pads are fine at least 50%+. my buddy also noted that my e-brake line might be streched and that's why my e-brake handle goes up to like 4-5 notches(yes i tighten the bolt). so does anyone know what might trigger the brake light? thx

choung
* Registered users of the site do not see these ads.
illegal2.2 is offline   Reply With Quote
Old 11-05-2007, 03:00 PM   #2
RM_2
Scooby Specialist
 
Member#: 163058
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Central Indiana
Vehicle:
2011 Impreza WRX SWP
2001 Legacy L WGM

Default

RM_2 is offline   Reply With Quote
Old 11-05-2007, 03:11 PM   #3
jey
Scooby Specialist
 
Member#: 32503
Join Date: Feb 2003
Chapter/Region: TXIC
Location: Johnson City, TX
Vehicle:
2011 Tribeca
1995 Legacy Wagon

Default

Yeah, I assume you've checked your brake fluid level?
jey is offline   Reply With Quote
Old 11-05-2007, 04:36 PM   #4
legacy1907
Scooby Specialist
 
Member#: 94024
Join Date: Aug 2005
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
05 WRX CGM
95 YJ Flat black

Default

happens to me when its cold out, but usually when the car warms up it goes away
legacy1907 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake light on 97 Legacy InsaneJester17 Newbies & FAQs 0 10-05-2008 10:51 AM
New member needs fog lights for 97 gt 2.5 hubble1953 Private 'Wanted' Classifieds 0 11-22-2006 02:43 AM
Brake light issues. japakazol Electrical & Lighting 2 09-16-2006 11:14 PM
1993 Legacy Brake Light issues pyropoptrt Electrical & Lighting 5 01-24-2005 01:56 AM
Emergency Brake Light Issues tiltedhugh Brakes, Steering & Suspension 8 04-07-2004 06:04 PM


All times are GMT -4. The time now is 12:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.