Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Commercial ECU Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2007, 10:20 PM   #1
CarterMarkham
Scooby Newbie
 
Member#: 79085
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Maine
Vehicle:
2011 Subaru WRX Lim
LRP

Question Can someone check my logs?

Here are my logs from my stock 08 LGT 5EAT. I'm mostly confused about the RPM's fluctuating a bit in the 3K and 4K range.


http://cartermarkham.homestead.com/f...110_115028.csv

http://cartermarkham.homestead.com/f...110_115324.csv
* Registered users of the site do not see these ads.
CarterMarkham is offline   Reply With Quote
Old 11-10-2007, 11:47 PM   #2
WeldingHank
Scooby Specialist
 
Member#: 98645
Join Date: Oct 2005
Chapter/Region: NESIC
Location: Lawrence,ma
Vehicle:
2002 WRX Wagon
PSM

Default

what concerns me the most, is how long the car stays in closed-loop. at your peak boost of 14psi and 3000RPMs, your car is still trying to maintain stoich A/F's. is there a reflash for the 08's yet? if there is, atleast clean-up that open/closed loop transition.
WeldingHank is offline   Reply With Quote
Old 11-11-2007, 01:06 AM   #3
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

I see what you mean, I think. Looks like 8 seconds from WOT till it starts dropping the AF ratio.
MasterKwan is offline   Reply With Quote
Old 11-11-2007, 10:29 AM   #4
CarterMarkham
Scooby Newbie
 
Member#: 79085
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Maine
Vehicle:
2011 Subaru WRX Lim
LRP

Default

There is a flash update for 2008 models, BUT only for manual transmissions. Doesnt make sense to me.


Ive been fighting with SOA for months now.
CarterMarkham is offline   Reply With Quote
Old 11-11-2007, 10:56 AM   #5
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

Hank's talking about an aftermarket flash I believe. That delay is designed in by Subaru.
MasterKwan is offline   Reply With Quote
Old 11-11-2007, 09:31 PM   #6
icslowmo
Scooby Newbie
 
Member#: 114667
Join Date: May 2006
Chapter/Region: SWIC
Location: Peoria, AZ
Vehicle:
00/5 Silver STi RS
FAT 40R kit w/ FMIC

Default

Quote:
Originally Posted by CarterMarkham View Post
Here are my logs from my stock 08 LGT 5EAT. I'm mostly confused about the RPM's fluctuating a bit in the 3K and 4K range.


http://cartermarkham.homestead.com/f...110_115028.csv

http://cartermarkham.homestead.com/f...110_115324.csv
That may be from pinging with the A/F ratio still above 14:1... Try higher octane and ecm reset and see if it smooths out.... Not sure why it's staying in closed loop for so long....
icslowmo is offline   Reply With Quote
Old 11-11-2007, 09:35 PM   #7
WeldingHank
Scooby Specialist
 
Member#: 98645
Join Date: Oct 2005
Chapter/Region: NESIC
Location: Lawrence,ma
Vehicle:
2002 WRX Wagon
PSM

Default

Quote:
Originally Posted by icslowmo View Post
That may be from pinging with the A/F ratio still above 14:1... Try higher octane and ecm reset and see if it smooths out.... Not sure why it's staying in closed loop for so long....
thats how subaru has tuned it from the factory. to try and get better emissions numbers.
WeldingHank is offline   Reply With Quote
Old 11-11-2007, 09:41 PM   #8
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

Yeah. I programmed it out of my 03 WRX. Apparently the newer the car, the worse the delay.
MasterKwan is offline   Reply With Quote
Old 11-12-2007, 08:50 AM   #9
CarterMarkham
Scooby Newbie
 
Member#: 79085
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Maine
Vehicle:
2011 Subaru WRX Lim
LRP

Default

So you think Subaru decided to suffer reliability to improve emissions? I cant have a hunk of junk I cant use under WOT. As far as I know COBB doesnt have an access port yet, not that I would want to do that. I'm not one to risk denying my warranty. I would perfer a SOA fix right now, atleast until the warranty is up.
CarterMarkham is offline   Reply With Quote
Old 11-12-2007, 09:35 AM   #10
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

This isn't a new issue. It's been known since 04-05? There won't be a fix from SOA. Pretty sure this change was mandated by the EPA. My guess is that Subaru's willing to eat the cost of motor replacements for the rare people who beat on their cars hard enough to pop the motors.
MasterKwan is offline   Reply With Quote
Old 11-12-2007, 11:29 AM   #11
CarterMarkham
Scooby Newbie
 
Member#: 79085
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Maine
Vehicle:
2011 Subaru WRX Lim
LRP

Default

Quote:
Originally Posted by MasterKwan View Post
This isn't a new issue. It's been known since 04-05? There won't be a fix from SOA. Pretty sure this change was mandated by the EPA. My guess is that Subaru's willing to eat the cost of motor replacements for the rare people who beat on their cars hard enough to pop the motors.

I find it very unsettling. I have been in contact with a couple of Subaru dealers and other Used Subaru specific dealers. I have faxed the log to the dealership I usually go to to see what they have to say, and I have an appointment with another dealership Monday. They will have the car all day. I know you say that this is "normal" according to SOA, but in reality its not normal, and its not smart. With my luck the engine will blow at 60,001 miles...
CarterMarkham is offline   Reply With Quote
Old 11-12-2007, 12:19 PM   #12
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

It's not clear to me what you expect. The dealers can't do anything about it. They can install new flashes from Subaru but, if the federal government mandates this delay before going into open loop do you think Subaru's going to fight with them about it?

If you want to save your motor, don't drive it hard and hope someone comes out with an aftermarket flash that turns off the delay. Either that or sell the car and buy something NA. How often do you need to go wide open throttle anyway? For me, when I'm on the track it's 50%+ of the time. On the street, it's never unless I'm playing around.

I'm sure that's how Subaru looks at it too. 4% of the people who buy the LGT beat on it, the other 96% won't. So, at worst they're looking at replacing some motors on the 4% who beat on the cars. What costs Subaru more, replacing some motors or fixing the issue? I'm sure they've done the math...
MasterKwan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can someone check out these logs. davis10 Open Source Reflashes 12 05-25-2010 10:12 PM
Can someone check this log? ezil71 AccessPort 0 05-08-2010 11:08 AM
Can someone check my learning view please? jexeffectz Open Source Reflashes 2 03-16-2010 12:24 PM
Can someone disect my log? Jaredm83 Commercial ECU Reflashes 20 01-04-2007 11:40 PM
can someone check my coil pack wiring for me? rabbitnutz Subaru Conversions 7 01-24-2006 10:26 PM


All times are GMT -4. The time now is 09:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.