Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-13-2007, 03:13 PM   #1
Blackmojo
Scooby Newbie
 
Member#: 137587
Join Date: Jan 2007
Chapter/Region: NWIC
Location: PNW
Vehicle:
2004 WRX Sti
JBP

Default Spark Plug Issue

Ok, so here is a wierd one...

I am the proud second owner of a 2004 wrx sti. Bought the car with 10k miles, changed plugs at 30k service last yr (car actually had closer to 35k by the time I got around to the service). The plugs I got from the dealership were NGK PFR6G SOA part number 22401aa530. Went in yesterday same dealership got NGK ILFR6B SOA part number 22401aa630.

Now when I did my service at 35K I compared plugs and proceeded. Meaning I was paying attention to the fact that the plugs were indeed correct and the same.

How is it that my car came from Subaru with these plugs, which I have been told are for the 2.0l WRX motor? And has anyone else had this issue? Will I have any issues putting the newer, longer plugs in my car?

I do still have the original plugs, at home (currently at my shop), but seriously what gives here?
* Registered users of the site do not see these ads.
Blackmojo is offline   Reply With Quote
Old 11-13-2007, 09:55 PM   #2
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

sti plugs are physically longer.
so there would no way your plugs were for a 2.0l motor.
unless the previous owner did something dumb.
part numbers 22401xxxxx are for 04 sti
P is platinum, I is iridum
jaxscuby is offline   Reply With Quote
Old 11-14-2007, 08:57 PM   #3
Blackmojo
Scooby Newbie
 
Member#: 137587
Join Date: Jan 2007
Chapter/Region: NWIC
Location: PNW
Vehicle:
2004 WRX Sti
JBP

Default

I'm telling you, yes they were. The plugs I have been running for the last 45k were the exact same plugs (NGK PFR6G). The plugs I put in yesterday were 3/8" longer and were the NGK ILFR6B. I have all my parts reciepts and as noted above were the part numbers for the two different plug sets.

Anyway the car hasn't changed the way its running, other than its a little snappier (probably just the butt dyno).

Still curious if anyone else has run into this?
Blackmojo is offline   Reply With Quote
Old 11-14-2007, 10:21 PM   #4
Clayton
Scooby Specialist
 
Member#: 121184
Join Date: Jul 2006
Chapter/Region: RMIC
Location: Fountain, Co
Vehicle:
2004 WRX
WRB

Default

It sounds like you were running 2.0L plugs in it previously. Since STI plugs are physically longer than the 2.0l plugs it seems like you finally put the right plugs in there haha...
Clayton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
spark plug issue subie9022 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 07-01-2009 11:30 PM
Spark plug issue traffic80 Service & Maintenance 2 05-20-2009 02:53 PM
spark plug warranty issue biohazard06 Warranty Issues & SOA Problems 9 09-22-2007 04:21 PM
Having Issues With Spark Plugs cruzinWRX2 Service & Maintenance 3 11-02-2006 10:53 PM
Spark Plugs, CEL's, Misfires, and UTEC issues JayGold Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 26 04-16-2003 02:35 PM


All times are GMT -4. The time now is 02:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.