Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 08-04-2006, 12:42 AM   #1
talon95tsi
Scooby Newbie
 
Member#: 73751
Join Date: Nov 2004
Chapter/Region: NESIC
Location: Natick, MA
Vehicle:
2002 wrx
wrb

Default Broken Rota Subzero :( (large pics)

so i had a strange noise coming from my left front wheel, especially when turning right. it sounded like a mix between the whump...whump...whump of a bad wheel bearing and the click...click...click of a bad cv joint. after inspecting the cv joint boot, i ruled that out. took off the wheel and examined it, and there was the culprit. right where one of the spokes of my subzero meets the lip of the rim, it was cracked clean through. these rims are at least 5 years old, maybe even older so i am not really mad, it just sucks i have to find new wheels now. anybody selling a set of 17's for cheap without tires?





* Registered users of the site do not see these ads.
talon95tsi is offline  
Old 08-04-2006, 12:52 AM   #2
import111
Scooby Specialist
 
Member#: 24447
Join Date: Sep 2002
Chapter/Region: SWIC
Location: Tucson, Arizona
Vehicle:
2010 Evo GSR
GG

Default

Not the 1st time I have seen a Rota wheel break. That sucks though man.
import111 is offline  
Old 08-04-2006, 01:00 AM   #3
Dynobyte
Scooby Specialist
 
Member#: 1636
Join Date: Jun 2000
Chapter/Region: SCIC
Location: los angeles
Vehicle:
1994 94L->RHD V5 STi
Grigio Silverstone

Default

yikes
Dynobyte is offline  
Old 08-04-2006, 01:42 AM   #4
kennyvb
Scooby Guru
 
Member#: 70234
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: NYC
Vehicle:
MY86 BMW E30 325
SCIC/NWIC tranplant (-_-)

Default

I hear Rota's good at replacing wheels
kennyvb is offline  
Old 08-04-2006, 02:53 AM   #5
X4 SRT
Scooby Newbie
 
Member#: 40636
Join Date: Jul 2003
Location: Las Vegas
Vehicle:
2001 2.5 RS Coupe
Silver

Default

That sucks man. You probably got them around the time that bad batch of subzeros were
floating around. They were breaking like crazy. Rota replaced every single wheel without any complaints. I would look into that first, because if it's one of those, then I would think they might replace them for free...Haven't seen any problems from rota wheels since the problem with the subzeros, so if I were you I wouldn't worry about buying another set if you have to.
X4 SRT is offline  
Old 08-04-2006, 03:44 AM   #6
Kostamojen
Scooby Guru
 
Member#: 2272
Join Date: Sep 2000
Chapter/Region: BAIC
Location: haha XD
Vehicle:
2013 Subaru 599 :P
Galaxy Blue Sexy

Default

5 years? Ya, that was probably the problem ones like X4 stated.
Kostamojen is offline  
Old 08-04-2006, 07:05 AM   #7
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by Kostamojen
5 years? Ya, that was probably the problem ones like X4 stated.
^^^^yep.....
Uncle Scotty is offline  
Old 08-06-2006, 07:21 PM   #8
talon95tsi
Scooby Newbie
 
Member#: 73751
Join Date: Nov 2004
Chapter/Region: NESIC
Location: Natick, MA
Vehicle:
2002 wrx
wrb

Default

so what would you guys suggest i do? i know i should send an email to rota, should i sound angry or just tell them i have heard about the bad batch? has anyone dealt with rota about this specific problem? if so, any resolutions?

benjamin
talon95tsi is offline  
Old 08-06-2006, 08:15 PM   #9
|Rev|
Scooby Specialist
 
Member#: 100651
Join Date: Nov 2005
Chapter/Region: RMIC
Location: Longmont, CO
Vehicle:
2010 STI
OBP

Default

I've delt with Rota before and they are a good company, I wouldn't sound angry unless you really are angry, if they don't comply then sound angry lol.. But at first just tell them what is happening.
|Rev| is offline  
Old 08-07-2006, 01:50 AM   #10
cgmwrx05
Scooby Newbie
 
Member#: 116506
Join Date: Jun 2006
Vehicle:
05 wrx
cgm

Default

Contact Rota. Ask for Kim Bong. He helped me out with my old Subzeros and replaced each broken wheel. It looks like you have the gunmetal color, I don't think they produce that without the polished lip anymore....I could be wrong. You did get the bad batch of wheels that were recalled. Just provide Rota with some numbers from each rim and they'll help you out. Good Luck
cgmwrx05 is offline  
Old 08-07-2006, 10:00 PM   #11
mrez
Scooby Newbie
 
Member#: 117656
Join Date: Jun 2006
Location: NB, MA
Vehicle:
04 sti
white

Default

wow...that hurts!! good luck with that.
mrez is offline  
Old 08-08-2006, 05:30 PM   #12
teiva-boy
Scooby Guru
 
Member#: 22825
Join Date: Aug 2002
Chapter/Region: NWIC
Location: Seattle, WA
Default

As other have mentioned, there was an initial first batch of wheels that were more prone to cracking then subsequent batches. about 5 yrs old seems about the right time.

Rota was proactive and listed a set of numbers on the rim for those that would qualify. They were awesome in doing what was right for their customers.
teiva-boy is offline  
Old 08-08-2006, 09:41 PM   #13
mav1c
Hoodbridge!
Moderator
 
Member#: 560
Join Date: Nov 1999
Chapter/Region: MAIC
Location: Woodbridge, VA
Vehicle:
2006 STi, '11 A4
Crystal Gray, Silver

Default

Definitely contact Rota. I had a set from the "bad batch" and they were replaced. They asked to have that I send the old wheels back (they payed shipping).

Never had a problem since.
mav1c is offline  
Old 08-08-2006, 09:58 PM   #14
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

if they would send me a set of 17x8's in 5x100, black or hyperblack with a polished lip, id be REAL happy ta test them for any issue and report back, here, with the results
Uncle Scotty is offline  
Old 08-08-2006, 10:21 PM   #15
talon95tsi
Scooby Newbie
 
Member#: 73751
Join Date: Nov 2004
Chapter/Region: NESIC
Location: Natick, MA
Vehicle:
2002 wrx
wrb

Default

I am currently in an email exchange with Kim directly from Rota and Suby_Dude also offered to help out so it looks like I'm in good hands! I'll keep you updated on the outcome.

Benjamin
talon95tsi is offline  
Old 11-14-2007, 06:13 PM   #16
Supraru gt
Scooby Newbie
 
Member#: 143270
Join Date: Mar 2007
Chapter/Region: SCIC
Location: LA area
Vehicle:
00 too many
cars

Default

be glad it didn't break while you were driving like kevin's did
Supraru gt is offline  
Old 11-14-2007, 06:30 PM   #17
Crawdads
Scooby Specialist
 
Member#: 30907
Join Date: Dec 2002
Chapter/Region: SWIC
Location: Cat Keyboard Cat
Vehicle:
SWP GDB-G

Default

Quote:
Originally Posted by Supraru gt View Post
be glad it didn't break while you were driving like kevin's did
Why did you bump this thread just to post that?
Crawdads is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Rota Subzeros *pics included* getek20 Tire & Wheel 25 04-25-2005 11:28 PM
Philly's Nite Out(Last Nites Meet LARGE pics) Accurit Tri-State Area Forum 5 05-13-2001 07:50 PM
('93-'01) Article on Jun Sti (warning, large pics) Tuning Factory Inc. Impreza Forum 24 05-02-2001 11:46 AM
('93-'01) Article on Zerosports Sti (warning, large pics) Tuning Factory Inc. Impreza Forum 1 04-30-2001 05:02 PM
Updated pics of my sedan (rather large pics) Marcin General Forum Archive 14 03-15-2001 04:08 PM


All times are GMT -4. The time now is 06:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.