Welcome to the North American Subaru Impreza Owners Club Saturday May 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old Today, 04:10 PM   #1
_impreza_matt_fb20_
Scooby Newbie
 
Member#: 445519
Join Date: Apr 2016
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2014 Impreza Sport
Dark Grey

Default Tune or no?

Okay so I've heard mixed answers with this, but I just installed my Ram Cold Air Intake from HPS Performance, and does this require a tune or no? Someone help because if it does, then I will but I'm not sure.
* Registered users of the site do not see these ads.
_impreza_matt_fb20_ is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old Today, 05:13 PM   #2
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Just an intake, as long as it's set up correctly and didn't leave something like the MAF sensor off then you don't need a tune.
drpoop is offline   Reply With Quote
Old Today, 06:40 PM   #3
Andrew7887
Scooby Newbie
 
Member#: 417828
Join Date: Apr 2015
Chapter/Region: NESIC
Location: Warwick RI
Vehicle:
2014 Sport Prem. M/T
Satin White Pearl

Default

I had the same one in black. The instructions say you don't need a tune. I took mine off because I lost low end torque. I hope u have better luck with it than I did.
Andrew7887 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.