Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-28-2012, 04:15 PM   #5601
OgBL6
Scooby Newbie
 
Member#: 306368
Join Date: Jan 2012
Location: San Bernardino
Vehicle:
2011 Impreza 2.5i
DGM

Default


finally picked one up yesterday.
2011 2.5i sedan
8120 miles
DGM
5spd
OEM Subaru Rainguards

looking into lowering ASAP!!
then some wheels & exhaust

more pics coming soon.
* Registered users of the site do not see these ads.

Last edited by OgBL6; 06-28-2012 at 10:02 PM. Reason: Picture
OgBL6 is offline   Reply With Quote
Old 06-28-2012, 04:57 PM   #5602
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Did any of you clean your carb and fuel injectors? I heard you don't need to if your using top brand gas, but I feel I should be on the safe side
Navysesal is offline   Reply With Quote
Old 06-28-2012, 06:47 PM   #5603
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Nope, never.

Are you trying to cure the rough idle? because some of your recent posts have been about engine stuff to cure out the rough idle to me.
theoutbackdream is offline   Reply With Quote
Old 06-28-2012, 09:31 PM   #5604
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by theoutbackdream
Nope, never.

Are you trying to cure the rough idle? because some of your recent posts have been about engine stuff to cure out the rough idle to me.
Nah, it was more towards keeping my car in tip top shape and getting better fuel economy :P
But my cars fine with idling ever since I cleaned the Maf sensor

It's just my friend has recently had some problems with his car so I have been a little paranoid haha
Navysesal is offline   Reply With Quote
Old 06-28-2012, 10:42 PM   #5605
scoobymatt93
Scooby Newbie
 
Member#: 254115
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2009 Impreza 2.5i
Dark Grey Metallic

Default

FINALLY got some new wheels! My car's almost exactly where I want it. Rallisport UEL headers are on the way, Tsudo N1 is sitting in the garage, and coilivers are the last purchase on the list. She's coming along perfectly

scoobymatt93 is offline   Reply With Quote
Old 06-28-2012, 10:59 PM   #5606
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Navysesal View Post
Nah, it was more towards keeping my car in tip top shape and getting better fuel economy :P
But my cars fine with idling ever since I cleaned the Maf sensor

It's just my friend has recently had some problems with his car so I have been a little paranoid haha
ah no wonder

Nothing really helps fuel economy IMO, other than your mood and the weight in your car. I removed my spare tire + spare parts during weekdays during the school year since that took off a lot of weight (id say about 30-40lbs) and then that boosted my mpg 0.3 but i say its BS, since im thinking it would boost only 0.1mpg...
theoutbackdream is offline   Reply With Quote
Old 06-29-2012, 01:34 AM   #5607
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by theoutbackdream

ah no wonder

Nothing really helps fuel economy IMO, other than your mood and the weight in your car. I removed my spare tire + spare parts during weekdays during the school year since that took off a lot of weight (id say about 30-40lbs) and then that boosted my mpg 0.3 but i say its BS, since im thinking it would boost only 0.1mpg...
Lol yah I knoe, just giving myself false hope
Lol well .1 adds up ya know
Navysesal is offline   Reply With Quote
Old 06-29-2012, 02:41 AM   #5608
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Haha it does. Btw have you calculated your mpg? Seems to me like you should.. The one displayed on the dash is off IMO, and usually are.

I haven't though since mpg isn't such a worry for me at the moment.
theoutbackdream is offline   Reply With Quote
Old 06-29-2012, 03:43 AM   #5609
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by theoutbackdream
Haha it does. Btw have you calculated your mpg? Seems to me like you should.. The one displayed on the dash is off IMO, and usually are.

I haven't though since mpg isn't such a worry for me at the moment.
I'm getting around 24-25 I haven't checked in a while

EDIT: http://slikdial.com/index.html

i found this very interesting, anyone seen this before?

Last edited by Navysesal; 06-29-2012 at 03:18 PM.
Navysesal is offline   Reply With Quote
Old 06-29-2012, 06:21 PM   #5610
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by Navysesal View Post
Did any of you clean your carb and fuel injectors? I heard you don't need to if your using top brand gas, but I feel I should be on the safe side
I use one bottle of name brand ''complete fuel system treatment'' once a year with full tank of gas. I did that this year on my last tank, I got it at NAPA for about $7. Who knows if it helps, it's possible it does, and I thought I remembered seeing something about that in owners manual.

I run 87 octane 99% of the time. I see slight mileage increase with 89, but not much. Car runs absolutely perfect always.

We have no carburetor.. if that's what you meant by ''carb''.
BWX is offline   Reply With Quote
Old 06-29-2012, 07:18 PM   #5611
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

So today (about 10 minutes ago) I decided to completely FILL my gas tank (until the pump clicked) for the first time in about 6 months and when I went I turned the key to start my car it completely died (no lights on, nothing) so I popped my hood and then heard the door ding. Went to start the car and it didn't turn over at first but fired right up on the second try.
The clock reset as well as everything on my radio.


Any idea what the culprit could be and what I can do to make sure it doesn't happen again?
premier00000 is offline   Reply With Quote
Old 06-29-2012, 07:21 PM   #5612
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Your battery lose? I noticed my battery terminal became lose after awhile
theoutbackdream is offline   Reply With Quote
Old 06-29-2012, 07:57 PM   #5613
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Quote:
Originally Posted by theoutbackdream
Your battery lose? I noticed my battery terminal became lose after awhile
That was the first thing I checked. Everything was nice and tight.
premier00000 is offline   Reply With Quote
Old 06-29-2012, 08:36 PM   #5614
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by premier00000 View Post
That was the first thing I checked. Everything was nice and tight.
Check all ground wires on both ends.. to engine/ chassis/ body. Something is definitely loose, or maybe battery failing? ECU failing? Bizzare! Check all fuses and check all relays next. Do our cars have fusable links? I don't have repair manual yet.
BWX is offline   Reply With Quote
Old 06-29-2012, 08:53 PM   #5615
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Whatever it is seemed to correct itself when I opened the hood. I guess it's time for an Optima Battery
premier00000 is offline   Reply With Quote
Old 06-29-2012, 09:30 PM   #5616
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by premier00000 View Post
Whatever it is seemed to correct itself when I opened the hood. I guess it's time for an Optima Battery
My battery was still fine but I got a Yellowtop and I'm really happy with it. When coming to a stop at night and idling, like at a red light, especially when it's raining- when lights, defrost, wipers, stereo amp/ subwoofer etc. are running; you can really tell the difference. With stock battery, even when brand new, everything slows down, dims, and has less power. With Optima, it feels like I have three stock batteries hooked up.. you never get that dimming of lights at idle, and voltage sag.

I can run my stereo system without car running and not worry too. Car starts up with more power.. cranks faster. Yup, Optima battery is a great investment.


You might have other issues though.. that new battery may or may not fix.
BWX is offline   Reply With Quote
Old 06-29-2012, 09:51 PM   #5617
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Quote:
Originally Posted by BWX

My battery was still fine but I got a Yellowtop and I'm really happy with it. When coming to a stop at night and idling, like at a red light, especially when it's raining- when lights, defrost, wipers, stereo amp/ subwoofer etc. are running; you can really tell the difference. With stock battery, even when brand new, everything slows down, dims, and has less power. With Optima, it feels like I have three stock batteries hooked up.. you never get that dimming of lights at idle, and voltage sag.

I can run my stereo system without car running and not worry too. Car starts up with more power.. cranks faster. Yup, Optima battery is a great investment.

You might have other issues though.. that new battery may or may not fix.
I used to have a Red Top (that was in 3 different cars) that unfortunately stayed with the last one when I traded it in. And that thing would last thru 4 movies at the local drive in theater when the stock ones only lasted thru only 1 (wouldnt start after the 2nd)
premier00000 is offline   Reply With Quote
Old 06-29-2012, 10:12 PM   #5618
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Yeah I'm amazed at how much more power is in my Yellowtop. I'm into LED flashlights driven hard with Lithium batteries.. I know Optimas aren't lithium, but compared to the stock battery, it's like the difference between a nickel–metal hydride (NiMH) and lithium-ion (Li-ion) in a flashlight or drill. Great upgrade.
BWX is offline   Reply With Quote
Old 06-30-2012, 12:36 AM   #5619
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by BWX

I use one bottle of name brand ''complete fuel system treatment'' once a year with full tank of gas. I did that this year on my last tank, I got it at NAPA for about $7. Who knows if it helps, it's possible it does, and I thought I remembered seeing something about that in owners manual.

I run 87 octane 99% of the time. I see slight mileage increase with 89, but not much. Car runs absolutely perfect always.

We have no carburetor.. if that's what you meant by ''carb''.
Alright good to knoe
Navysesal is offline   Reply With Quote
Old 06-30-2012, 06:37 AM   #5620
bidaci
Scooby Newbie
 
Member#: 291519
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Suburban Boston
Vehicle:
2011 OBS
Black

Default

I posted this elsewhere but figured this would be the best spot to ask. Does an 08 Wrx axleback bolt up to the 2011 2.5?
bidaci is offline   Reply With Quote
Old 06-30-2012, 09:40 AM   #5621
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2009 Impreza 2.5i 5D
Sunlight Gold Opal

Default

Yes..
JourdanWithaU is offline   Reply With Quote
Old 06-30-2012, 09:48 AM   #5622
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Quote:
Originally Posted by JourdanWithaU
Yes..
Thank you. I was going to quote all the other questions and answers located through the rest of this thread.
premier00000 is offline   Reply With Quote
Old 06-30-2012, 11:32 AM   #5623
bidaci
Scooby Newbie
 
Member#: 291519
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Suburban Boston
Vehicle:
2011 OBS
Black

Default

Quote:
Originally Posted by JourdanWithaU
Yes..
Thank you. I spent hours last night searching this board, forum and Google and just couldn't find the answer on a axleback. Tons of info on catbacks.
bidaci is offline   Reply With Quote
Old 06-30-2012, 11:56 AM   #5624
Digital Dillon
Scooby Specialist
 
Member#: 288727
Join Date: Jul 2011
Chapter/Region: NESIC
Location: Sturbridge, MA
Vehicle:
2008 WRX premium
Obsidian Black Pearl

Default

Quote:
Originally Posted by bidaci

Thank you. I spent hours last night searching this board, forum and Google and just couldn't find the answer on a axleback. Tons of info on catbacks.
A lot of people are running the Nameless Performance axlebacks on their cars!
Digital Dillon is offline   Reply With Quote
Old 06-30-2012, 12:37 PM   #5625
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Just wondering, did that Yellow top help with any of the somewhat rough idle the imprezas have? because im noticing that the battery is fading away too during idles
theoutbackdream is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM


All times are GMT -4. The time now is 12:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.