Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-17-2012, 09:59 PM   #5801
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by BWX View Post
^ Yup.. It was a little (lot in front) more difficult to install... because of screw- hole interference. It worked out ok though. Had to drill one extra hole in front flaps and use longer hardware for one of the stock screws IIRC.
did you try turning your wheel in/out a little bit? I did the same thing and I dont recall it being very difficult
Yours are probably a lot more stiffer than mine are though
* Registered users of the site do not see these ads.
KartRacer3 is offline   Reply With Quote
Old 07-17-2012, 10:51 PM   #5802
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by KartRacer3 View Post
did you try turning your wheel in/out a little bit? I did the same thing and I dont recall it being very difficult
Yours are probably a lot more stiffer than mine are though
Yeah I actually took my wheels right off.

The hard part was drilling out the slot in the UR mudflap in the correct place, and then lining up the clips after going through the washer/ thick flap/ washer/ factory mud guard/ washer/ fender liner/ then the clip. It was extremely difficult with the center hole (the drilled out slot on the flap) just because the clip couldn't be held and the screw barely made it through. It was a lot harder on the passenger side for some reason too- just because of how everything lined up. The clip wouldn't stay put. It took many attempts. It was a real bitch, but once I drilled that extra hole in the flap, I was committed.
BWX is offline   Reply With Quote
Old 07-17-2012, 10:53 PM   #5803
woWRX
Scooby Specialist
 
Member#: 207901
Join Date: Apr 2009
Chapter/Region: South East
Vehicle:
2010 2.5i Prem
NBP

Default

BWX, can I get a rear shot and angle from rear shot from farther back if you could? I just got a NBP 2.5i and I don't know if I want flaps or not.
woWRX is offline   Reply With Quote
Old 07-17-2012, 11:34 PM   #5804
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by woWRX View Post
BWX, can I get a rear shot and angle from rear shot from farther back if you could? I just got a NBP 2.5i and I don't know if I want flaps or not.
A rear shot is a few posts back.. I have a shot from a little further back though.

I didn't think I wanted flaps for a long time (bought it new in '09), but got them a few months ago and I like the way they look, but I like their function even more!

(I'll make it large resolution)


I can take a better one sometime soon.


Oh and KartRacer3 --here's a pic of that center hole I was talking about..
BWX is offline   Reply With Quote
Old 07-17-2012, 11:47 PM   #5805
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Oh, and you can adjust the flaps in or out quite a bit too. I didn't have a lot of adjustment because I installed them with the stock guards on there, especially on front.. but if you don't have stock guards I think you could push the flaps in a lot more.
BWX is offline   Reply With Quote
Old 07-18-2012, 12:33 AM   #5806
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Why did you leave the stock guards on? Just wondering..
theoutbackdream is offline   Reply With Quote
Old 07-18-2012, 05:33 PM   #5807
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

so i found this while i was "working"
Navysesal is offline   Reply With Quote
Old 07-18-2012, 06:25 PM   #5808
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Navysesal View Post
so i found this while i was "working"
thats been in debate for awhile man but nice find

And even if you do get UEL's i believe you wont get the real boxer sound without the Turbo.

Last edited by theoutbackdream; 07-18-2012 at 06:36 PM.
theoutbackdream is offline   Reply With Quote
Old 07-18-2012, 06:30 PM   #5809
subi2.5i
Scooby Specialist
 
Member#: 236778
Join Date: Jan 2010
Chapter/Region: Tri-State
Location: Rhinebeck,NY
Vehicle:
08 Impreza
SWP

Default

Quote:
Originally Posted by theoutbackdream

thats been in debate for awhile man

And even if you do get UEL's i believe you wont get the real boxer sound without the Turbo.
The turbo acts as the resonator to get that deep rumble.
subi2.5i is offline   Reply With Quote
Old 07-18-2012, 07:02 PM   #5810
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by subi2.5i View Post
The turbo acts as the resonator to get that deep rumble.
i thought the turbo also didnt give it that pure boxer rumble..? right?

I do understand that you do get that rumble, but the deep rumble and the raspy-ness arent there due to the lack of turbo.
theoutbackdream is offline   Reply With Quote
Old 07-18-2012, 07:02 PM   #5811
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

I have said UEL headers and a tsudo n1 street catback and you just about get that sound. If I can find my video I'll put it up
ozunadel is offline   Reply With Quote
Old 07-18-2012, 07:08 PM   #5812
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by ozunadel View Post
I have said UEL headers and a tsudo n1 street catback and you just about get that sound. If I can find my video I'll put it up
this one?

videos imo just dont cut it as youtube and different speakers and mics willl catch the sound differently.

But i do admit the rumble is there, but is a bit different... but it could be like what i mentioned about the speakers.
Quote:
Originally Posted by ozunadel View Post
YouTube - Rallisport header
Headers installed with an exhaust
theoutbackdream is offline   Reply With Quote
Old 07-18-2012, 07:25 PM   #5813
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

Quote:
Originally Posted by theoutbackdream

this one?

videos imo just dont cut it as youtube and different speakers and mics willl catch the sound differently.

But i do admit the rumble is there, but is a bit different... but it could be like what i mentioned about the speakers.

Video Link: http://www.youtube.com/watch?v=jlrFNbJrYb0
Oh it's absolutely not the same but it's really close just maybe not as deep. But yor right my iPhone isn't the best device to capture how it really sounds
ozunadel is offline   Reply With Quote
Old 07-18-2012, 07:50 PM   #5814
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

So I blew a front turn signal and went to the store to buy a replacement. And for some reason EVERYTHING said the bulb is a 3457 bulb, so I took everything out to get to both of them, and take it out and it's an 1157... Wtf?
premier00000 is offline   Reply With Quote
Old 07-18-2012, 09:37 PM   #5815
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Thats weird... MY09 used a 1157A when i swapped it out.. It cant be the rear either as its a 7440A bulb..


Edit:
From what im reading the MY08 uses 3457A front signal lights. Weird how it has a 1157 though..

(2008) http://www.modifiedlife.com/2008-sub...lb-size-chart/
(2009) http://www.modifiedlife.com/2009-sub...lb-size-guide/
theoutbackdream is offline   Reply With Quote
Old 07-18-2012, 10:54 PM   #5816
krzywhtboi82
Scooby Newbie
 
Member#: 280582
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: jackson mi
Vehicle:
2009 2.5i premium
ssm

Default

So question to all the smart guys.does anyone know some stock numbers for iat,maf,and possibly fuel trim? Did some modding with my intake and want to see if I helped or made worse.just need some numbers to go off of. Did quick search but didn't find anything.
krzywhtboi82 is offline   Reply With Quote
Old 07-19-2012, 11:59 AM   #5817
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

I need some help. Lately, I've been noticing my car feel quite sluggish. I really have to get on the gas to feel any kind of power and accelerate. When I am pushing the gas as much as I normally to, I can definitely tell that the car feels slower. Any suggestions on what it may be? I am think it could be a dirty MAF sensor, but was looking for some more opinions. Thanks.
DirknJirkn13 is offline   Reply With Quote
Old 07-19-2012, 12:03 PM   #5818
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

Quote:
Originally Posted by DirknJirkn13
I need some help. Lately, I've been noticing my car feel quite sluggish. I really have to get on the gas to feel any kind of power and accelerate. When I am pushing the gas as much as I normally to, I can definitely tell that the car feels slower. Any suggestions on what it may be? I am think it could be a dirty MAF sensor, but was looking for some more opinions. Thanks.
Do you have any mods on your car such as intake exhaust etc...
ozunadel is offline   Reply With Quote
Old 07-19-2012, 12:21 PM   #5819
Digital Dillon
Scooby Specialist
 
Member#: 288727
Join Date: Jul 2011
Chapter/Region: NESIC
Location: Sturbridge, MA
Vehicle:
2008 WRX premium
Obsidian Black Pearl

Default

Quote:
Originally Posted by DirknJirkn13
I need some help. Lately, I've been noticing my car feel quite sluggish. I really have to get on the gas to feel any kind of power and accelerate. When I am pushing the gas as much as I normally to, I can definitely tell that the car feels slower. Any suggestions on what it may be? I am think it could be a dirty MAF sensor, but was looking for some more opinions. Thanks.
I think the problem is because2.5i
Digital Dillon is offline   Reply With Quote
Old 07-19-2012, 12:28 PM   #5820
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

Quote:
Originally Posted by Digital Dillon

I think the problem is because2.5i
Yes that's a large reason but they aren't all THAT bad. It could have to do with the weather. I know mine feels really slow when it's hot and runs awesome when it's chilly
ozunadel is offline   Reply With Quote
Old 07-19-2012, 12:33 PM   #5821
Digital Dillon
Scooby Specialist
 
Member#: 288727
Join Date: Jul 2011
Chapter/Region: NESIC
Location: Sturbridge, MA
Vehicle:
2008 WRX premium
Obsidian Black Pearl

Default

Quote:
Originally Posted by ozunadel

Yes that's a large reason but they aren't all THAT bad. It could have to do with the weather. I know mine feels really slow when it's hot and runs awesome when it's chilly
Yea, it's insanely humid here and the car runs fine but I can tell it doesn't like the weather :sadbananna:
Digital Dillon is offline   Reply With Quote
Old 07-19-2012, 12:55 PM   #5822
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

Yup it's already slow but the heat just makes it slow and my clutch feel like its jelly
ozunadel is offline   Reply With Quote
Old 07-19-2012, 01:04 PM   #5823
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by ozunadel View Post
Do you have any mods on your car such as intake exhaust etc...
Yea I have a custom intake that only replaced the accordion piping and an STi quad exhaust. I have had them on there for a few months but just recently started noticing it.

Quote:
Originally Posted by Digital Dillon View Post
I think the problem is because2.5i
Figured someone would say this, just who was the question. What I'm noticing is even worse than when I got the car.

Quote:
Originally Posted by ozunadel View Post
Yes that's a large reason but they aren't all THAT bad. It could have to do with the weather. I know mine feels really slow when it's hot and runs awesome when it's chilly
Quote:
Originally Posted by Digital Dillon View Post
Yea, it's insanely humid here and the car runs fine but I can tell it doesn't like the weather :sadbananna:
I do suppose the weather could be a factor, but it has been hot and humid for a good month now, but only starting feeling this about 2 weeks ago.

I am at 28.5k miles now, and due for 30k service soon. What has everyone done for their 30k?
DirknJirkn13 is offline   Reply With Quote
Old 07-19-2012, 01:14 PM   #5824
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

How's your throttle body plate? Navysesal cleaned his and i think he got good results. I did the same but the results weren't too different as my tbp wasn't too dirty but i did feel it.
theoutbackdream is offline   Reply With Quote
Old 07-19-2012, 01:15 PM   #5825
ozunadel
Scooby Newbie
 
Member#: 313772
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Northern NJ
Vehicle:
2011 Impreza
DGM

Default

Quote:
Originally Posted by DirknJirkn13

Yea I have a custom intake that only replaced the accordion piping and an STi quad exhaust. I have had them on there for a few months but just recently started noticing it.

Figured someone would say this, just who was the question. What I'm noticing is even worse than when I got the car.

I do suppose the weather could be a factor, but it has been hot and humid for a good month now, but only starting feeling this about 2 weeks ago.

I am at 28.5k miles now, and due for 30k service soon. What has everyone done for their 30k?
It honestly could just be the weather all in all. And for my 30k I did oil change 4 spark plugs cleaned the MAF and IACV change tranny and rear diff fluid runs like a champ
ozunadel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM


All times are GMT -4. The time now is 12:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.