Welcome to the North American Subaru Impreza Owners Club Saturday December 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-09-2012, 05:17 PM   #7951
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by premier00000 View Post
Thats what I had, and they only lasted me about 3 months until the wiper blade tore off.
That's weird, I would have taken them back for a replacement.. maybe you got a defect? Mine are like new after many months.
* Registered users of the site do not see these ads.
BWX is offline   Reply With Quote
Old 12-09-2012, 05:28 PM   #7952
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Quote:
Originally Posted by BWX View Post

That's weird, I would have taken them back for a replacement.. maybe you got a defect? Mine are like new after many months.
Seems like I've had better luck with the cheap brands. LOL.
premier00000 is offline   Reply With Quote
Old 12-09-2012, 05:40 PM   #7953
krzywhtboi82
Scooby Newbie
 
Member#: 280582
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: jackson mi
Vehicle:
2009 2.5i premium
ssm

Default

Quote:
Originally Posted by NH8991 View Post
For me the fronts have never been a problem, the rear is something else, it's almost as though the arm is not applying enough pressure. I've seen reports from other hatch owners having the same issue....
I work at az. Do not get a flex blade for the rear. They don't work. Not enough pressure
krzywhtboi82 is offline   Reply With Quote
Old 12-09-2012, 07:30 PM   #7954
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Well we got some snow today. Over 10" and still coming down.





fancyfootwork15 is offline   Reply With Quote
Old 12-09-2012, 08:47 PM   #7955
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by fancyfootwork15 View Post
Well we got some snow today. Over 10" and still coming down.



Those first two pictures just look glorious.
Slow Scoobie is offline   Reply With Quote
Old 12-09-2012, 10:07 PM   #7956
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

installed a Kenwood KDCX896 by myself last night. Holy crap am i blown away by the sound quality.

Makes me want to get new speakers AND a sub now. lol
theoutbackdream is offline   Reply With Quote
Old 12-09-2012, 10:09 PM   #7957
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by Slow Scoobie View Post

Those first two pictures just look glorious.
Thanks dude!
fancyfootwork15 is offline   Reply With Quote
Old 12-09-2012, 11:06 PM   #7958
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default Useless ride height


Luckily it doesn't sit that low anymore. I couldn't handle the .5 in clearance.

Last edited by Slow Scoobie; 12-10-2012 at 12:11 AM.
Slow Scoobie is offline   Reply With Quote
Old 12-09-2012, 11:44 PM   #7959
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Slow Scoobie View Post
Luckily it doesn't sit that low anymore.
How did you mount your License plate?
theoutbackdream is offline   Reply With Quote
Old 12-10-2012, 12:10 AM   #7960
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by theoutbackdream View Post
How did you mount your License plate?
3m double sided tape about 10 months ago . Screw $40 brackets i could mount 25 license plates with a 5 dollar roll of 3m.
Slow Scoobie is offline   Reply With Quote
Old 12-10-2012, 12:12 AM   #7961
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by Slow Scoobie View Post

3m double sided tape about 10 months ago . Screw $40 brackets i could mount 25 license plates with a 5 dollar roll of 3m.
My bracket was custom made and shipped to me for $8.
fancyfootwork15 is offline   Reply With Quote
Old 12-10-2012, 12:25 AM   #7962
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Slow Scoobie View Post
3m double sided tape about 10 months ago . Screw $40 brackets i could mount 25 license plates with a 5 dollar roll of 3m.
Wow, i might do that! thanks
Quote:
Originally Posted by fancyfootwork15 View Post
My bracket was custom made and shipped to me for $8.
Any info for this?
theoutbackdream is offline   Reply With Quote
Old 12-10-2012, 12:33 AM   #7963
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by fancyfootwork15 View Post
My bracket was custom made and shipped to me for $8.
I know this gonna sound stupid but i had my plate relocate bracket stolen once....along with my license plate. So i just stick to the tape now. Does it attach to the front tow hook btw?
Slow Scoobie is offline   Reply With Quote
Old 12-10-2012, 12:35 AM   #7964
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by theoutbackdream View Post
installed a Kenwood KDCX896 by myself last night. Holy crap am i blown away by the sound quality.

Makes me want to get new speakers AND a sub now. lol
Great to hear. Crutchfield install? I had the same reaction with my car as well .
KartRacer3 is offline   Reply With Quote
Old 12-10-2012, 12:37 AM   #7965
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by KartRacer3 View Post
Great to hear. Crutchfield install? I had the same reaction with my car as well .
nope, just local audio store, bought parts, then just tried figuring it out myself....
theoutbackdream is offline   Reply With Quote
Old 12-10-2012, 12:41 AM   #7966
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by theoutbackdream View Post
Wow, i might do that! thanks

Any info for this?
I think I bought it from Havok but I don't remember lol.
fancyfootwork15 is offline   Reply With Quote
Old 12-10-2012, 12:42 AM   #7967
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by Slow Scoobie View Post

I know this gonna sound stupid but i had my plate relocate bracket stolen once....along with my license plate. So i just stick to the tape now. Does it attach to the front tow hook btw?
It's a rod that screws into the tow look location.
fancyfootwork15 is offline   Reply With Quote
Old 12-10-2012, 02:17 AM   #7968
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by theoutbackdream View Post
nope, just local audio store, bought parts, then just tried figuring it out myself....
Props to you man lol. I mean im sure at worst case you have to solder a few wires but other than that it was probably pnp right?
KartRacer3 is offline   Reply With Quote
Old 12-10-2012, 06:19 AM   #7969
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

I know of a guy over in the bay that just zip tied the license plate to his bumper

Pretty sure he drilled it tho
Navysesal is offline   Reply With Quote
Old 12-10-2012, 08:42 AM   #7970
BSP671
Scooby Newbie
 
Member#: 288190
Join Date: Jul 2011
Location: Guam
Vehicle:
2009 Impreza 2.5i
Spark Silver

Default

Quote:
Originally Posted by Slow Scoobie

Luckily it doesn't sit that low anymore. I couldn't handle the .5 in clearance.
For some reason that lip looks a bit off. Is it the non premium underspoiler with a Bayson R lip? Need more pics with better angles
BSP671 is offline   Reply With Quote
Old 12-10-2012, 11:02 AM   #7971
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by BSP671

For some reason that lip looks a bit off. Is it the non premium underspoiler with a Bayson R lip? Need more pics with better angles
Yea its a non premium bumper with the Bayson R lip. I saw Daigledangle8 had one and it didnt look half bad so I slapped one on.
Slow Scoobie is offline   Reply With Quote
Old 12-10-2012, 06:01 PM   #7972
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

First snow that stuck around for more than an hour. Car pivots better in the snow with the stiffer spring set up.

Sellars21 is offline   Reply With Quote
Old 12-10-2012, 06:25 PM   #7973
09subi2.5i
Scooby Newbie
 
Member#: 331636
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Bronx NY/Philly PA
Vehicle:
09 impreza
paprika

Default

[IMG][/IMG]

no snow yet but thought the fog looked pretty cool
09subi2.5i is offline   Reply With Quote
Old 12-10-2012, 07:02 PM   #7974
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by 09subi2.5i View Post
[/IMG]

no snow yet but thought the fog looked pretty cool
Photo? Lol
Navysesal is offline   Reply With Quote
Old 12-10-2012, 07:31 PM   #7975
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by 09subi2.5i View Post
[IMG]
no snow yet but thought the fog looked pretty cool
Nice photo. Do you have a close up of your grille? It looks like you modified the oem one but I cant tell.
KartRacer3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 03:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 12:57 PM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 10:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 03:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 03:35 PM


All times are GMT -4. The time now is 10:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.