Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-22-2013, 02:42 PM   #9876
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by krueger519 View Post
Here are the before and after pics of the new wheels.
Very nice!
* Registered users of the site do not see these ads.
KartRacer3 is offline   Reply With Quote
Old 03-22-2013, 04:02 PM   #9877
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza 2.5i
Newport Blue

Default

Quote:
Originally Posted by krueger519 View Post
Here are the before and after pics of the new wheels.
I dig it. I wish I didn't get hit or I'd have new rims
Steve2.5i is offline   Reply With Quote
Old 03-24-2013, 03:18 PM   #9878
Brian722
Scooby Newbie
 
Member#: 339726
Join Date: Dec 2012
Default

Quote:
Originally Posted by Silver08Waggs View Post
if any one is interested in a Silver wrx hood im looking to trade mine for a scoop less plus some cash im located in Red Bank,NJ 07701
(picture from when i picked it up at the body shop)
How much cash? I have a 09 silver hood
Brian722 is offline   Reply With Quote
Old 03-24-2013, 07:12 PM   #9879
aceofskies05
Scooby Newbie
 
Member#: 326539
Join Date: Jul 2012
Chapter/Region: MWSOC
Location: GR
Vehicle:
2008 Impreza 2.5
newport blue

Default

Original battery gave out. Super hard starts in cold weather. Decided to just buy a new battery. When I put the new battery in, my car wouldn't start. It took like 4, six second turns of the key before it started. Now when ever I put the clutch in and brake, the RPMS drop to below 500rpms and the traction control light pops up. Its like its idling too low now. Now I remember that the ECU gets reset if the battery is off for too long, so thats what I figured happened. But I would like a clarification.
aceofskies05 is offline   Reply With Quote
Old 03-24-2013, 07:33 PM   #9880
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by aceofskies05
Original battery gave out. Super hard starts in cold weather. Decided to just buy a new battery. When I put the new battery in, my car wouldn't start. It took like 4, six second turns of the key before it started. Now when ever I put the clutch in and brake, the RPMS drop to below 500rpms and the traction control light pops up. Its like its idling too low now. Now I remember that the ECU gets reset if the battery is off for too long, so thats what I figured happened. But I would like a clarification.
Yes, everything is normal. I reset daily to get pesky CEL out of the way. City driving and idling for 10min helps reinstate your normal idling patterns.

Next time, one turn of the key, remove key and count 5 Mississippi's. starts on second turn every time.
Sellars21 is offline   Reply With Quote
Old 03-24-2013, 08:47 PM   #9881
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Just installed my sideskirts today adding the sideskirts makes it look lower and more sharp!

MoLiu is offline   Reply With Quote
Old 03-24-2013, 08:54 PM   #9882
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by MoLiu View Post
Just installed my sideskirts today adding the sideskirts makes it look lower and more sharp!

Looks great! Where did you get them from?
DirknJirkn13 is offline   Reply With Quote
Old 03-24-2013, 08:58 PM   #9883
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Quote:
Originally Posted by DirknJirkn13 View Post
Looks great! Where did you get them from?
Thanks I just bought it at a local paint shop garage since their pricing is similar to http://www.subarugenuineparts.com
MoLiu is offline   Reply With Quote
Old 03-24-2013, 09:13 PM   #9884
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by MoLiu View Post
Thanks I just bought it at a local paint shop garage since their pricing is similar to http://www.subarugenuineparts.com
I see. Did you install them yourself? I know there's a few of us on here who would like to know the process.
DirknJirkn13 is offline   Reply With Quote
Old 03-24-2013, 09:21 PM   #9885
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Quote:
Originally Posted by DirknJirkn13 View Post
I see. Did you install them yourself? I know there's a few of us on here who would like to know the process.
Nope, the shop did it for me. They custom fit the side skirts on since I didnt want them to drill holes in my car. They installed it for free too so I figured it'll be better for them to do anyway since I wont be installing it in this kinda weather
MoLiu is offline   Reply With Quote
Old 03-24-2013, 09:26 PM   #9886
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by MoLiu View Post
Nope, the shop did it for me. They custom fit the side skirts on since I didnt want them to drill holes in my car. They installed it for free too so I figured it'll be better for them to do anyway since I wont be installing it in this kinda weather
This shop sounds good. Where is it?
DirknJirkn13 is offline   Reply With Quote
Old 03-24-2013, 09:50 PM   #9887
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Quote:
Originally Posted by DirknJirkn13 View Post
This shop sounds good. Where is it?
Canada
MoLiu is offline   Reply With Quote
Old 03-24-2013, 11:15 PM   #9888
aceofskies05
Scooby Newbie
 
Member#: 326539
Join Date: Jul 2012
Chapter/Region: MWSOC
Location: GR
Vehicle:
2008 Impreza 2.5
newport blue

Default

Quote:
Originally Posted by Sellars21 View Post
Yes, everything is normal. I reset daily to get pesky CEL out of the way. City driving and idling for 10min helps reinstate your normal idling patterns.

Next time, one turn of the key, remove key and count 5 Mississippi's. starts on second turn every time.
Cool. I don't know if its a coincidence or not, but my mpg just jumped from 22 back to the 26 mpg I used to get.

What do you do to reset it everyday? Seems like a pain to disconnect the battery terminals all the time.
aceofskies05 is offline   Reply With Quote
Old 03-25-2013, 01:08 AM   #9889
s1eepR
Scooby Specialist
 
Member#: 335330
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: NYC
Vehicle:
2008 Impreza 5DR
DGM

Default

Quote:
Originally Posted by aceofskies05 View Post
Cool. I don't know if its a coincidence or not, but my mpg just jumped from 22 back to the 26 mpg I used to get.

What do you do to reset it everyday? Seems like a pain to disconnect the battery terminals all the time.
They must be changing the gas formula back to summer mix soon. My best guess.

+ weather.
s1eepR is offline   Reply With Quote
Old 03-25-2013, 07:01 AM   #9890
NH8991
Scooby Newbie
 
Member#: 197937
Join Date: Dec 2008
Chapter/Region: E. Canada
Location: Montreal, QC
Vehicle:
2009 Impreza 2.5i
Mk7 Golf R incoming

Default

Quote:
Originally Posted by Sellars21 View Post
I reset daily to get pesky CEL out of the way.
Daily?!

What CEL? P0420? Anything you can just disable with Romraider?
NH8991 is online now   Reply With Quote
Old 03-25-2013, 09:20 AM   #9891
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by NH8991

Daily?!

What CEL? P0420? Anything you can just disable with Romraider?
Inefficient cat code, forget the number. From my headers. Only in the cold though. It could most likely be taken care of through romraider but I don't have the cables or the software. And I'm in the process of communications to fix my problem, so a tune might not be required to fix this problem.
Sellars21 is offline   Reply With Quote
Old 03-25-2013, 09:22 AM   #9892
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by MoLiu View Post
Just installed my sideskirts today adding the sideskirts makes it look lower and more sharp!
Side skirts look good I got out bid for a set from ebay, what rear lip do you have? And any chance you have a link to it?
Silver08Waggs is offline   Reply With Quote
Old 03-25-2013, 09:24 AM   #9893
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by aceofskies05

Cool. I don't know if its a coincidence or not, but my mpg just jumped from 22 back to the 26 mpg I used to get.

What do you do to reset it everyday? Seems like a pain to disconnect the battery terminals all the time.
Yes with a CEL slight loss of power, depending on the code is normal. Mpg are also effected.

And it's the biggest pain, especially in -40c weather for most of the winter because the code was a temperature based cat inefficacy code.
Sellars21 is offline   Reply With Quote
Old 03-25-2013, 09:36 AM   #9894
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Quote:
Originally Posted by Silver08Waggs View Post
Side skirts look good I got out bid for a set from ebay, what rear lip do you have? And any chance you have a link to it?
Thanks its an oem sport rear bumper w/ the diffusers. The code for it is 57704FG051
MoLiu is offline   Reply With Quote
Old 03-25-2013, 11:17 AM   #9895
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by MoLiu View Post

Thanks its an oem sport rear bumper w/ the diffusers. The code for it is 57704FG051
Oh ok... Got a product number for the side skirts by any chance?
Silver08Waggs is offline   Reply With Quote
Old 03-25-2013, 04:13 PM   #9896
NH8991
Scooby Newbie
 
Member#: 197937
Join Date: Dec 2008
Chapter/Region: E. Canada
Location: Montreal, QC
Vehicle:
2009 Impreza 2.5i
Mk7 Golf R incoming

Default

Quote:
Originally Posted by Sellars21 View Post
Inefficient cat code, forget the number. From my headers. Only in the cold though. It could most likely be taken care of through romraider but I don't have the cables or the software. And I'm in the process of communications to fix my problem, so a tune might not be required to fix this problem.
Yep, sounds like the good 'ol P0420. You don't need to perform a tune, you can just reflash your existing ROM with the code disabled.
Of course you still need the Tactrix cable though.....
NH8991 is online now   Reply With Quote
Old 03-25-2013, 04:59 PM   #9897
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by NH8991

Yep, sounds like the good 'ol P0420. You don't need to perform a tune, you can just reflash your existing ROM with the code disabled.
Of course you still need the Tactrix cable though.....
The cable isn't the real issue, the program is what's over my head. Doesn't help that I have a Mac and need additional programs for my computer.

But this is good to know that its a simple fix. I'll start looking around for other Subi guys in my area that might be able to help.
Sellars21 is offline   Reply With Quote
Old 03-25-2013, 05:33 PM   #9898
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza 2.5i
Newport Blue

Default

Quote:
Originally Posted by Sellars21 View Post

The cable isn't the real issue, the program is what's over my head. Doesn't help that I have a Mac and need additional programs for my computer.

But this is good to know that its a simple fix. I'll start looking around for other Subi guys in my area that might be able to help.
Mac tsk tsk
Steve2.5i is offline   Reply With Quote
Old 03-25-2013, 06:25 PM   #9899
MoLiu
Scooby Newbie
 
Member#: 319114
Join Date: May 2012
Location: Ontario
Default

Quote:
Originally Posted by Silver08Waggs View Post
Oh ok... Got a product number for the side skirts by any chance?
Nope sorry, but I do have the code number for the front bumper with the built in lip. It is 57704FG041
MoLiu is offline   Reply With Quote
Old 03-25-2013, 06:40 PM   #9900
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by MoLiu View Post

Nope sorry, but I do have the code number for the front bumper with the built in lip. It is 57704FG041
Already got that
Silver08Waggs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM


All times are GMT -4. The time now is 02:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.