Welcome to the North American Subaru Impreza Owners Club Saturday July 23, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-04-2013, 05:21 PM   #10401
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by fancyfootwork15 View Post

Take a picture of your dash with all of the lights on. Sounds like you have just been driving with your brights on accidentally.
The brights are blue tho, so idk if it's that yard to tell the difference
* Registered users of the site do not see these ads.
Navysesal is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-05-2013, 01:37 AM   #10402
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

I remember seeing someone post a pic of their hella supertones a while back. Has anyone else installed them? I'm thinking of buying them, summer brings out the idiots over here n I'm finding myself using my horn way to often.
Steve2.5i is offline   Reply With Quote
Old 05-05-2013, 01:45 AM   #10403
Bubakanush
Scooby Newbie
 
Member#: 209975
Join Date: Apr 2009
Chapter/Region: Tri-State
Location: South Jersey
Vehicle:
2016 WRX
LBP

Default

Quote:
Originally Posted by Steve2.5i View Post
I remember seeing someone post a pic of their hella supertones a while back. Has anyone else installed them? I'm thinking of buying them, summer brings out the idiots over here n I'm finding myself using my horn way to often.
I have them installed on my 06. I bought them on Black Friday from subimods and got a good deal on the horns, bracket, and wiring harness. However, you can easily make your own harness as well. I love them, the way people jump when you honk them is priceless. I'd love to see what two sets of the Hellas would do! Very easy to install as well.
Bubakanush is offline   Reply With Quote
Old 05-05-2013, 02:26 AM   #10404
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by Bubakanush View Post

I have them installed on my 06. I bought them on Black Friday from subimods and got a good deal on the horns, bracket, and wiring harness. However, you can easily make your own harness as well. I love them, the way people jump when you honk them is priceless. I'd love to see what two sets of the Hellas would do! Very easy to install as well.
+1. I have them, painted them blue, got the subimods harness and just installed them using factory holes. Using 4 supertones does make it slightly louder and a deeper tone. Looks pretty cool but would block too much area for the radiator to work properly IMO
KartRacer3 is offline   Reply With Quote
Old 05-05-2013, 02:55 AM   #10405
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

Quote:
Originally Posted by KartRacer3 View Post

+1. I have them, painted them blue, got the subimods harness and just installed them using factory holes. Using 4 supertones does make it slightly louder and a deeper tone. Looks pretty cool but would block too much area for the radiator to work properly IMO
Quote:
Originally Posted by Bubakanush View Post

I have them installed on my 06. I bought them on Black Friday from subimods and got a good deal on the horns, bracket, and wiring harness. However, you can easily make your own harness as well. I love them, the way people jump when you honk them is priceless. I'd love to see what two sets of the Hellas would do! Very easy to install as well.
Sweet gunna wait a bit for my next paycheck to roll in n buy them. I wanna go the same route n paint them blue, I hate red.
Steve2.5i is offline   Reply With Quote
Old 05-05-2013, 10:06 AM   #10406
Bubakanush
Scooby Newbie
 
Member#: 209975
Join Date: Apr 2009
Chapter/Region: Tri-State
Location: South Jersey
Vehicle:
2016 WRX
LBP

Default

Quote:
Originally Posted by Steve2.5i View Post

Sweet gunna wait a bit for my next paycheck to roll in n buy them. I wanna go the same route n paint them blue, I hate red.
I am pretty sure you can pay like $10 extra and get them in blue from subimods
Bubakanush is offline   Reply With Quote
Old 05-05-2013, 10:34 AM   #10407
premier00000
Scooby Specialist
 
Member#: 251060
Join Date: Jul 2010
Location: Schenectady, NY
Vehicle:
2008 Impreza Outback
Black

Default

Quote:
Originally Posted by DirknJirkn13 View Post
Why wouldn't there be something telling you that your headlights are on? According to your theory there shouldn't be a fog light indicator, but there is.
There IS something telling you that your headlights are on. It's either called "LIGHT ON THE ROAD in front of you" or or "all the dash lights are on"
premier00000 is offline   Reply With Quote
Old 05-05-2013, 10:57 AM   #10408
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Thanks for all the help everyone, really appreciate it.
DirknJirkn13 is offline   Reply With Quote
Old 05-05-2013, 02:03 PM   #10409
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

Quote:
Originally Posted by Bubakanush View Post

I am pretty sure you can pay like $10 extra and get them in blue from subimods
Ill look into it lol that would save me the hassle.
Steve2.5i is offline   Reply With Quote
Old 05-05-2013, 02:37 PM   #10410
Bubakanush
Scooby Newbie
 
Member#: 209975
Join Date: Apr 2009
Chapter/Region: Tri-State
Location: South Jersey
Vehicle:
2016 WRX
LBP

Default

Quote:
Originally Posted by Steve2.5i View Post

Ill look into it lol that would save me the hassle.
Here ya go
http://www.subimods.com/hella-supert...-kit-blue.html
Bubakanush is offline   Reply With Quote
Old 05-05-2013, 02:46 PM   #10411
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

Quote:
Originally Posted by Bubakanush View Post
Thanks much appreciated
Steve2.5i is offline   Reply With Quote
Old 05-05-2013, 05:33 PM   #10412
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

I hate to promote PnP HID kits but I have these for sale :http://forums.nasioc.com/forums/show....php?t=2501789
If anybody on this thread wants it, pm me and I'll give you a better deal!
KartRacer3 is offline   Reply With Quote
Old 05-05-2013, 08:21 PM   #10413
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by KartRacer3

+1. I have them, painted them blue, got the subimods harness and just installed them using factory holes. Using 4 supertones does make it slightly louder and a deeper tone. Looks pretty cool but would block too much area for the radiator to work properly IMO
Where do you think a good mounting point for the second set would be. I have the first set right up front where they should be. Don't really want the second set to been seen.

And call me classic but I prefer the red. Kinda fits for my red car tho.
Sellars21 is offline   Reply With Quote
Old 05-05-2013, 08:45 PM   #10414
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Any one know if the Bayson R Sti lip (http://www.ebay.com/itm/390507018751...witem=&vxp=mtr) will work with the OEM look alike lip? (http://www.ebay.com/itm/08-09-SUBARU...3c69c0&vxp=mtr)

Ignore this post. It honestly doesn't matter. If it doesn't fit ill make it fit lol.

Last edited by Slow Scoobie; 05-05-2013 at 09:04 PM.
Slow Scoobie is offline   Reply With Quote
Old 05-06-2013, 03:21 AM   #10415
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by Slow Scoobie View Post
Any one know if the Bayson R Sti lip (http://www.ebay.com/itm/390507018751...witem=&vxp=mtr) will work with the OEM look alike lip? (http://www.ebay.com/itm/08-09-SUBARU...3c69c0&vxp=mtr)

Ignore this post. It honestly doesn't matter. If it doesn't fit ill make it fit lol.
Gonna be attempting this sometime next week
KartRacer3 is offline   Reply With Quote
Old 05-06-2013, 12:09 PM   #10416
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by KartRacer3 View Post

Gonna be attempting this sometime next week
Your gonna need to trim the bayson r a little. Its actually a lot easier to make fit then I thought it would be.

Last edited by Slow Scoobie; 05-06-2013 at 01:07 PM.
Slow Scoobie is offline   Reply With Quote
Old 05-06-2013, 01:10 PM   #10417
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by Slow Scoobie

Your gonna need to trim the bayson r a little. Its actually a lot easier to make fit then I thought it would be.
Anyone know if the eBay one fits the premium front bumper?

I was looking at this one. I know this one will fit my car.

http://www.hptmotorsports.com/subaru...08-10-wrx.html
Sellars21 is offline   Reply With Quote
Old 05-06-2013, 01:25 PM   #10418
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

Had to disconnect my battery yesterday and now I got a funny idle. I was dreading for this day to come lol. I was reading last night n the proper way to get it to idle back is turn everything off ac-lights-ect ect then turn the key to the on position n leaving it there for 10-20secs. Turn it off then start the car letting it idle for 8-10mins and the idle should of adjusted. Can anyone confirm this?
Steve2.5i is offline   Reply With Quote
Old 05-06-2013, 02:20 PM   #10419
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by Steve2.5i View Post
Had to disconnect my battery yesterday and now I got a funny idle. I was dreading for this day to come lol. I was reading last night n the proper way to get it to idle back is turn everything off ac-lights-ect ect then turn the key to the on position n leaving it there for 10-20secs. Turn it off then start the car letting it idle for 8-10mins and the idle should of adjusted. Can anyone confirm this?
I was in a similar situation a few months ago. I had pulled the battery out of my car for a few days While parked in an airport lot while I went on vacation. (I was scared someone try to steal my car lol) well anyway when I got back the car idled really rough so I called one of my buddies who owns a shop and he told me to let it idle for a while. Low and behold it fixed the idle problem

Car computers learn and get use to the way they are operated everyday. when you disconnect the battery its like you wiped their memory and they have to relearn everything. I was told too let the car idle for 30 mins to an hour. This was confirmed to me by a few Subaru techs.

This only applys to newer cars were almost everything is computer controlled.

Last edited by Slow Scoobie; 05-06-2013 at 02:27 PM.
Slow Scoobie is offline   Reply With Quote
Old 05-06-2013, 02:20 PM   #10420
zsniperz
Scooby Newbie
 
Member#: 352610
Join Date: Apr 2013
Default

Quote:
Originally Posted by Slow Scoobie View Post
Your gonna need to trim the bayson r a little. Its actually a lot easier to make fit then I thought it would be.
Do you have some pics of the install?
zsniperz is offline   Reply With Quote
Old 05-06-2013, 02:35 PM   #10421
BSP671
Scooby Newbie
 
Member#: 288190
Join Date: Jul 2011
Location: Guam
Vehicle:
2009 Impreza 2.5i
Spark Silver

Default

Quote:
Originally Posted by Slow Scoobie View Post

I was in a similar situation a few months ago. I had pulled the battery out of my car for a few days While parked in an airport lot while I went on vacation. (I was scared someone try to steal my car lol) well anyway when I got back the car idled really rough so I called one of my buddies who owns a shop and he told me to let it idle for a while. Low and behold it fixed the idle problem

Car computers learn and get use to the way they are operated everyday. when you disconnect the battery its like you wiped their memory and they have to relearn everything. I was told too let the car idle for 30 mins to an hour. This was confirmed to me by a few Subaru techs.

This only applys to newer cars were almost everything is computer controlled.
I was just about to say this lol. It takes a bit for the computer to compute the air/fuel ratio and what not to let the ecu compensate for the running conditions
BSP671 is offline   Reply With Quote
Old 05-06-2013, 03:00 PM   #10422
Steve2.5i
Scooby Specialist
 
Member#: 293006
Join Date: Aug 2011
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2015 Subaru WRX
WR Blue

Default

Quote:
Originally Posted by Slow Scoobie View Post
I was in a similar situation a few months ago. I had pulled the battery out of my car for a few days While parked in an airport lot while I went on vacation. (I was scared someone try to steal my car lol) well anyway when I got back the car idled really rough so I called one of my buddies who owns a shop and he told me to let it idle for a while. Low and behold it fixed the idle problem

Car computers learn and get use to the way they are operated everyday. when you disconnect the battery its like you wiped their memory and they have to relearn everything. I was told too let the car idle for 30 mins to an hour. This was confirmed to me by a few Subaru techs.

This only applys to newer cars were almost everything is computer controlled.
Do I have to re-disconnect the battery then let it idle? or can I just start my car up now n let it idle?
Steve2.5i is offline   Reply With Quote
Old 05-06-2013, 03:13 PM   #10423
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
2005 Legacy GT
ABP

Default

Quote:
Originally Posted by Steve2.5i View Post
Do I have to re-disconnect the battery then let it idle? or can I just start my car up now n let it idle?
1. Connect Battery
2. Turn car on and let idle
3. Wait.
Slow Scoobie is offline   Reply With Quote
Old 05-06-2013, 06:18 PM   #10424
DownhillSubie
Scooby Newbie
 
Member#: 342985
Join Date: Jan 2013
Chapter/Region: Tri-State
Default

SlowScoobie, I demand more pictures! Those Gold grids are the wheels i've been wanting for my 2.5i.

Please share suspension and wheel specs.
DownhillSubie is offline   Reply With Quote
Old 05-06-2013, 06:26 PM   #10425
KartRacer3
Scooby Specialist
 
Member#: 268328
Join Date: Dec 2010
Chapter/Region: BAIC
Location: Norcal
Vehicle:
2011 2.5i prem pckg
SSM

Default

Quote:
Originally Posted by Slow Scoobie View Post
1. Connect Battery
2. Turn car on and let idle
3. Wait.
+1, also post up some pics of the dual-lip setup as well please!
KartRacer3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM

All times are GMT -4. The time now is 10:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.