Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-16-2007, 12:12 PM   #1
n2opowered
Scooby Newbie
 
Member#: 146856
Join Date: Apr 2007
Default 04+ LGT - Does your factory radio suck??

Then look no further. These guys in Denver have found a solution. Im anxiously awaiting them to make mine. Looks to be of very high quality and seems as if they have done their homework.

See the mayhem here -> http://legacygt.com/forums/showthread.php?t=74919

This guy got it done first -> http://legacygt.com/forums/showthread.php?t=72548

LGT owners unite!
* Registered users of the site do not see these ads.
n2opowered is offline   Reply With Quote
Old 11-16-2007, 04:12 PM   #2
finse46
Scooby Newbie
 
Member#: 30756
Join Date: Dec 2002
Location: Denver, Co
Vehicle:
2006 Legacy GT SpecB
Artic Silver

Default

Mine did.. But not anymore.
finse46 is offline   Reply With Quote
Old 11-16-2007, 04:45 PM   #3
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default

All factory Subaru radios suck. They're manufactured by Pannasonic, that must be why.
runninstrong is offline   Reply With Quote
Old 11-17-2007, 01:41 PM   #4
spdracr00
Scooby Specialist
 
Member#: 65823
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
1996 Impreza L
Red

Default

mine used to suck as well. while that looks nice i dont think its worth 1k. thats a good set of coilovers or some other goodies. i went with a nice clarion cross-over with high level inputs which let me tune my system and set my EQ and cross-over points and it only cost me $100. sure i dont have any aux inputs, but i upgraded to the 6 disc mp3 headunit and that holds lets see.... 500songs per disc, 6 discs... yeah, plenty of music for me. not perfect by any means but i'd say 85% perfect. if anyone wants i'll post pics..
spdracr00 is offline   Reply With Quote
Old 11-17-2007, 03:46 PM   #5
that one legacy
Scooby Specialist
 
Member#: 103665
Join Date: Dec 2005
Default

Quote:
Originally Posted by runninstrong View Post
All factory Subaru radios suck. They're manufactured by Pannasonic, that must be why.
omg, don't get me started on my hatred for panasonic products...
that one legacy is offline   Reply With Quote
Old 11-18-2007, 04:44 AM   #6
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

Quote:
Originally Posted by that one legacy View Post
omg, don't get me started on my hatred for panasonic products...
Panasonic isn't great in the car audio department, but their Plasma TVs are excellent!

Anyways, pretty much all factory decks in non luxury cars (with exception of cool factory options like McIntosh) blow. It's not like it's just Subaru...I'd have to say the decks in our Hondas are a lot worse than my old OEM panasonic. And that's saying something...
Wiscon_Mark is offline   Reply With Quote
Old 11-18-2007, 01:36 PM   #7
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Woolley
Vehicle:
1998 Ram 2500
Green.

Default

Hm, I'm actually fairly happy with the sound quality of the oem setup in my wagon. I swapped out the factory deck for an 07 and added the ipod interface, and while I'd rather have the clickwheel and a better ipod interface, it does the trick and was a lot cheaper. Oh well.
CosmoTheCat is offline   Reply With Quote
Old 11-18-2007, 11:41 PM   #8
JOSHMAN
Scooby Specialist
 
Member#: 13938
Join Date: Jan 2002
Chapter/Region: NESIC
Location: Wormtown, MA
Vehicle:
2012 WRX limited
Dark Gray

Default

Thanks for the heads up. I haven't seen that thread there yet.
JOSHMAN is offline   Reply With Quote
Old 11-18-2007, 11:48 PM   #9
spdracr00
Scooby Specialist
 
Member#: 65823
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
1996 Impreza L
Red

Default

Quote:
Originally Posted by HoratioCaine View Post
Hm, I'm actually fairly happy with the sound quality of the oem setup in my wagon. I swapped out the factory deck for an 07 and added the ipod interface, and while I'd rather have the clickwheel and a better ipod interface, it does the trick and was a lot cheaper. Oh well.
PICS!!! and did it plug right in?
spdracr00 is offline   Reply With Quote
Old 11-19-2007, 04:42 PM   #10
74767777
Scooby Newbie
 
Member#: 163100
Join Date: Oct 2007
Chapter/Region: VIC
Location: Vancouver
Vehicle:
2004 Impreza 2.5 RS
Pacifica Blue Pearl

Default

What do you guys mean by suck? Not much functions or....bad quality kind of suck? Honestly speaking, the audio on my 06 LGT is already much better than the 04 IMpreza I've got..at least, it has 6 cd
74767777 is offline   Reply With Quote
Old 11-19-2007, 04:56 PM   #11
toysnyc
Scooby Newbie
 
Member#: 164703
Join Date: Nov 2007
Default

I have a 1996 and I have to say that I am not too disappointed int he radio. I have heard much worse.
toysnyc is offline   Reply With Quote
Old 11-19-2007, 05:34 PM   #12
JaySVX
Scooby Newbie
 
Member#: 164676
Join Date: Nov 2007
Location: Collegeville, PA
Vehicle:
1994 Subaru SVX LSi
Barcelona Red

Default

My 1992 Subaru SVX has an AM/FM/CD/Cassette, works great, sounds great.

My 1994 Subaru SVX has an AM/FM/6CD changer out of a 2003 WRX, and it works and sounds great.

My 1996 Subaru Legacy has an AM/FM/CD changer with the 6 disc changer under the passenger seat, and I've had zero problems.

What's wrong with Subaru factory radios? Sure, they're not $800 after market head units, but for factory radios, I think they're pretty nice.
JaySVX is offline   Reply With Quote
Old 11-19-2007, 10:04 PM   #13
Matt
Allergic to turbos
Moderator
 
Member#: 181
Join Date: Aug 1999
Chapter/Region: MAIC
Location: MAIC & Southeast
Vehicle:
Two Subarus and
a truck

Default

Quote:
Originally Posted by spdracr00 View Post
PICS!!! and did it plug right in?

I swapped the stock stereo on our 05 Outback with an 07 head unit. Its very nice to have mp3 capability now and I picked one up on Ebay for $100 with the facia and it is a direct plug-in.

I still need to find part numbers for the factory aux-in. Subaru Canada shows it as an accessory on their website, but no part number.
Matt is offline   Reply With Quote
Old 11-20-2007, 03:04 AM   #14
n2opowered
Scooby Newbie
 
Member#: 146856
Join Date: Apr 2007
Default

Thats the great thing about modding. Everyone mods for a different reason. Such as adding more boost via a bigger turbo, or rollin some filthy gold BBS's, everyone has a different plate of mods they want to do.

Every mod, to me, is an expression of what I am about. Not only am a boost nut, I LOVE music. And I love it LOUD. Not a vibrating trunk with 4-15" subs loud. Im talking LOUD and CLEAR, just like the symphonies Im about. No factory radio will live up to the task (I dont care if its the McIntosh system. It still SUCKS in the end).

Yes it is a pricey mod. But when were mods, that actually affect positively, cheap? I believe its amazing what these guys have done. They have opened a portal where very few have ventured into. And Im going down the portal to thirst my audio quest, in a car I love to death (in fact, I might just buy another LGT in the near future).

I almost didnt buy it because the radio sucked. I am glad there is hope.

Thanks for listening to my rant.
n2opowered is offline   Reply With Quote
Old 11-26-2007, 09:04 PM   #15
n2opowered
Scooby Newbie
 
Member#: 146856
Join Date: Apr 2007
Default

Looks as if the project is under way!

Check it out here > http://legacygt.com/forums/showthrea...t=74919&page=7
n2opowered is offline   Reply With Quote
Old 11-27-2007, 06:11 AM   #16
RSKwannabe
Scooby Newbie
 
Member#: 15819
Join Date: Feb 2002
Location: Hollywood, MD
Vehicle:
2001 LEGACY GT
Black

Default

I have an 01 Legacy and recently when I have the radio on and turn on the rear defrost switch I get static. Anyone else have this problem? Seems like it just started happening this year. Any solution?
RSKwannabe is offline   Reply With Quote
Old 11-27-2007, 10:41 AM   #17
spdracr00
Scooby Specialist
 
Member#: 65823
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
1996 Impreza L
Red

Default

my 05 does that when i'm listening to the am band...
spdracr00 is offline   Reply With Quote
Old 11-27-2007, 03:30 PM   #18
Theoffspring99us
Scooby Newbie
 
Member#: 150325
Join Date: Jun 2007
Chapter/Region: MAIC
Location: Baltimore,MD
Vehicle:
2004 Impreza TS
White

Default

my dad's 08 rocks :-)
Theoffspring99us is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the factory uppipe really suck this bad!? XanRules Factory 2.0L Turbo Powertrain 29 04-25-2010 06:07 PM
WTB: 04-06 6 disk factory Radio working or not Dragula NESIC Private Classifieds 0 09-28-2008 08:57 AM
WTB: IL: 02-04 factory radio anthonywrx MWSOC Private Classifieds 0 10-30-2006 12:10 AM
Does your rear defrost suck as bad as mine? UltimateLurker Newbies & FAQs 16 10-29-2005 05:42 PM
Why does radio suck so F'en bad? Hazdaz Off-Topic 26 01-08-2005 11:15 PM


All times are GMT -4. The time now is 12:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.