Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-04-2007, 06:59 AM   #1
StoryBookSin
Scooby Specialist
 
Member#: 85514
Join Date: Apr 2005
Chapter/Region: RMIC
Location: That one place.
Vehicle:
2009 Now screwing
Over the PPl of nasioc

Default Headlights are dead, No Speedo, No ABS

I have a 2003 WRX that i was putting the Hella Horns on. I was going to run them to a switch but as i was splicing in the wries to the fuse box i must have grounded out and lost my Headlights, Speedo and ABS. I have the head lights riggered so they will turn on when the car turns on. All my fuses and relays are good to go. Where do i look next? Most likely ill have to follow each wire individually. i know/believe that the problem is after the fuse box in the engine bay, but who knows... Any suggestions from the people in NASIOC land?

Rob
* Registered users of the site do not see these ads.
StoryBookSin is offline   Reply With Quote
Old 12-04-2007, 07:04 AM   #2
gte123v
Scooby Specialist
 
Member#: 114481
Join Date: May 2006
Location: Atlanta
Vehicle:
2006 Sti
WRB

Default

double check your fuses again, as in actually pull each one out and check them (both in the engine bay and the panel on the driver side). If that's not the problem, then you better start taking things apart and check for burned wires, did you smell burning plastic when this happened?
gte123v is offline   Reply With Quote
Old 12-04-2007, 07:30 AM   #3
StoryBookSin
Scooby Specialist
 
Member#: 85514
Join Date: Apr 2005
Chapter/Region: RMIC
Location: That one place.
Vehicle:
2009 Now screwing
Over the PPl of nasioc

Default

didnt smell a thing. the fans kicked on when the headlights shorted out.
StoryBookSin is offline   Reply With Quote
Old 12-04-2007, 04:26 PM   #4
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Check for voltage on both sides of fuse #18 in the dash fuse panel.
Cougar4 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So my headlights don't work and my wipers are dead OL Off-Topic 7 10-22-2009 12:17 PM
My headlights are dead! thumpetto007 Electrical & Lighting 9 02-15-2008 10:49 AM
left turn signal no work when headlights are on Chuck the swimmer Electrical & Lighting 1 07-05-2006 09:19 AM
Speedo/headlights are not working subaru mike Electrical & Lighting 5 05-24-2004 02:01 PM
No speedo, CE light and stalling - Help? BoomerRS New England Impreza Club Forum -- NESIC 20 12-06-2000 08:55 AM


All times are GMT -4. The time now is 02:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.