Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-11-2007, 10:46 PM   #1
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default How many MPG and not able to get a full tank

I have an 05 STI(Stock), and I cant get a full tank. I'll fill up at the pump and it will shut off, i get in and it will be just below full. Also the gas light came on and I was only able to get about 9 gallons. Can someone shed some light on this. I know Ive seen a couple of topics on this before but I was not able to find them. Anyhelp would be greatly appreciated.
* Registered users of the site do not see these ads.
leeswrx is offline   Reply With Quote
Old 12-12-2007, 12:20 AM   #2
a6n6d6y
Scooby Specialist
 
Member#: 123347
Join Date: Aug 2006
Chapter/Region: NWIC
Location: SEATTLE
Vehicle:
1993 POS
burgandy legacy

Default

is your tank damaged ,,dent underneath the car ??
a6n6d6y is offline   Reply With Quote
Old 12-12-2007, 01:01 AM   #3
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

I'm going to assume you got the car used and i'll also assume the previous owner change fuel pumps and somehow bent or messed up the fuel level sender. Then again I could be wrong but has this always been like that or did it just start happening. Check the plat that covers the fuel pump in the trunk and see if it looks like its been tampered.
kellygnsd is offline   Reply With Quote
Old 12-12-2007, 12:55 PM   #4
07SWPSTi
Scooby Newbie
 
Member#: 158960
Join Date: Sep 2007
Chapter/Region: South East
Location: Bentonville, AR
Vehicle:
07 Impreza STi

Default

I don't mean to "hijack" this thread but it would save us all another one with the same issue. I have had my car for at least three months roughly, I was hoping I this would not be the issue with my STi as it was on my WRX. I also fill up all the way till the pump stops, but never been able to get a full tank of gas, It's always the 3/4 line.
07SWPSTi is offline   Reply With Quote
Old 12-12-2007, 11:46 PM   #5
STIred05
Scooby Newbie
 
Member#: 115223
Join Date: May 2006
Chapter/Region: MWSOC
Location: Glen Ellyn, IL
Vehicle:
2005 Subaru STI
silver

Default

Not likly, but you may have a small restriction in the filler neck. A restriction would cause it takes about 9gal to back fill enough to shut the pump off. I would sit at the pump for about 5 min after it shuts off and then try to pump again. If it still shuts off right away I would take a good long look at your tank.
STIred05 is offline   Reply With Quote
Old 12-13-2007, 10:18 PM   #6
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

I believe this has been going on the whole time. And I did buy the car used. Subaru replaced the block, clutch, flywheel, and turbo. I had an 02 wrx and it got great gas milage. I'll check the plate in the trunk and get back with you. thanks
leeswrx is offline   Reply With Quote
Old 12-15-2007, 11:08 AM   #7
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

I looked in the trunk and there was two plates, one on the left and right. Neither of them looked like they were messed with, could be wrong though. By the way I filled up about a week ago and my tank is down to a 1/4 with 135 miles. Im a real easy driver, I think I would get better gas milage, considering it is suppose to get around 280ish to the tank. Should I take this to subaru or is there something else to look for or do? Once again, I appreciate the help.
leeswrx is offline   Reply With Quote
Old 12-16-2007, 03:42 AM   #8
jigga
Scooby Guru
 
Member#: 9960
Join Date: Sep 2001
Location: in bed...
Vehicle:
2002 Impreza WRX
WRBlue Perl

Default

someone posted about this a while back... I think it had something to do with some anti-syphon valve or something in that filler neck or something that was getting stuck.. Can't remember the details..
jigga is offline   Reply With Quote
Old 12-16-2007, 07:53 AM   #9
cbourbs
Scooby Specialist
 
Member#: 117749
Join Date: Jun 2006
Default

one thing i've noticed with mine (05 sti) is that when it stops, don't fill it up anymore, like not even 10cents more. I've got gas on my feet a few times LOL!!!
cbourbs is offline   Reply With Quote
Old 12-17-2007, 01:04 AM   #10
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

how many miles are you guys getting per tank?
leeswrx is offline   Reply With Quote
Old 12-17-2007, 01:58 AM   #11
C J
Scooby Specialist
 
Member#: 132587
Join Date: Nov 2006
Location: Lincoln, NE
Vehicle:
2006 JrTuned STi
E85 GT3582r/10.83@126mph

Default

I have read somewhere else in this forum that it has todo with how fast the pump at the gas station is filling the tank. Apparently if it fills to fast the gas pump will kick off as if the tank was full b/c of the fuel building up in your cars gas tank's filler neck. So to avoid this problem all you need todo is fill the tank slower. You should beable to set the fuel pump at the station by using the metal deal on the handle (not sure what its called)

I had this problem when I first bought my car and ever since have always set the gas pump at the slower setting and never had a problem again. Might want to give it a try next time and see how it goes.
C J is offline   Reply With Quote
Old 12-17-2007, 04:18 AM   #12
phanofmuzik
Scooby Newbie
 
Member#: 136068
Join Date: Dec 2006
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2005 STi
Blue

Default

my 05 sti does a similar thing, where sometimes it shuts the pump off with about 2 gallons to go. I just start pumping again and sometimes it clicks off, but usually itll fill the rest of the 2 gallons or so. Try pumping at like half speed. My dads 930 turbo clicks off pumps unless youre very careful with the speed on the pump. Takes SO LONG to fill that damned car up.
phanofmuzik is offline   Reply With Quote
Old 12-17-2007, 04:34 AM   #13
EJRex
Scooby Newbie
 
Member#: 119024
Join Date: Jul 2006
Chapter/Region: South East
Location: North AL
Vehicle:
2004 Impreza WRX
San Remo Red

Default

Quote:
Originally Posted by jigga View Post
someone posted about this a while back... I think it had something to do with some anti-syphon valve or something in that filler neck or something that was getting stuck.. Can't remember the details..
^^ this is the right idea.. what's likely happening is that your tank purge vent (for excess fuel vapor) is slow or non-functioning, causing your issue. It happens with some Subies, but I don't know the stats... the vapors build up in the tank during filling, not allowing it to be filled completely and shutting the gas pump off prematurely.. in most cases, if you take it slow thereafter, you can top off the tank, but if the valve is clogged or stuck closed, gas will come out the filler neck.. this may or may not be your problem, but something to consider.
EJRex is offline   Reply With Quote
Old 12-17-2007, 06:04 AM   #14
btung423
Scooby Newbie
 
Member#: 165934
Join Date: Dec 2007
Default

Quote:
Originally Posted by leeswrx View Post
I looked in the trunk and there was two plates, one on the left and right. Neither of them looked like they were messed with, could be wrong though. By the way I filled up about a week ago and my tank is down to a 1/4 with 135 miles. Im a real easy driver, I think I would get better gas milage, considering it is suppose to get around 280ish to the tank. Should I take this to subaru or is there something else to look for or do? Once again, I appreciate the help.

It could be our MAF sensor or your spark plugs. It happened on my car (MB e320), the MAF sensor was old and faulty. I could be wrong.
btung423 is offline   Reply With Quote
Old 12-17-2007, 08:31 PM   #15
wrxfactor
Scooby Specialist
 
Member#: 49978
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
2002 WRX w/ JDM STi
6spd, EJ255, VF39 & EWG

Default

Quote:
Originally Posted by btung423 View Post
It could be our MAF sensor or your spark plugs. It happened on my car (MB e320), the MAF sensor was old and faulty. I could be wrong.
He would get a CEL for that, maybe even an O2 sensor code if his MAF was messed up. He'd likely have idling problems and such also. Sounds like it's what people have already diagnosed, but the gas station I fill up at when at school does this to me too. My gas light will be on and it will only take 10.5 or 11 gallons. I fill up at one specific pump and it's the only way I get a full tank.
wrxfactor is offline   Reply With Quote
Old 12-19-2007, 05:00 AM   #16
leeswrx
Scooby Newbie
 
Member#: 118295
Join Date: Jun 2006
Chapter/Region: AKIC
Vehicle:
05 STI
Blue

Default

The other day, when I came to a couple of red lights, right before stopping clutch in and no throttle, the rpm went up to almost 2 grand. Is this common, or is this a sign of something else?
leeswrx is offline   Reply With Quote
Old 12-19-2007, 10:33 AM   #17
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Quote:
Originally Posted by wrxfactor View Post
He would get a CEL for that, maybe even an O2 sensor code if his MAF was messed up. He'd likely have idling problems and such also. Sounds like it's what people have already diagnosed, but the gas station I fill up at when at school does this to me too. My gas light will be on and it will only take 10.5 or 11 gallons. I fill up at one specific pump and it's the only way I get a full tank.
That's about right on the money if you ask me. As soon as the gas light comes on you still have quite a few gallons in the tank its just a warning. I usually get 11.5 gallons in if I fill up right when the gas light comes on but I usually drive about 40 miles after I get the light and put 13 gallons in or so. It would make sense for the gas light to come on when you were completely out of gas would it.
kellygnsd is offline   Reply With Quote
Old 12-19-2007, 01:08 PM   #18
beermesf
Scooby Newbie
 
Member#: 142593
Join Date: Mar 2007
Location: San Francisco
Vehicle:
2002 STI Wagon
Silver

Default

This was an interesting read. I noticed the same thing on my 05' sti tank. I thought there was something wrong because the most I have been able to get in was 12 gal. But I usually fill up within a few miles of my light going on. Thanks for posting this.
beermesf is offline   Reply With Quote
Old 12-19-2007, 01:55 PM   #19
wrxfactor
Scooby Specialist
 
Member#: 49978
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
2002 WRX w/ JDM STi
6spd, EJ255, VF39 & EWG

Default

Double post.

Last edited by wrxfactor; 12-19-2007 at 02:34 PM.
wrxfactor is offline   Reply With Quote
Old 12-19-2007, 01:58 PM   #20
wrxfactor
Scooby Specialist
 
Member#: 49978
Join Date: Dec 2003
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
2002 WRX w/ JDM STi
6spd, EJ255, VF39 & EWG

Default

Quote:
Originally Posted by kellygnsd View Post
That's about right on the money if you ask me. As soon as the gas light comes on you still have quite a few gallons in the tank its just a warning. I usually get 11.5 gallons in if I fill up right when the gas light comes on but I usually drive about 40 miles after I get the light and put 13 gallons in or so. It would make sense for the gas light to come on when you were completely out of gas would it.
That doesn't make any sense though. With a 15.9 gallon tank, the gas light should go on with about 2.5 or so gallons remaining. Only taking 10.5 or 11 gallons at the light just doesn't seem correct, and I usually get about 12.5-13 in there if I fill up immediately after the light goes on. Additionally, if I "fill" it from one of the other pumps and it stops at 10.5-11 gallons, the needle will not go past the full line all the way up to the F like it normally does. I get around 60 miles from the F to the full line on average, which is where that 2ish gallons extra comes in.
wrxfactor is offline   Reply With Quote
Old 12-19-2007, 02:17 PM   #21
`04AlpineWhite
Scooby Newbie
 
Member#: 65562
Join Date: Jul 2004
Chapter/Region: RMIC
Location: Denver, CO
Default

Quote:
Originally Posted by leeswrx View Post
The other day, when I came to a couple of red lights, right before stopping clutch in and no throttle, the rpm went up to almost 2 grand. Is this common, or is this a sign of something else?

Check both your MAF and front O2 sensors, at least one, if not both, are bad and are causing that issue. That is, if you didn't forget to take your foot off the gas.
`04AlpineWhite is offline   Reply With Quote
Old 12-19-2007, 08:07 PM   #22
SpeedMasterLee
Scooby Specialist
 
Member#: 78417
Join Date: Dec 2004
Chapter/Region: SCIC
Location: Torrance, CA
Vehicle:
2005 WRX/STI Stage 2
Aspen White

Default

I have had my o5 sti for about 3 years and I have never ever been able to fully fill up all the way. Always slightly above the second to the top marking.
SpeedMasterLee is offline   Reply With Quote
Old 12-19-2007, 08:24 PM   #23
az_sti_2
Scooby Newbie
 
Member#: 163885
Join Date: Nov 2007
Location: Tucson AZ
Vehicle:
04 STI
Silver

Default

full in my tank and i get like 200 miles 2 a tank! lol
az_sti_2 is offline   Reply With Quote
Old 12-21-2007, 03:52 PM   #24
jaimejrivera
Scooby Newbie
 
Member#: 112943
Join Date: Apr 2006
Default

280 on highway
180 on city and hard driving
Sti 05 with FP green
jaimejrivera is offline   Reply With Quote
Old 12-21-2007, 03:53 PM   #25
jaimejrivera
Scooby Newbie
 
Member#: 112943
Join Date: Apr 2006
Default

280 on highway
180 on city and hard driving
Sti 05 with FP green
jaimejrivera is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas tank problem.. not able to get a full tank. Jim.mEh Factory 2.5L Turbo Powertrain 52 03-23-2010 01:21 AM
Need to get a full tank out of my car in a day..... lavid2002 Newbies & FAQs 22 12-18-2009 04:41 AM
anybody else not able to get on flscc.com? wako29 South East Region Forum 7 12-19-2003 01:41 PM
How many of you commit crimes to get money and goods to live? Instead of working. I ROBOT Off-Topic 38 10-01-2002 12:00 AM


All times are GMT -4. The time now is 06:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.