Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-16-2007, 09:46 PM   #1
Sawyerscooby
Scooby Newbie
 
Member#: 149122
Join Date: May 2007
Chapter/Region: SWIC
Location: Mesa AZ
Vehicle:
2006 WRX Stage II
Black w/ scratches

Default Shaking

so i went snowboarding up in flag today, and on the way back obviously keeping with pace of traffice i might add, i was averaging about 85-95mph depending, but a few times i had to break and my car was shaking really really bad, i was curious what this might be?
* Registered users of the site do not see these ads.
Sawyerscooby is offline   Reply With Quote
Old 12-16-2007, 09:48 PM   #2
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

rotors would cause that.
SubeSTIle is offline   Reply With Quote
Old 12-16-2007, 09:50 PM   #3
enominus
Scooby Specialist
 
Member#: 130622
Join Date: Oct 2006
Chapter/Region: SWIC
Location: AZIC Chandler
Vehicle:
1998 2.5RS

Default

maybe you got some snow/ice in the wheels that made it off balance? just a shot in the dark..
enominus is offline   Reply With Quote
Old 12-16-2007, 10:02 PM   #4
Sawyerscooby
Scooby Newbie
 
Member#: 149122
Join Date: May 2007
Chapter/Region: SWIC
Location: Mesa AZ
Vehicle:
2006 WRX Stage II
Black w/ scratches

Default

that may be it, i did screw around a lil and cut some cookies and spin around lol
Sawyerscooby is offline   Reply With Quote
Old 12-16-2007, 10:52 PM   #5
thegreg
Scooby Specialist
 
Member#: 105429
Join Date: Jan 2006
Chapter/Region: SWIC
Location: az
Vehicle:
2004 WRX STi
PSM

Default

got some snow/ice on the rotors...hit the brakes, made a hot spot....boom.. warped rotors!
thegreg is offline   Reply With Quote
Old 12-17-2007, 12:23 AM   #6
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

Quote:
Originally Posted by thegreg View Post
got some snow/ice on the rotors...hit the brakes, made a hot spot....boom.. warped rotors!
sounds like it.. or if they were really really hot
szeny is offline   Reply With Quote
Old 12-17-2007, 10:31 AM   #7
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

Did you brake hard??? abs? or of course warped rotors
racingfish is offline   Reply With Quote
Old 12-17-2007, 11:55 AM   #8
dust12
Scooby Specialist
 
Member#: 13417
Join Date: Dec 2001
Location: Phoenix, AZ
Vehicle:
2002 WRX
Blue

Default

Its kind've funny that you say your going 85-95 even though your brakes weren't working properly and your car was shaking bad. I'm glad to hear you made it back ok and didn't run anyone off the road.

Most likely you have warped rotors like a few other people said.
dust12 is offline   Reply With Quote
Old 12-17-2007, 04:28 PM   #9
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

^^ he said he was going that speed when he found out. not that he was going that sped after he found out. read it all (and pay attention) before you act like a pee-pee.
gormonk is offline   Reply With Quote
Old 12-18-2007, 04:11 AM   #10
John2.5RS
Scooby Guru
 
Member#: 1140
Join Date: Mar 2000
Chapter/Region: SCIC
Location: On the road
Vehicle:
2013 Ecoboost'd F150
Grey

Default

Check tire pressures, possible warped rotors, or maybe wheel balance issues (debris stuck to tire/wheel) Glad you made it back safely.
John2.5RS is offline   Reply With Quote
Old 12-18-2007, 09:32 AM   #11
Sawyerscooby
Scooby Newbie
 
Member#: 149122
Join Date: May 2007
Chapter/Region: SWIC
Location: Mesa AZ
Vehicle:
2006 WRX Stage II
Black w/ scratches

Default

lol thanks gormonk, no i obviously didnt know they where doing that till it happend...lol i drove to work and back yesterday tested it out, they seem fine, it may have been a combo of hot rotors, a long car ride high spead braking and having some snow it there, so i dont think their warped cause it didnt do it at all yesterday but we'll see how today goes..... and sad banana
Sawyerscooby is offline   Reply With Quote
Old 12-18-2007, 01:13 PM   #12
dhymers
Scooby Newbie
 
Member#: 166446
Join Date: Dec 2007
Default

I'm not sure, but the wapage could be very small and might only show up when braking from high-speed.

post count ftw!
dhymers is offline   Reply With Quote
Old 12-18-2007, 01:46 PM   #13
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

Sucks Jared..... Probably the ABS kicking in, you dont get that too much here in the never changing PHX weather.
Quote:
Originally Posted by dhymers View Post
I'm not sure, but the wapage could be very small and might only show up when braking from high-speed.

post count ftw!
mods have been known to reset post counts for that
v8eaterWRX is offline   Reply With Quote
Old 12-18-2007, 05:53 PM   #14
AaronB
Worst Mod Ever
Moderator
 
Member#: 369
Join Date: Oct 1999
Chapter/Region: SWIC
Location: Phoenix, AZ
Default

Quote:
Originally Posted by v8eaterWRX View Post
mods have been known to reset post counts for that
He only has 6, its not worth the time
AaronB is offline   Reply With Quote
Old 12-19-2007, 03:44 PM   #15
Sawyerscooby
Scooby Newbie
 
Member#: 149122
Join Date: May 2007
Chapter/Region: SWIC
Location: Mesa AZ
Vehicle:
2006 WRX Stage II
Black w/ scratches

Default

Quote:
Originally Posted by v8eaterWRX View Post
Sucks Jared..... Probably the ABS kicking in, you dont get that too much here in the never changing PHX weather.

mods have been known to reset post counts for that

brock my hero
Sawyerscooby is offline   Reply With Quote
Old 12-20-2007, 12:06 PM   #16
WorldWide
Scooby Newbie
 
Member#: 167017
Join Date: Dec 2007
Default

Newbie question... what's the post count get you?
WorldWide is offline   Reply With Quote
Old 12-20-2007, 12:19 PM   #17
DroppedClutch
Scooby Specialist
 
Member#: 52313
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Chandler, AZ
Vehicle:
2005 STiOmgWtfBbq20G
2007 MS3 Black

Default

Quote:
Originally Posted by WorldWide View Post
Newbie question... what's the post count get you?
When you get to 1000, Nick sends you $1000.
DroppedClutch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Braum's Peanut Butter Cup ice cream shake is the best shake in the world. BGPunk2001 Off-Topic 9 05-11-2009 02:42 PM
Vehicle Shaking at Highway speed. Intermittent shake. turbobird14 Transmission (AT/MT) & Driveline 0 01-07-2008 12:19 PM
Shake it. Shake it like a polaroid picture. Charge Off-Topic 6 09-23-2003 11:01 AM
Shake Shake Shake CFX27 Newbies & FAQs 16 05-22-2002 02:45 PM
('93-'01) Exhaust shakes alot... any Suggestions? kaos200 Impreza Forum 10 05-03-2001 04:05 PM


All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.