Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-08-2008, 01:20 PM   #101
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by bp_968 View Post
couple of questions I didn't see covered:

1> can this be used with the generic "ELM 327" units you see on ebay all the time (I have one I used for my other cars before I got my 06 STi this week).
No, but some of the generic obdii cables on ebay may work for logging only. As far as which ones, hard to say, you may want to do a search and see what people have had success with. With the cheap cables, you can sometimes run into driver issues.

Quote:
2> can it be used in *READ ONLY* mode (I have ZERO desire to tune yet. I want nothing to do with messing with the ECU right now. I only want the data!)
Then you just need to log.
* Registered users of the site do not see these ads.
Tea cups is offline   Reply With Quote
Old 10-25-2008, 11:13 AM   #102
V8 GTFO Lesbic WGN
Scooby Specialist
 
Member#: 191212
Join Date: Oct 2008
Chapter/Region: South East
Location: Nashboringville
Vehicle:
2007 FXT-5MT E85 20G
TD06SL2 TurboTektuning

Default

Can I use the CANBUS APv2 OBDII connector/USB cable to datalog on RomRaider? Or do I need Tactrix, I ONLY need to datalog. If I need drivers where to find them? Thx.
V8 GTFO Lesbic WGN is offline   Reply With Quote
Old 10-25-2008, 01:01 PM   #103
Noah
Rustle Crow
Moderator
 
Member#: 111510
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: Chicago area
Vehicle:
05 WRX
03 SV650S

Default

The old APv1 allowed for data logging on the older models. I would assume that you could do the same with the APv2 cable, but I may be wrong.
Noah is offline   Reply With Quote
Old 10-25-2008, 04:21 PM   #104
awdm666
Scooby Newbie
 
Member#: 187667
Join Date: Aug 2008
Chapter/Region: Tri-State
Location: new jersey
Vehicle:
2004 sti
jbp

Default

can someone point me in the direction of finding a map that i could download?
awdm666 is offline   Reply With Quote
Old 10-25-2008, 06:10 PM   #105
Noah
Rustle Crow
Moderator
 
Member#: 111510
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: Chicago area
Vehicle:
05 WRX
03 SV650S

Default

Noah is offline   Reply With Quote
Old 10-25-2008, 08:12 PM   #106
awdm666
Scooby Newbie
 
Member#: 187667
Join Date: Aug 2008
Chapter/Region: Tri-State
Location: new jersey
Vehicle:
2004 sti
jbp

Default

thanks alot bro...really appreciate it....trying to find a good map to use....my buddy keeps on telling me not to use an aggressive map...what do you think... i have a stock 06 wrx
awdm666 is offline   Reply With Quote
Old 10-25-2008, 10:02 PM   #107
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

no, you can't use the ap ver 2 cable for logging with romraider or reading/flashing with Ecuflash.
Tea cups is offline   Reply With Quote
Old 10-29-2008, 08:21 PM   #108
MrSlowbaru
Scooby Specialist
 
Member#: 129231
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Long Island NY
Vehicle:
2005 wrx
cgm

Default

can i use romraider with linux (ubuntu)?
MrSlowbaru is offline   Reply With Quote
Old 10-30-2008, 09:16 PM   #109
neversummer489
Scooby Specialist
 
Member#: 153729
Join Date: Jul 2007
Chapter/Region: NWIC
Location: Oregon
Vehicle:
PSM Bugeye
Missing rod bearing??

Default

may have been coverd but there are 5 pages and i just need a quick answer, with romraider on the 2.0 cable there are no definitions or a logger with it so where do i store them? sorry new to this
neversummer489 is offline   Reply With Quote
Old 10-30-2008, 09:53 PM   #110
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by neversummer489 View Post
may have been coverd but there are 5 pages and i just need a quick answer, with romraider on the 2.0 cable there are no definitions or a logger with it so where do i store them? sorry new to this
DL them and use the Ecu Definition Manager and the logger definition manager with RomRaider 0.5.1b RC4 to add them.
Tea cups is offline   Reply With Quote
Old 11-01-2008, 07:18 PM   #111
neversummer489
Scooby Specialist
 
Member#: 153729
Join Date: Jul 2007
Chapter/Region: NWIC
Location: Oregon
Vehicle:
PSM Bugeye
Missing rod bearing??

Default

cool thanks got it
neversummer489 is offline   Reply With Quote
Old 11-17-2008, 06:18 AM   #112
bereda
Scooby Scammer- Do Not Buy From User
 
Member#: 192034
Join Date: Oct 2008
Vehicle:
2004 2.5rs
red

Default

is there even away to flash a 2004 rs.. any way or can i replace the ecu with a newer better moddel oem or aftermarket
bereda is offline   Reply With Quote
Old 11-17-2008, 07:29 AM   #113
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by bereda View Post
is there even away to flash a 2004 rs.. any way or can i replace the ecu with a newer better moddel oem or aftermarket
No, there's no way to flash 2004 and prior NA models. You cannot swap in a newer ECU (i.e. 2005+ N/A) as those cars have drive-by-wire throttle (and even if it didn't still wouldn't likely be compatible). Swapping in a standalone ECU would be possible but outside the scope of an open source reflash discussion and not worth the cost unless you've added a turbo, etc.
Tea cups is offline   Reply With Quote
Old 11-26-2008, 05:58 AM   #114
V8 GTFO Lesbic WGN
Scooby Specialist
 
Member#: 191212
Join Date: Oct 2008
Chapter/Region: South East
Location: Nashboringville
Vehicle:
2007 FXT-5MT E85 20G
TD06SL2 TurboTektuning

Default

I am trying to datalog for the first time with the Openport 2.0 cable. I am choosing the right com port 4 (Openport 2.0) but cannot connect to the ecu. Have the latest defs and all.

Do I need to add the Ecuflash defs to the ECU Manager in order to log? I only have the Romraider ECU def loaded in in ECU Manager but none of the 20 or so Ecuflash defs. Just trying to figure out what's going on.

Last edited by V8 GTFO Lesbic WGN; 11-26-2008 at 06:23 AM.
V8 GTFO Lesbic WGN is offline   Reply With Quote
Old 11-26-2008, 08:15 AM   #115
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by V8 GTFO Lesbic WGN View Post
I am trying to datalog for the first time with the Openport 2.0 cable. I am choosing the right com port 4 (Openport 2.0) but cannot connect to the ecu. Have the latest defs and all.

Do I need to add the Ecuflash defs to the ECU Manager in order to log? I only have the Romraider ECU def loaded in in ECU Manager but none of the 20 or so Ecuflash defs. Just trying to figure out what's going on.
No, Ecuflash defs do not go in the ECU definition manager for RomRaider. Are you using RomRaider test release 0.5.1b RC5 found in the development forum at the RomRaider site? If so, make sure you are not using an old shortcut - should read "0.5.1b RC5" in the title bar when you are running RomRaider. You also need to install Ecuflash 1.40 and do the firmware update if necessary. The firmware update for the OP 2.0 occurs in Ecuflash when you attempt to read from the ECU - so do that first.

EDIT: Also, if you are running Vista, make sure you install RomRaider as an admin by right-clicking the RR installer and selecting "run as admin". You may also need to do the same thing when you run RomRaider (romraider.exe).

Last edited by Tea cups; 11-26-2008 at 08:33 AM.
Tea cups is offline   Reply With Quote
Old 11-26-2008, 09:53 AM   #116
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim TQ monster

Default

Quote:
Originally Posted by Tea cups View Post
EDIT: Also, if you are running Vista, make sure you install RomRaider as an admin by right-clicking the RR installer and selecting "run as admin". You may also need to do the same thing when you run RomRaider (romraider.exe).
I had to do just that in Vista. You have to run RR as admin for the OP 2.0 for some reason to get the logger to connect...
gabedude is offline   Reply With Quote
Old 11-26-2008, 11:51 AM   #117
V8 GTFO Lesbic WGN
Scooby Specialist
 
Member#: 191212
Join Date: Oct 2008
Chapter/Region: South East
Location: Nashboringville
Vehicle:
2007 FXT-5MT E85 20G
TD06SL2 TurboTektuning

Default

Running:

- XP
- Romraider 0.5.0 Beta Build # 83 =>> I will uninstall and load 0.5.1b RC5.
- EcuFlash 1.40.2178

".....The firmware update for the OP 2.0 occurs in Ecuflash when you attempt to read from the ECU - so do that first...."

I interpret the above comment as :

1. Run EcuFlash and hit the "Read from ECU" icon. Doing so creates the vehicle interface between ECU and OP 2.0 cable.

2. Run Romraider and start logging.

Part of my confusion aside from running the Beta version of Romraider was I just wanted to log and did not think it was necessary to read my ECU first on EcuFlash.

I will try the above two steps and report back.
V8 GTFO Lesbic WGN is offline   Reply With Quote
Old 11-26-2008, 01:12 PM   #118
V8 GTFO Lesbic WGN
Scooby Specialist
 
Member#: 191212
Join Date: Oct 2008
Chapter/Region: South East
Location: Nashboringville
Vehicle:
2007 FXT-5MT E85 20G
TD06SL2 TurboTektuning

Default

It finally worked (Tea Cups thank you). I am able to log now on my CAN BUS 07 FXT with OP 2.0

I was not able to read the ROM but the fact of starting EcuFlash first (before opening RomRaider) and trying to read the ECU must have loaded the OP2.0 missing driver and allowed me to finally be able to datalog.

This is the error message, just for giggles as I am not interested in copying or flashing my ROM at this time, I just want to datalog.

14:51:28.731] Version 1.40.2178
[14:51:28.751] 19 memory models read.
[14:51:28.751] scanning for metadata models in C:/Program Files/OpenECU/EcuFlash/rommetadata
[14:51:29.031] 308 ROM metadata models scanned.
[14:51:29.031] checksum module "subarudbw" loaded.
[14:51:29.031] flashing tool "wrx02" loaded.
[14:51:29.031] flashing tool "wrx04" loaded.
[14:51:29.031] flashing tool "sti04" loaded.
[14:51:29.031] flashing tool "sti05" loaded.
[14:51:29.031] flashing tool "mitsukernel" loaded.
[14:51:29.031] flashing tool "mitsukernelocp" loaded.
[14:51:29.031] flashing tool "shbootmode" loaded.
[14:51:29.031] flashing tool "shaudmode" loaded.
[14:51:29.031] flashing tool "subarucan" loaded.
[14:53:23.406] J2534 API Version: 04.04
[14:53:23.406] J2534 DLL Version: 0.50.2176 Oct 20 2008 17:50:12
[14:53:23.406] Device Firmware Version: 1.01.2145
[14:53:42.433] kernel get version
[14:53:42.703] SSM2 init
[14:53:42.753] SSM2 ECU ID is 4E 12 58 41 07
[14:53:42.804] Requesting Seed...
[14:53:42.854] Sending Key...
[14:53:42.894] interface close

Last edited by V8 GTFO Lesbic WGN; 11-26-2008 at 03:45 PM.
V8 GTFO Lesbic WGN is offline   Reply With Quote
Old 11-27-2008, 10:54 AM   #119
crashtke
Scooby Specialist
 
Member#: 120912
Join Date: Jul 2006
Chapter/Region: South East
Location: Atlanta, GA
Default

So were you able to log with the AP v2 cable?
crashtke is offline   Reply With Quote
Old 11-27-2008, 10:59 AM   #120
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by V8 GTFO Lesbic WGN View Post
It finally worked (Tea Cups thank you). I am able to log now on my CAN BUS 07 FXT with OP 2.0

I was not able to read the ROM but the fact of starting EcuFlash first (before opening RomRaider) and trying to read the ECU must have loaded the OP2.0 missing driver and allowed me to finally be able to datalog.
It writes the new firmware to the cable by doing this. The firmware has to be compatible with the OP 2.0 DLL that is installed by Ecuflash, otherwise it won't work, which is what your problem was. As far as the Ecuflash read failure, you need to make sure you are in test mode first. Also, could be your timing between turning the ignition on and starting the read. Read the Ecuflash troubleshooting section of the RomRaider FAQ.
Tea cups is offline   Reply With Quote
Old 11-27-2008, 11:51 AM   #121
dwmoss_68
Scooby Specialist
 
Member#: 6030
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Northeastern PA , USA
Vehicle:
04 Gold FXT
07 WRB FXT Sport

Default

Tea Cups,
Thanks for all your time and effort with all the questions.
Happy Thanksgiving!
dm
dwmoss_68 is offline   Reply With Quote
Old 11-27-2008, 12:31 PM   #122
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by dwmoss_68 View Post
Tea Cups,
Thanks for all your time and effort with all the questions.
Happy Thanksgiving!
dm
no problem.
Happy Thanksgiving!
Tea cups is offline   Reply With Quote
Old 11-27-2008, 12:37 PM   #123
V8 GTFO Lesbic WGN
Scooby Specialist
 
Member#: 191212
Join Date: Oct 2008
Chapter/Region: South East
Location: Nashboringville
Vehicle:
2007 FXT-5MT E85 20G
TD06SL2 TurboTektuning

Default

Quote:
Originally Posted by crashtke View Post
So were you able to log with the AP v2 cable?
No, I ended up buying the Tactrix OP2.0.
V8 GTFO Lesbic WGN is offline   Reply With Quote
Old 11-27-2008, 02:36 PM   #124
crashtke
Scooby Specialist
 
Member#: 120912
Join Date: Jul 2006
Chapter/Region: South East
Location: Atlanta, GA
Default

Ah ok, seems like it would just take a driver for the dongle or something in order to be able to use the AP2 cable...
crashtke is offline   Reply With Quote
Old 01-04-2009, 10:07 PM   #125
Zornorph
Scooby Specialist
 
Member#: 17332
Join Date: Apr 2002
Chapter/Region: NESIC
Location: The neighbor's yard
Vehicle:
2004 Black STI
Not stock anymore

Default

Noob to this , having problem with Romraider

I successfully downloaded the rom from the car, and saved it. When I try t open it in Romraider, the progress bar says promising things, such as creating tables, populating tables, finalizing, then done, bu the screen stays black, nothing else.

Latest Java installed, all the latest ecu def's installed, ect.

Any ideas?
Zornorph is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
romraider/ecuflash? weaponstroop Open Source Reflashes 8 10-21-2008 10:04 AM
reading logs - FAQ or getting started guide? jmc9809 Newbies & FAQs 2 08-05-2005 06:40 PM
I want to get started racing! Where to start? wayne_rx Motorsports 27 12-23-2004 03:00 AM
Auto-Xing Newbe, How to get started? Ed_RS New England Impreza Club Forum -- NESIC 7 01-31-2001 11:34 AM
how to get started jjp New England Impreza Club Forum -- NESIC 5 11-09-2000 06:26 AM


All times are GMT -4. The time now is 08:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.