Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-29-2007, 05:48 PM   #1
jmodica
Scooby Newbie
 
Member#: 157508
Join Date: Aug 2007
Chapter/Region: South East
Location: Florida
Vehicle:
2002 Impreza WRX
World Rally Blue

Question Clicking sound between 2k and 3k rpm

I've noticed when I accelerate and let off the gas between 2000 and 3000 rpm, as the car slows down there is a quick clicking noise coming from the drivers side of the car... I have a 02 WRX with up and down pipes and exhaust... I have an AP that I have flashed a stage 2 map to... Does anyone have an idea of what the clicking is... I have been having issues hitting target boost, only 9 psi... I'm starting to think this click is part of the problem...
* Registered users of the site do not see these ads.
jmodica is offline   Reply With Quote
Old 12-29-2007, 06:41 PM   #2
fastlanerex
Scooby Specialist
 
Member#: 133391
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Delaware
Vehicle:
2004 boosted saleen
white

Default

sounds like it could be a pre-turbo exhaust leak. More than likley coming from the uppipe check for black exhaust gases staind on the pipe around all the gaskets and your egt probe on the upipipe.
fastlanerex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noise @ 2k and 3k RPMs Sean2.5Black Pre-2002 Factory Turbo Powertrain 2 02-07-2010 03:44 AM
Whine between 2k-2.5k rpms Mike37 Transmission (AT/MT) & Driveline 1 02-23-2009 04:34 PM
clicking noise at 2k and under WrxWonderWagon Factory 2.5L Turbo Powertrain 8 02-16-2007 11:40 AM
car idles between 1250 and 1700 rpms cold hotshot172 Factory 2.0L Turbo Powertrain 9 12-05-2005 11:51 PM
need a noise Identified, Rattling between 1800 and 2000 rpm MarkyMark Factory 2.0L Turbo Powertrain 3 05-10-2003 08:46 PM


All times are GMT -4. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.