Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-08-2014, 02:54 PM   #1
mbhammerbro
Scooby Specialist
 
Member#: 344521
Join Date: Jan 2013
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2013 STi
DGM

Default Vent on Bumper

Hey guys, not sure if this is the right forum so if it isn't please move it?

I've got an issue with the right rear vent on my bumper. I found it hanging out today, because one of the slots that the bumper clips hold onto was broken. Not sure how this happened, but I just wanted to see if anyone else has had this issue. And if any way to deal with it without replacing it. It seems like it holds fine now that I pushed it back into the clips, but I don't want it to fall again since it's using 2 clips instead of three.

I'm not sure if everything I said is confusing, but there is a picture below of the part I am talking about.

Thanks.

* Registered users of the site do not see these ads.
mbhammerbro is offline   Reply With Quote
Old 02-08-2014, 03:07 PM   #2
bbun
Scooby Specialist
 
Member#: 184554
Join Date: Jul 2008
Chapter/Region: SCIC
Location: Orange County
Vehicle:
02 ghettoFABness
bugeye rolling.

Default

gorilla glue
bbun is offline   Reply With Quote
Old 02-08-2014, 04:35 PM   #3
xxEvolve
Scooby Newbie
 
Member#: 336719
Join Date: Nov 2012
Chapter/Region: TXIC
Location: El Paso, Texas
Vehicle:
2004 Deer Destroyer
AW

Default

VHB double sided tape? Or Gorilla glue as previously stated. Its kinda obvious since your clips are broken lol
xxEvolve is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.