Welcome to the North American Subaru Impreza Owners Club Tuesday July 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-30-2007, 12:30 PM   #1
07Wagon
Scooby Newbie
 
Member#: 152718
Join Date: Jun 2007
Chapter/Region: BAIC
Location: Citrus Heights, CA
Vehicle:
2004 WRX Wagon

Default CEL came on, and Cruise Control light is flashing

Anyone know what that signifies?
* Registered users of the site do not see these ads.
07Wagon is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-30-2007, 12:42 PM   #2
STIBungy
Scooby Specialist
 
Member#: 51684
Join Date: Jan 2004
Location: CO
Default

Holy crap, another one of these!

Step 1: go to an auto parts store or anyplace that has an OBD-II scanner and have them pull the code that's causing the CEL

Step 2: google and search on here the code and there should be some troubleshooting tips

Step 3: fix yo *****!
STIBungy is offline   Reply With Quote
Old 12-30-2007, 12:43 PM   #3
dougb76
Scooby Newbie
 
Member#: 160340
Join Date: Sep 2007
Location: Burlington MA
Vehicle:
2009 wrx 5 door
RIP

Default

do this^^^

Could be a lot of things. have you done any mods? What were you doing when this happened?
dougb76 is offline   Reply With Quote
Old 12-30-2007, 12:44 PM   #4
dumpstercrusher
Scooby Specialist
 
Member#: 134940
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Glen Burnie, MD
Vehicle:
2006 Impreza WRX TR
vf39 ewg tuned ppg gears

Default

You have just overboosted..I get that all the time in 4th gear. Kinda weird for you cause I never had that happen to me when i was stage 2. Anyways I think the only way to fix is maybe a protune. So im saving up and getting me a protune. =)
dumpstercrusher is offline   Reply With Quote
Old 12-30-2007, 12:45 PM   #5
07Wagon
Scooby Newbie
 
Member#: 152718
Join Date: Jun 2007
Chapter/Region: BAIC
Location: Citrus Heights, CA
Vehicle:
2004 WRX Wagon

Default

Well, I have an Invidia catted DP, HKS Hi-Power exhaust, and the stage 2 map. I was just idling waiting for the car to warm up when it started. I was just seeing if anyone knew offhand what those 2 together meant, if not I was going to go to the store.
07Wagon is offline   Reply With Quote
Old 12-30-2007, 12:48 PM   #6
dumpstercrusher
Scooby Specialist
 
Member#: 134940
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Glen Burnie, MD
Vehicle:
2006 Impreza WRX TR
vf39 ewg tuned ppg gears

Default

you could always try to pull the code up from your access port and if you want the cruise control light and the CEL to go away just turn off and turn on your car about 4-5 times. It will go away.
dumpstercrusher is offline   Reply With Quote
Old 12-30-2007, 01:12 PM   #7
mapleleaf
Scooby Specialist
 
Member#: 103399
Join Date: Dec 2005
Chapter/Region: E. Canada
Location: Halifax, Nova Scotia
Vehicle:
2009 Stripped STI
Dirty White

Default

Check the code with your AP(might have been the smartest thing to due before you posted), reset your ECU and reflash your Realtime map if you use one. If it's an overboost code, you may want to get someone to adjust your WGDC accordingly and do a few data logs.
mapleleaf is offline   Reply With Quote
Old 12-30-2007, 01:14 PM   #8
mapleleaf
Scooby Specialist
 
Member#: 103399
Join Date: Dec 2005
Chapter/Region: E. Canada
Location: Halifax, Nova Scotia
Vehicle:
2009 Stripped STI
Dirty White

Default

Quote:
Originally Posted by 07Wagon View Post
Well, I have an Invidia catted DP, HKS Hi-Power exhaust, and the stage 2 map. I was just idling waiting for the car to warm up when it started. I was just seeing if anyone knew offhand what those 2 together meant, if not I was going to go to the store.

You were idling when it threw the code?
Look up the code ASAP.
mapleleaf is offline   Reply With Quote
Old 12-30-2007, 01:24 PM   #9
07Wagon
Scooby Newbie
 
Member#: 152718
Join Date: Jun 2007
Chapter/Region: BAIC
Location: Citrus Heights, CA
Vehicle:
2004 WRX Wagon

Default

AP can't pull the code, Advance Auto Parts doesn't have the ability, Firestone was too busy. I'm headed to the on-post auto shop, and if they can't help me, I'll hit the nearest Autozone.
07Wagon is offline   Reply With Quote
Old 12-30-2007, 01:34 PM   #10
STIBungy
Scooby Specialist
 
Member#: 51684
Join Date: Jan 2004
Location: CO
Default

Just go to Autozone first. They've always been helpful with pulling codes. I send alot of local peeps there when I dont have my laptop with me to check for them.
STIBungy is offline   Reply With Quote
Old 12-30-2007, 01:39 PM   #11
mapleleaf
Scooby Specialist
 
Member#: 103399
Join Date: Dec 2005
Chapter/Region: E. Canada
Location: Halifax, Nova Scotia
Vehicle:
2009 Stripped STI
Dirty White

Default

Quote:
Originally Posted by 07Wagon View Post
AP can't pull the code, Advance Auto Parts doesn't have the ability, Firestone was too busy. I'm headed to the on-post auto shop, and if they can't help me, I'll hit the nearest Autozone.
That's strange.
Do you have ECUexplorer?
Download it on your laptop and pull the code.
mapleleaf is offline   Reply With Quote
Old 12-30-2007, 02:52 PM   #12
07Wagon
Scooby Newbie
 
Member#: 152718
Join Date: Jun 2007
Chapter/Region: BAIC
Location: Citrus Heights, CA
Vehicle:
2004 WRX Wagon

Default

p0304 is the code that autozone came up with, misfire in cylinder #4.
07Wagon is offline   Reply With Quote
Old 12-30-2007, 03:10 PM   #13
a6n6d6y
Scooby Specialist
 
Member#: 123347
Join Date: Aug 2006
Chapter/Region: NWIC
Location: SEATTLE
Vehicle:
1993 POS
burgandy legacy

Default

reset and go on your way ,if it keeps happening I see a dealer in your future (warranty)
a6n6d6y is offline   Reply With Quote
Old 12-30-2007, 03:16 PM   #14
a6n6d6y
Scooby Specialist
 
Member#: 123347
Join Date: Aug 2006
Chapter/Region: NWIC
Location: SEATTLE
Vehicle:
1993 POS
burgandy legacy

Default

Quote:
Originally Posted by 07Wagon View Post
AP can't pull the code, Advance Auto Parts doesn't have the ability, Firestone was too busy. I'm headed to the on-post auto shop, and if they can't help me, I'll hit the nearest Autozone.
what does th AP say when you try to pull the code
a6n6d6y is offline   Reply With Quote
Old 12-31-2007, 12:12 PM   #15
07Wagon
Scooby Newbie
 
Member#: 152718
Join Date: Jun 2007
Chapter/Region: BAIC
Location: Citrus Heights, CA
Vehicle:
2004 WRX Wagon

Default

AP said that there was no code. I reset the ECU, hasn't repeated thus far.
07Wagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
Blinking Cruise Control, CEL, Tire Pressure, AND Traction Control Lights ALL on The Database Electrical & Lighting 5 03-14-2010 03:32 AM
Check engine light, VDC light is on, and cruise control and sport light is flashing Legacymun2k6 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 01-30-2010 12:47 PM
CEL on and cruise control light flashing silversurfer307 Service & Maintenance 0 01-11-2008 08:08 PM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 01-23-2005 02:04 PM


All times are GMT -4. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.