Welcome to the North American Subaru Impreza Owners Club Saturday August 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-18-2008, 02:36 AM   #1
scorpokat3
Scooby Newbie
 
Member#: 168080
Join Date: Jan 2008
Chapter/Region: NWIC
Location: Pullman
Vehicle:
2008 Impreza WRX STi
DGM

Default 2008 Impreza rock chips. Post your issues.

So I searched over there forums a bit and nobody has posted anything big about rock chips on their new 2008 Imprezas. A few have mentioned it in nonspecific threads.

I have a new 2008 STi and I am at 2000 miles (got the car 12/17/07). The rocks chips are down to the primer and metal in some places from the front wheels kicking up the damn traction gravel the city lays down because of the snow. The rear door jam is down to metal and the wheel flares look sand blasted. I can't believe Subaru didn't see this coming!!!

I have been talking with the dealer I bought the car from and they took an interest. They have looked it over and sent information to Subaru. Subaru has also come back with an interest and requested photos. I sent those out today. I'm hoping they help out with the problem.

I understand that this is a brand new body style that hasn't gone through a whole lot of road worthy testing. I'm sure Subaru is very interested with any customer input so they can fix the problems. I'm just a little upset that they did not foresee this potential. I'm surprised even more that the STi (a nearly $40k vehicle) did not come with any kind of protection from flying debris picked up by the tires. There are no factory mud flaps and the factory sticky summer tires stick out of the wheel wells about 3/4". There is a small portion of clear adhesive decal protector at the front of the rear wheel well but it's pretty worthless.

If anyone has a 2008 model Impreza with the same problems please post it. I'm curious to see how many are having the same problem. Also, please post if you contacted the dealer or Subaru about it. Has anyone had any luck with getting this taken care of?

The follow pictures were taken right after a wash and wax at a local car detail shop in their parking lot. The specks are all chips. After the wash and wax I went over the car with a spray detailer and towel to ensure no dirt was on the car during the shots.

You can see higher resolution photos at my Flickr album.
http://www.flickr.com/photos/devincp/








Name: Devin Prewett
Year: 2008
Make/Model: Subaru Impreza WRX STi
Color: Dark Grey Metallic
Dealership/City: Ambassador Subaru / Moscow, Idaho
Car's Location: Pullman, Washington

Thanks much, Devin
* Registered users of the site do not see these ads.

Last edited by scorpokat3; 02-09-2008 at 04:51 AM.
scorpokat3 is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-18-2008, 02:42 AM   #2
stierzy34
Scooby Specialist
 
Member#: 92113
Join Date: Jul 2005
Chapter/Region: MWSOC
Location: Belleville, IL
Vehicle:
2013 Mini Cooper S
"Martha"

Default

holy crap! i thought my paint was bad. that sucks man, I hope they do something about it
stierzy34 is offline  
Old 01-18-2008, 02:47 AM   #3
WRXjp93
Scooby Newbie
 
Member#: 94346
Join Date: Aug 2005
Location: Misawa JAPAN
Vehicle:
'92 Nissan 180SX
Black

Default

man they definitely need to do something about that. that **** is just unacceptable...especially for such a new car. my car is a 92 and doesnt even have that kinda crap happening to it.
WRXjp93 is offline  
Old 01-18-2008, 03:03 AM   #4
jigga
Scooby Guru
 
Member#: 9960
Join Date: Sep 2001
Location: in bed...
Vehicle:
2002 Impreza WRX
WRBlue Perl

Default

ouch! At 2000 miles too! Imagine what the thing will look like at 10K miles!
jigga is offline  
Old 01-18-2008, 03:09 AM   #5
coast_rider
Scooby Specialist
 
Member#: 146956
Join Date: Apr 2007
Chapter/Region: South East
Location: Fort Walton Beach
Vehicle:
2003 WRX Impreza
PSM

Default

Although they're not out yet I believe you should definitely pick up a set of rally armor mud flaps once they're released. I know that doesn't solve the paint issue which is in itself absolutely horrible, it will help to decrease and/or stop this in some areas of the vehicle. For all the damage already done to your brand new sti, words escape me.
coast_rider is offline  
Old 01-18-2008, 03:21 AM   #6
scorpokat3
Scooby Newbie
 
Member#: 168080
Join Date: Jan 2008
Chapter/Region: NWIC
Location: Pullman
Vehicle:
2008 Impreza WRX STi
DGM

Default

Quote:
Originally Posted by coast_rider View Post
Although they're not out yet I believe you should definitely pick up a set of rally armor mud flaps once they're released. I know that doesn't solve the paint issue which is in itself absolutely horrible, it will help to decrease and/or stop this in some areas of the vehicle. For all the damage already done to your brand new sti, words escape me.
I inquired on the Rally Armour UR mud flaps the first week I had the car... It really sucks I have to wait... I sent them another e-mail recently. I hope they have them soon!

Hey! Rally Armor! I'll poster them for you!

-Devin
scorpokat3 is offline  
Old 01-18-2008, 03:36 AM   #7
fastwrx25
Scooby Guru
 
Member#: 126441
Join Date: Sep 2006
Chapter/Region: SCIC
Location: TPE
Vehicle:
03 bugeye

Default

welcome to the world of subaru!!!
fastwrx25 is offline  
Old 01-18-2008, 03:53 AM   #8
scorpokat3
Scooby Newbie
 
Member#: 168080
Join Date: Jan 2008
Chapter/Region: NWIC
Location: Pullman
Vehicle:
2008 Impreza WRX STi
DGM

Default

Quote:
Originally Posted by fastwrx25 View Post
welcome to the world of subaru!!!
Are you saying I bough the wrong brand vehicle? I love Subaru though...

-Devin
scorpokat3 is offline  
Old 01-18-2008, 04:46 AM   #9
Spoolin415
Scooby Newbie
 
Member#: 164074
Join Date: Nov 2007
Default

Crappy design/no foresight used in the design. That coupled with crappy PNW winter roads = your dilemma. Hope they can help you.
Spoolin415 is offline  
Old 01-18-2008, 05:14 AM   #10
retroXvertigo
Scooby Specialist
 
Member#: 118922
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2007 Doggy Doo
Sno-cone

Default

Quote:
Originally Posted by scorpokat3 View Post
Are you saying I bough the wrong brand vehicle? I love Subaru though...

-Devin
you bought the right vehicle. Subary paint isn't the best out there though. I have an 07 STI with a few good rock chips in it.
retroXvertigo is offline  
Old 01-18-2008, 05:23 AM   #11
soji
Scooby Specialist
 
Member#: 87178
Join Date: May 2005
Chapter/Region: MAIC
Location: Valencia, PA
Vehicle:
2003 Japanese Spec
Impreza STi

Default

Wow I can already hear the SOA denying your claim cause you don't have the potenza's on, I hope thats not your case
soji is offline  
Old 01-18-2008, 05:26 AM   #12
nhmtns
Scooby Guru
 
Member#: 94283
Join Date: Aug 2005
Chapter/Region: NESIC
Location: Mt. Washington Valley, NH
Vehicle:
'05 OBXT Stage 2
Min bil är svart

Default

It sucks that the '08 STI's are arriving om the east coast during winter, because if I buy one I'd rather wait until spring to have one less winter of driving to destroy the body. By spring I bet they'll be nearly impossible to find.

Seems like my wagon is covered in salt and dirt all winter long. Washing it is almost futile because the roads around here are never clear during winter. Mudflaps are helpful but road grime still gets everywhere.

nhmtns is offline  
Old 01-18-2008, 06:11 AM   #13
blacktrail
Scooby Specialist
 
Member#: 154841
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Davidsonville, MD
Vehicle:
2002 white
johnny tran

Default

Ouch, gl with everything. I'm sure they'll do something though since its still a new car.
blacktrail is offline  
Old 01-18-2008, 06:45 AM   #14
Spenk
Scooby Guru
 
Member#: 7164
Join Date: Jun 2001
Location: Arizona Bay
Vehicle:
2000 Miata LS
Evo Orange Mica (1/644)

Default

Yep. That's definately a Subaru paintjob!



Now that Subaru is charging BMW/Audi/Infiniti $$ for the STI, you'd think they might have upgraded the paint quality and process.

NOT!
Spenk is offline  
Old 01-18-2008, 07:07 AM   #15
06STIGO13
Scooby Specialist
 
Member#: 110526
Join Date: Mar 2006
Chapter/Region: MWSOC
Location: St. Louis(Chesterfield), MO
Vehicle:
2007 STI Ltd 306 UGM
2008 STI Nav & BBS AW

Default

Quote:
Originally Posted by scorpokat3 View Post
I'm sure Subaru is very interested with any customer input so they can fix the problems.

Yeah... I'm sure they are!
















06STIGO13 is offline  
Old 01-18-2008, 08:08 AM   #16
WRXLTD
Scooby Specialist
 
Member#: 136314
Join Date: Jan 2007
Location: A$$achusetts
Vehicle:
2014 Grand Cherokee

Default

This thread makes me want to by an 08 STI even more...



I hope Subaru does something for you, sucks to have things like this happen to a new car.
WRXLTD is offline  
Old 01-18-2008, 08:32 AM   #17
obs2008
Scooby Newbie
 
Member#: 163068
Join Date: Oct 2007
Location: Jersey
Vehicle:
08 outback sport

Default

wow sucks to see that. i have an 08 impreza with about 3 or four good chips on my a pillars. the weird thing is i have no chips anywhere else, so all i can contribute it to is crappy chipping pain on the pillars. iv been meaning to get my car over to the dealership to have them take a look at it. im sure they will not do anything about it, but id at least like to have it on record so when it gets worse down the road i can tell them that i brought it in when it was new to show them. hopefully this wont be a problem with all the 08's
obs2008 is offline  
Old 01-18-2008, 09:00 AM   #18
Mechie3
Scooby Guru
 
Member#: 120152
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: Indy
Default

Buy a pair of cheapie universal mudflaps for now. I did that for a winter before getting rally armor flaps. Not the prettiest or best, but better than nothing.
Mechie3 is offline  
Old 01-18-2008, 10:36 AM   #19
dees421
Scooby Specialist
 
Member#: 156291
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Nampa, Idaho
Vehicle:
2008 Impreza 2.5i
DGM

Default

I've posted my pics a couple times but I'll add to this thread. This was at 3300-3500 miles. I got back from a trip to the mountains and washed it, that's when I noticed it.

I have been to the dealer and they took pictures to submit to SOA and there is suppose to be a guy coming to test the thickeness of the paint. I have the OEM spash guards which according to subaruparts.com (are suppose to help protect your vehicles paint finish from stones and road grime). I noticed last night when I washed my car that I have chips on both doors now below the crease, along with the other chips in the pictures below. I did find some rust already on a few of the chips.

Year: 08 2.5i DGM
Mileage: 3500
Contacted: Dealership (Team Mazda/Subaru)
Action: They took pictures to submit to SOA
Time: It's been 2 weeks and havent heard anything back.



dees421 is offline  
Old 01-18-2008, 10:42 AM   #20
Hondaslayer
think you
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

Wow, that is weird.

Looks like both cars are dark gray as well.

I saw this thread and thought it was going to be the usual 2-3 rock chips on the hood edge, but this is definately an issue.

Got any pics with a clean car?
Hondaslayer is offline  
Old 01-18-2008, 10:45 AM   #21
Rallyarmor
NASIOC Manufacturer
 
Member#: 44856
Join Date: Oct 2003
Location: NYC
Vehicle:
1999 Impreza WRX
Rally Blue

Default

Quote:
Originally Posted by scorpokat3 View Post
I inquired on the Rally Armour UR mud flaps the first week I had the car... It really sucks I have to wait... I sent them another e-mail recently. I hope they have them soon!

Hey! Rally Armor! I'll poster them for you!

-Devin

Hi Devin, We have responded to your request.


Thanks much
Costas @ R/A
Rallyarmor is offline  
Old 01-18-2008, 10:49 AM   #22
dees421
Scooby Specialist
 
Member#: 156291
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Nampa, Idaho
Vehicle:
2008 Impreza 2.5i
DGM

Default

Quote:
Originally Posted by hondaslayer View Post
Got any pics with a clean car?
Both cars are clean, mine just looks like that cause I drove it from the do-it-yourself car wash about 3 miles away from my house so I could grab the camera and take pictures. .
dees421 is offline  
Old 01-18-2008, 10:52 AM   #23
scorpokat3
Scooby Newbie
 
Member#: 168080
Join Date: Jan 2008
Chapter/Region: NWIC
Location: Pullman
Vehicle:
2008 Impreza WRX STi
DGM

Default

Quote:
Originally Posted by Rallyarmor View Post
Hi Devin, We have responded to your request.


Thanks much
Costas @ R/A
I e-mailed you the pictures you requested. I hope it works out.

Thanks very much, Devin
scorpokat3 is offline  
Old 01-18-2008, 10:54 AM   #24
Cooter05WRX
Scooby Specialist
 
Member#: 110567
Join Date: Mar 2006
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2009 JK
Sunburst Orange

Default

yeah subaru paint doesn't hold up well to rock chips. My neighbor offered to add a nice thick clear coat to my car for $300 when i got my 05 and I said no. Now I wish i would have taken him up on the offer.
Cooter05WRX is offline  
Old 01-18-2008, 01:38 PM   #25
Loubaru
Scooby Specialist
 
Member#: 155489
Join Date: Jul 2007
Chapter/Region: NWIC
Location: NW WA
Vehicle:
07 STi

Default

Wow... thats really bad! My 07 has ~6.5k miles and doesn't have any sand blasting like that (put RAs on at ~4k miles). If my paint was as thing as yours mine should be just as bad or worst... I wonder if this is an 08 only thing?
Loubaru is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'08 Impreza Rock chip/paint issues registry jimmi Warranty Issues & SOA Problems 323 02-09-2013 03:32 PM
post your favorite rock intros BobbyV Off-Topic 157 03-28-2012 07:04 PM
2008 Impreza OBS Hatch Water-Trapping Issue roobaroo Newbies & FAQs 0 10-20-2008 06:53 PM
The 2008 Impreza Photoshop thread...post them here adizon Member's Car Gallery 307 09-19-2007 11:36 PM
FMIC owners!!! What did you do about getting rock chips to your FMIC?? STR8OUT Interior & Exterior Modification 7 11-13-2002 12:29 PM


All times are GMT -4. The time now is 07:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.