Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-02-2002, 11:08 PM   #1
gingerbread man
Scooby Newbie
 
Member#: 12712
Join Date: Nov 2001
Location: Scenic (ha-ha) Nitro, West Vir
Vehicle:
1993 impreza wagon
L. blue (rolled my WRX)

Default ECU problems??

Speedometer reads 60 mph when I am sitting in my driveway, then jumps around 20mph in both directions at highway speeds. When decelerating, the tach goes to zero and the CEL flashes. The coolant temperature light twitches like its on acid and I am getting 18 miles per gallon without ever allowing the car to come under boost. Anyone else have problems like these?
Jason
* Registered users of the site do not see these ads.
gingerbread man is offline   Reply With Quote
Old 02-03-2002, 11:01 AM   #2
WRXSTi69
Scooby Newbie
 
Member#: 12012
Join Date: Nov 2001
Default

The ECU does not control the speedometer. The speedo is electronic and gets a signal from a sensor in the tranny. That signal is then sent to the ECU. You may have a speed sensor or speedo head problem, or an electrical wiring problem. A bad speed sensor signal to the ECU will cause running problems and trip the MIL (what you refer to as the CEL).
Have you added any gauges or anything else electrical to the car? Any mods done with the ECU or wiring? If it's stock and still under warranty, bring it to your dealer for diagnosis.
WRXSTi69 is offline   Reply With Quote
Old 02-05-2002, 08:48 AM   #3
Fast4Door
Scooby Newbie
 
Member#: 14709
Join Date: Jan 2002
Location: St. Paul, MN
Default Wierd?

Does your car rack mileage from just sitting in the driveway too? I assume it would if your spedo thinks you are doing 60. I would get it fixed ASAP and mention an extension to the warrenty due to the fact there are miles on your car that you didnt actually drive.
Fast4Door is offline   Reply With Quote
Old 02-05-2002, 01:28 PM   #4
Stanley
Scooby Guru
 
Member#: 7374
Join Date: Jun 2001
Location: North Bay, SFCA
Vehicle:
2007 Grandpamobile
BlingBlingBlue

Question Is this a joke?

If it isn't, get your car into the shop ASAP, your car is whacked.
Stanley is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EGT Problem or ECU Problem??? STUDAndring Factory 2.0L Turbo Powertrain 8 04-29-2006 10:01 PM
ecu problem eraser1303 Factory 2.0L Turbo Powertrain 5 05-31-2002 04:32 PM
('93-'01) ECU problems Help!!!!!!!!! Jimmy Impreza Forum 9 04-09-2001 10:29 AM
ECU problems Frank General Forum Archive 4 02-13-2001 12:55 AM
Air/Fuel & ECU Problems... ndmorespd Bay Area Impreza Club Forum -- BAIC 1 09-07-2000 06:11 PM


All times are GMT -4. The time now is 02:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.