Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-19-2008, 07:58 PM   #1
teeots
Scooby Newbie
 
Member#: 140731
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Maine
Default Rough High Idle and hunting

Maybe not the right place to post this...?



I came back from a 530 mile trip in 10 hours, the last two of which it snowed like hell. The car ran like a champ. It sat in the garage for about 7 days at which time I started it and it ran rough, like maybe a misfire and was idling fast almost 2k until warm then 1300 when it kicked down. I tried to take it for a gentle drive to see if it would come out of it, but it would hiccup on throttle and boost and almost stall (hunt for idle)when out of gear. Car was open source tuned by previous owner and has run perfectly till now. I took a look around the engine bay for obvious visible probs-- cracked or poor connectors, loose or leaky hoses. (Does the first gen accessport double as a code reader?) Any ideas are welcome. I will eventually trailer to a Subaru mechanic but am looking for some general easy things to check.


Danke for now.
* Registered users of the site do not see these ads.
teeots is offline   Reply With Quote
Old 01-20-2008, 03:33 PM   #2
scherejs
Scooby Newbie
 
Member#: 169547
Join Date: Jan 2008
Vehicle:
2003 Evo VIII
Tarmac Black

Default

Boost/vaccuum leak? Check plugs.
scherejs is offline   Reply With Quote
Old 01-20-2008, 05:54 PM   #3
rkramer
Scooby Guru
 
Member#: 118209
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2015 WRX Limitec

Default

check your air filter. it is possible you sucked alot of snow in and now have a really wet air filter, which doesn't exactly flow air well.
rkramer is offline   Reply With Quote
Old 01-20-2008, 08:41 PM   #4
teeots
Scooby Newbie
 
Member#: 140731
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Maine
Default

Thanks guys. I couldn't detect a vac leak by simply poking around, but intend to check the air filter. Its an open element and located down in the fender well. I ordered a code reader last night, so I should figure out a little better idea of where to look.
teeots is offline   Reply With Quote
Old 01-20-2008, 11:01 PM   #5
rkramer
Scooby Guru
 
Member#: 118209
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2015 WRX Limitec

Default

Quote:
Originally Posted by teeots View Post
Thanks guys. I couldn't detect a vac leak by simply poking around, but intend to check the air filter. Its an open element and located down in the fender well. I ordered a code reader last night, so I should figure out a little better idea of where to look.
so it is probably an oiled filter then? scratch that idea... The stock intake system can suck up enough snow to do this, it is great at separating water, but snow is light enough it can bypass the big jug and stick to the filter. get enough and the engine heat will melt it into a big chunk of ice/water.
rkramer is offline   Reply With Quote
Old 01-23-2008, 08:46 PM   #6
teeots
Scooby Newbie
 
Member#: 140731
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Maine
Default

Code is P0519- description is idle air
teeots is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluctuating, Rough, High Idle. Cause? wrx0001 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 12-01-2009 12:34 AM
help! rough/shaky idle and ticking noise from engine resideinva Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 05-15-2008 10:57 PM
Need input for rough/high idle Crazykev Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 07-09-2006 10:25 PM
Rough/High Idle and P0519 Code SloRice Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 8 02-20-2006 01:58 PM
Rough high idle Gilla-Machster Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 03-30-2004 10:31 PM


All times are GMT -4. The time now is 08:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.