Welcome to the North American Subaru Impreza Owners Club Saturday August 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-28-2012, 04:25 PM   #1
04STIscore
Scooby Newbie
 
Member#: 305390
Join Date: Dec 2011
Chapter/Region: NWIC
Location: Lynchburg, VA
Vehicle:
2004 STI
JBP

Default Climate control, Clock, and Radio don't turn on...

2004 STI ac couple of days ago my climate control, clock, and radio stopeed working. I checked the fuses, they all look ok. noticed that I am not getting power to my blower motor, but I get power to my AC switch, the light turns on anyway. I am pretty much stumped at this point. I was wondering if anyone has experience with this problem, or has an idea as to what else the problem may be.

Thanks,
Jesse
* Registered users of the site do not see these ads.
04STIscore is offline   Reply With Quote
Old 05-28-2012, 04:52 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

You don't test fuses by looking at them. Use a meter or test light to find the one that's blown.
Mulder is offline   Reply With Quote
Old 05-28-2012, 05:39 PM   #3
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

You have most likely overlooked a bad fuse like Mulder stated. Many folks miss them on the first pass.
Cougar4 is offline   Reply With Quote
Old 05-28-2012, 05:54 PM   #4
04STIscore
Scooby Newbie
 
Member#: 305390
Join Date: Dec 2011
Chapter/Region: NWIC
Location: Lynchburg, VA
Vehicle:
2004 STI
JBP

Default

Yeah we used a volt meter looks like they are ok, but with the volt meter we aren't getting a reading. So could it possibly still be the fuse, or a wiring issue?
04STIscore is offline   Reply With Quote
Old 05-28-2012, 08:22 PM   #5
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The trouble is most likely due to a bad fuse in the dash or under the hood. To use the voltmeter set it to measure DC volts, not AC volts. You can measure the battery voltage to test the operation. Place the common lead on a known good metal ground point when you measure the fuses. There are small slits on the top of the fuses you can measure voltage on each side of the fuse using the other probe. If you are looking for a voltage across the fuse then the only time you will see 12 volts is when the fuse is open or bad. There will be no voltage across a good fuse because it has no resistance so no voltage drop can occur.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clock and radio not working and seatbelt light doesnt go on RXinFX Electrical & Lighting 8 12-05-2011 10:52 AM
FS MA: 05 STi complete center console + climate controls + clock + shift boot BlackRS Interior/Dressup/Audio & Security 33 05-22-2008 07:45 AM
FS: 05 STi complete center console + climate controls + clock + shift boot BlackRS NESIC Private Classifieds 0 04-29-2008 04:48 PM
climate control lights and some more Puckman Legacy Forum 22 06-05-2004 01:34 AM
jdm gd wrx/sti climate control... plug and play? Benjamin Tang Electrical & Lighting 10 02-01-2004 10:44 AM


All times are GMT -4. The time now is 03:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.