Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2008, 09:47 PM   #1
vaccine
Scooby Newbie
 
Member#: 94490
Join Date: Aug 2005
Location: Australia
Default Lost my Intercooler spray using current defs

g'day guys.

recently starting playing with my ecu from my ADM 2002 STi.
A4RG060Q -- 2954594105

Now i had the sti on the track in december and the intercooler water spray was working then, as i drained a bottle! Now since december i have been playing a little with the ecu. Was on the same track again over the weekend and the intercooler spray was not working. Looking at the stock ROM map i have used on the track, when using ecuFlash the table has been grayed out saying that it is incomplete etc. Now i copied the memory address from the JDM 2002 STi as refernce for my ADM 2002 STi, and the spray system is now working, as i tested it on the track afterwards!

Problem is, that when i origniall read the ROM it never copied across, is this just an error in def file?? As it is a pretty serious table! are there other tables that could have had the same treatment.

The reason i ask is that while on the track from AFR's on a stock IJN map went from mid-low 10's to just on 8's. on only 15psi!! needless to say the car was not very happy with me and i lifted the foot, did a cool down lap with no boost, and came off! The intercooler was like at small oven. ambient temp outside was like 35degrees celcius.
* Registered users of the site do not see these ads.
vaccine is offline   Reply With Quote
Old 01-27-2008, 11:07 PM   #2
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by vaccine View Post
Looking at the stock ROM map i have used on the track, when using ecuFlash the table has been grayed out saying that it is incomplete etc. Now i copied the memory address from the JDM 2002 STi as refernce for my ADM 2002 STi, and the spray system is now working, as i tested it on the track afterwards!
Whether or not the ic spray threshold tables are defined for your ROM has absolutely nothing to do with whether or not the ic spray works. The incomplete (greyed-out) tables in Ecuflash just means that other ROMs have those tables defined and yours does not, NOT that they are defined incorrectly for your ROM. However, copying over definitions from another ROM, as you did, is a big mistake and can result in major problems if you tried to modify those tables. You should go back to a factory original ROM if this is the case. Also, A4RG060Q is an EDM map (A4RG060P is ADM) -> is that the original map that was on the car?
Tea cups is offline   Reply With Quote
Old 01-28-2008, 01:53 AM   #3
vaccine
Scooby Newbie
 
Member#: 94490
Join Date: Aug 2005
Location: Australia
Default

sorry.. yeh A4RG060P.
so why was the intercooler spray not working then??
as when i did what i did to the ROM it worked fine again??
which originally led me to believe it was something todo with the ROM.

Last edited by vaccine; 01-28-2008 at 02:01 AM.
vaccine is offline   Reply With Quote
Old 01-28-2008, 09:54 AM   #4
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

The definitions just define where a table is in the ROM. I could, for example, have one table defined only in the defs "Target Boost". I could tune that single table only. Would that mean that all of a sudden fuel and timing would not work because I didn't have them defined? No.

On the other hand, what could jack up the ECU is if you were to copy definitions from another ROM. The whole reason we have separate definitions is because the locations for each table can vary between ROMs. When you copy over defs from another ROM, and then modify those tables, you could overwrite something completely different which could cause any number of problems.
Tea cups is offline   Reply With Quote
Old 01-28-2008, 02:37 PM   #5
vaccine
Scooby Newbie
 
Member#: 94490
Join Date: Aug 2005
Location: Australia
Default

cool, thanx for the explination.
You guys by no means, do a fantastic job!
It just seemed really wierd that from when i did the track day in december till now it not working, the only thing i could put it down to was re-flashing the rom. And when i copied the memory address for the intercooler spray tables from the the V7 JDM ecu to mine, it worked again all of a sudden. nothing else has really changed since then.
vaccine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
using methanol in 2006 STi intercooler spray? KaBar6 Water/Methanol Injection, Nitrous & Intercooler Cooling 5 12-28-2006 11:19 AM
me=noob: when to use intercooler spray? Picard Water/Methanol Injection, Nitrous & Intercooler Cooling 9 07-06-2006 10:13 PM
OEM Sti intercooler spray button- used with Nitrous? BillyC Electrical & Lighting 3 10-12-2005 06:43 PM
My DIY Intercooler Spray Carnot Factory 2.0L Turbo Powertrain 24 06-20-2004 01:49 PM
Shots of my Intercooler Spray Kit ShaggyGT Member's Car Gallery 9 07-21-2002 07:17 PM


All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.