Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-04-2008, 12:38 PM   #76
turboge
Scooby Specialist
 
Member#: 35076
Join Date: Apr 2003
Chapter/Region: TXIC
Location: Austin/Round Rock
Vehicle:
2004 507whp Wagon
Silver

Default

Keep in mind this is 16-bit only at this time. Tiny, when do you think we can do the same with the 32-bit?
* Registered users of the site do not see these ads.
turboge is offline   Reply With Quote
Old 02-04-2008, 01:19 PM   #77
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

Quote:
Originally Posted by gaveup View Post
wait wait wait...You got yours to work on an 06?

explain how
Sorry, my friends car that is.

Man I would love it on the 32bit
Nuke209 is offline   Reply With Quote
Old 02-04-2008, 04:29 PM   #78
06rexwagon
Scooby Specialist
 
Member#: 114730
Join Date: May 2006
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2006 WRX Limited Wag
9.9@142

Default

This is great. Thanks!
06rexwagon is offline   Reply With Quote
Old 02-04-2008, 04:31 PM   #79
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

So I finally got around to flashing the patched ROM this afternoon, after fixing my wife's Saab..

So here's snippets of the ECUFlash:

Code:
[17:27:25.174] kernel version is : OpenECU Subaru HC16 Kernel V1.03
[17:27:25.174] reading kernel comm buffer size
[17:27:25.205] comm buffer size set to 512
[17:27:25.221] reading kernel flash buffer size
[17:27:25.236] flash buffer size set to 4096
[17:27:25.236] Flashing image to ECU memory...
[17:27:25.642] comparing ECU flash memory pages to image file
[17:27:25.642] segment   len   ecu CRC32    img CRC32    same?
[17:27:25.985] FB01 00004000   8FA0F940     8FA0F940     YES
[17:27:26.344] FB02 00004000   C56FE35D     C56FE35D     YES
[17:27:26.656] FB03 00004000   ED12BFA3     ED12BFA3     YES
[17:27:26.999] FB04 00004000   A65CCCBF     A65CCCBF     YES
[17:27:27.327] FB05 00004000   743E3637     743E3637     YES
[17:27:27.654] FB06 00004000   CE2D00DD     CE2D00DD     YES
[17:27:27.997] FB07 00004000   DC572A50     DC572A50     YES
[17:27:28.356] FB08 00004000   30FC31D3     30FC31D3     YES
[17:27:28.668] FB09 00004000   7A099934     7A099934     YES
[17:27:29.011] FB10 00004000   3B5EC3FA     244A3514      NO
[17:27:29.339] reading ecu programming voltage

[17:27:36.390] verifying result...
[17:27:36.390] comparing ECU flash memory pages to image file
[17:27:36.390] segment   len   ecu CRC32    img CRC32    same?
[17:27:36.702] FB01 00004000   8FA0F940     8FA0F940     YES
[17:27:37.046] FB02 00004000   C56FE35D     C56FE35D     YES
[17:27:37.389] FB03 00004000   ED12BFA3     ED12BFA3     YES
[17:27:37.748] FB04 00004000   A65CCCBF     A65CCCBF     YES
[17:27:38.075] FB05 00004000   743E3637     743E3637     YES
[17:27:38.418] FB06 00004000   CE2D00DD     CE2D00DD     YES
[17:27:38.746] FB07 00004000   DC572A50     DC572A50     YES
[17:27:39.074] FB08 00004000   30FC31D3     30FC31D3     YES
[17:27:39.432] FB09 00004000   7A099934     7A099934     YES
[17:27:39.760] FB10 00004000   244A3514     244A3514     YES
[17:27:39.776] flash correct! exiting.
[17:33:25.583] 163840 byte image read.
Minus the guts between the initial and post comparisons..

Bottom line, I've got the speed set to 15mph, and the RPM delta to 4400, with my redline @ 7200. so it should engage limiter to 2800RPM, correct?

If so, then it no worky for me.. Mine will continue to rev well beyond that, until the actual redline...

Ideas?
This is on A4SGE01C ecu, MY02
Rogan is offline   Reply With Quote
Old 02-04-2008, 04:44 PM   #80
turboge
Scooby Specialist
 
Member#: 35076
Join Date: Apr 2003
Chapter/Region: TXIC
Location: Austin/Round Rock
Vehicle:
2004 507whp Wagon
Silver

Default

Set the speed to 4mph and the delta to 3200 and try it out. 15mph is a bit much for a launch limiter.
turboge is offline   Reply With Quote
Old 02-04-2008, 05:17 PM   #81
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

I set it to 5..

So to ensure I am understanding this.. If I have it set, will it limit it to whatever rpm, sitting still, as well as until the car reaches the set speed? IE, if it's set to limit to 4500 (7100-2600delta), I can flat-foot the throttle, it'll sit at 4500, I dump the clutch, and when I reach 5mph (set in the patch), it'll then go past 4500? If that holds true, then it isnt working for me. It'll free-rev to 6-7k if I throttle it that much..
Rogan is offline   Reply With Quote
Old 02-04-2008, 06:15 PM   #82
.one lane
Scooby Specialist
 
Member#: 114528
Join Date: May 2006
Location: Outer space
Vehicle:
2002 Space Shuttle
Discovery

Default

here's me testing it out.
http://www.youtube.com/watch?v=kvUJkhTPdpE

I had a vid of me actually launching, but the video came out horrible.
.one lane is offline   Reply With Quote
Old 02-04-2008, 07:19 PM   #83
Wheeler Bement
Scooby Specialist
 
Member#: 15652
Join Date: Feb 2002
Chapter/Region: TXIC
Location: sugar land, katy
Vehicle:
2002 2.5L WRX Wag.
160K club

Default

I have the A4SGE01C and the patch loaded fine(seeing how I can see it in ECUFlash. However, mine did the same as above with respect to no values in the table, but I went and clicked on "Edit Map Definitions" and then selected the RPM and Vehicle speed and bingo, the number appeared. My only prolem is that the verison of ECU Flash I have only has a vehicle speed of KPH, no MPH option...so I guess I need an update??

--edit, updated to Ecuflash 1.34...still have the same issue. I can only select the KPH value...maybe I'll give it a shot anyway.

Last edited by Wheeler Bement; 02-04-2008 at 07:41 PM.
Wheeler Bement is offline   Reply With Quote
Old 02-04-2008, 08:59 PM   #84
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

^^^
Tea cups released the latest definitions for both Enginuity and ECUFlash, it comes in both standard and metric.

So install the standard version.
Nuke209 is offline   Reply With Quote
Old 02-04-2008, 09:00 PM   #85
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

Quote:
Originally Posted by .one lane View Post
here's me testing it out.
http://www.youtube.com/watch?v=kvUJkhTPdpE

I had a vid of me actually launching, but the video came out horrible.
yeah, well mine is like it isn't even there
Rogan is offline   Reply With Quote
Old 02-04-2008, 09:04 PM   #86
WeldingHank
Scooby Specialist
 
Member#: 98645
Join Date: Oct 2005
Chapter/Region: NESIC
Location: Lawrence,ma
Vehicle:
2002 WRX Wagon
PSM

Default

anyone have any suggestions for a delta on a 2.0 with a 16g?
WeldingHank is offline   Reply With Quote
Old 02-04-2008, 10:03 PM   #87
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Quote:
Originally Posted by bchslap View Post
yeah, well mine is like it isn't even there
Put your damned car model/year in your profile so we don't have to scan all your previous posts.
Jon [in CT] is offline   Reply With Quote
Old 02-04-2008, 10:05 PM   #88
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

Quote:
Originally Posted by bchslap View Post
yeah, well mine is like it isn't even there
GOSH, IDIOT!

Glad you're partaking in activities that ensure a nice long life for your 5 speed
Tgui is offline   Reply With Quote
Old 02-04-2008, 10:27 PM   #89
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

double-posted...

Last edited by Rogan; 02-04-2008 at 10:37 PM.
Rogan is offline   Reply With Quote
Old 02-04-2008, 10:36 PM   #90
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

Quote:
Originally Posted by Tgui View Post
GOSH, IDIOT!

Glad you're partaking in activities that ensure a nice long life for your 5 speed
LOL Im good to it.


There ya go, Jon.
Rogan is offline   Reply With Quote
Old 02-04-2008, 10:58 PM   #91
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

So I've been messing with Adding the LC into Enginuity, and got it to work, and made sure ECUFlash read it the same also

I can post the definition if you guys want it
Nuke209 is offline   Reply With Quote
Old 02-04-2008, 11:07 PM   #92
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

I'd be interested in seeing it.
How's it working within Enginuity?
Rogan is offline   Reply With Quote
Old 02-04-2008, 11:15 PM   #93
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

I mean, works the same as EcuFlash, just that I left the LC features in the Misc area in Enginuity, you can edit it the same way, just for those who don't want to edit with EcuFlash, but you still have to patch the rom with TinyWREX's patch in order to see it.
Nuke209 is offline   Reply With Quote
Old 02-04-2008, 11:45 PM   #94
Rogan
Scooby Specialist
 
Member#: 142133
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Virginia - hate it
Vehicle:
3 Jeeps
And a Saab

Default

yeah, that'd be my preference, actually (to edit all in one place.)
Rogan is offline   Reply With Quote
Old 02-04-2008, 11:47 PM   #95
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

If you open up an Unpatched rom in Ecuflash, you'll see the LC feature but the value in the LC Disable Speed Threshold is 158 and in LC RPM Delta, the value is 12800

Remember, a patched rom should be 0 in both the LC Disable Speed Threshold and the LC RPM Delta.
This goes for A4SGE10C, A4TF800F and A4TF800E

A4TF800E gets it's inheritance from A4TF800F.

So when I added it to Enginuity, the whole 158 and 12800 is still in Enginuity.

So there must be a way to add it in both Ecuflash and Enginuity, without the stock unpatched roms being able to see the LC features.
Nuke209 is offline   Reply With Quote
Old 02-05-2008, 01:12 AM   #96
AruisDante
Scooby Specialist
 
Member#: 122365
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Worcester, MA
Vehicle:
1999 BMW 330i ZHP
GSM

Default

Quote:
Originally Posted by Nuke209 View Post
If you open up an Unpatched rom in Ecuflash, you'll see the LC feature but the value in the LC Disable Speed Threshold is 158 and in LC RPM Delta, the value is 12800

Remember, a patched rom should be 0 in both the LC Disable Speed Threshold and the LC RPM Delta.
This goes for A4SGE10C, A4TF800F and A4TF800E

A4TF800E gets it's inheritance from A4TF800F.

So when I added it to Enginuity, the whole 158 and 12800 is still in Enginuity.

So there must be a way to add it in both Ecuflash and Enginuity, without the stock unpatched roms being able to see the LC features.
He'd simply have to put in a marker that's only there in a patched ROM, and then have engininuity look for that marker. If it doesn't see it, then it doesn't enable the LC stuff. If it does, then the ROM is patched, so the LC tools become active.
AruisDante is offline   Reply With Quote
Old 02-05-2008, 01:24 AM   #97
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

Yes, both software uses definitions, for example, when you load up A4SGE10C, it'll look for the rom id in the definition and load up what it matches to.
Thing is, the rom id in both the patched and unpatched files are the same.

Unless there's another way around it, the only way I can think of, is changing the rom id and loading up the LC featured on the new rom id but inheriting from the original.
Nuke209 is offline   Reply With Quote
Old 02-05-2008, 02:17 AM   #98
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by bchslap View Post
So I finally got around to flashing the patched ROM this afternoon, after fixing my wife's Saab..

So here's snippets of the ECUFlash:

Code:
[17:27:25.174] kernel version is : OpenECU Subaru HC16 Kernel V1.03
[17:27:25.174] reading kernel comm buffer size
[17:27:25.205] comm buffer size set to 512
[17:27:25.221] reading kernel flash buffer size
[17:27:25.236] flash buffer size set to 4096
[17:27:25.236] Flashing image to ECU memory...
[17:27:25.642] comparing ECU flash memory pages to image file
[17:27:25.642] segment   len   ecu CRC32    img CRC32    same?
[17:27:25.985] FB01 00004000   8FA0F940     8FA0F940     YES
[17:27:26.344] FB02 00004000   C56FE35D     C56FE35D     YES
[17:27:26.656] FB03 00004000   ED12BFA3     ED12BFA3     YES
[17:27:26.999] FB04 00004000   A65CCCBF     A65CCCBF     YES
[17:27:27.327] FB05 00004000   743E3637     743E3637     YES
[17:27:27.654] FB06 00004000   CE2D00DD     CE2D00DD     YES
[17:27:27.997] FB07 00004000   DC572A50     DC572A50     YES
[17:27:28.356] FB08 00004000   30FC31D3     30FC31D3     YES
[17:27:28.668] FB09 00004000   7A099934     7A099934     YES
[17:27:29.011] FB10 00004000   3B5EC3FA     244A3514      NO
[17:27:29.339] reading ecu programming voltage

[17:27:36.390] verifying result...
[17:27:36.390] comparing ECU flash memory pages to image file
[17:27:36.390] segment   len   ecu CRC32    img CRC32    same?
[17:27:36.702] FB01 00004000   8FA0F940     8FA0F940     YES
[17:27:37.046] FB02 00004000   C56FE35D     C56FE35D     YES
[17:27:37.389] FB03 00004000   ED12BFA3     ED12BFA3     YES
[17:27:37.748] FB04 00004000   A65CCCBF     A65CCCBF     YES
[17:27:38.075] FB05 00004000   743E3637     743E3637     YES
[17:27:38.418] FB06 00004000   CE2D00DD     CE2D00DD     YES
[17:27:38.746] FB07 00004000   DC572A50     DC572A50     YES
[17:27:39.074] FB08 00004000   30FC31D3     30FC31D3     YES
[17:27:39.432] FB09 00004000   7A099934     7A099934     YES
[17:27:39.760] FB10 00004000   244A3514     244A3514     YES
[17:27:39.776] flash correct! exiting.
[17:33:25.583] 163840 byte image read.
Minus the guts between the initial and post comparisons..

Bottom line, I've got the speed set to 15mph, and the RPM delta to 4400, with my redline @ 7200. so it should engage limiter to 2800RPM, correct?

If so, then it no worky for me.. Mine will continue to rev well beyond that, until the actual redline...

Ideas?
This is on A4SGE01C ecu, MY02
I am almost sure that this rom you flashed is not patched properly.
See the comparing of flash blocks? FB09-FB10 is the area of the maps and it seems that it is the only one that has a change (you changed the LC parameters) whereas one or more of FB01-FB08 should show a change as the code is changed!
Post a screenshot of TinyPatcher running and showing in the end "xx bytes patched"
xswrex is offline   Reply With Quote
Old 02-05-2008, 02:21 AM   #99
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

Quote:
Originally Posted by Tgui View Post
GOSH, IDIOT!

Glad you're partaking in activities that ensure a nice long life for your 5 speed
xswrex is offline   Reply With Quote
Old 02-05-2008, 02:33 AM   #100
xswrex
Scooby Newbie
 
Member#: 87255
Join Date: May 2005
Location: Greece
Vehicle:
2002 Impreza WRX
given up emptying PMs...

Default

all released patches have been updated to include LC speed threshold in MPH so it will work out of the box for both available versions of EcuFlash XML definitions (Standard and Metric)
xswrex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Launch Control on 2004 WRX Doomsti AccessPort 18 11-16-2012 03:16 PM
Launch Control on 32bit ECU Nuke209 Open Source Reflashes 126 05-17-2008 10:49 AM
Help with wiring in launch control on an 05 WRX. Sir Wagon UTEC 2 03-07-2008 04:45 PM
Failed NY state Inspection because of Launch Control on UTEC? vipernj Engine Management & Tuning 2 01-24-2006 06:10 PM
utec remote switch launch control on 4eat topgrinder Engine Management & Tuning 1 03-27-2003 08:34 PM


All times are GMT -4. The time now is 11:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.