Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-13-2008, 09:40 PM   #1
acemyles2.5i
Scooby Specialist
 
Member#: 151012
Join Date: Jun 2007
Chapter/Region: South East
Location: lakeland, Fl
Vehicle:
2007 impreza 2.5i
urban

Subaru Banner rpms

i took apart my gauge cluster today to get the bulb size for some new led's, and when i plugged everything back in i noticed my rpms were in a sense studdering when going up, its moving up really choppy like, any ideas whats wrong????
* Registered users of the site do not see these ads.
acemyles2.5i is offline   Reply With Quote
Old 02-14-2008, 10:40 AM   #2
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

Did you futz with the needle?
Counterfit is offline   Reply With Quote
Old 02-14-2008, 10:46 AM   #3
mopartodd
Scooby Newbie
 
Member#: 164929
Join Date: Nov 2007
Chapter/Region: South East
Location: NC
Vehicle:
2010 2.5i Outback
Satin White

Default

Bad connection maybe.
mopartodd is offline   Reply With Quote
Old 02-17-2008, 08:51 PM   #4
Shiz36
Scooby Specialist
 
Member#: 147730
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Quincy MA
Vehicle:
2007 Impreza 2.5i SE
Urban Gray Metallic

Default

my guess would be all the pieces weren't snapped together when putting the gauges back together. the needle might be rubbing against number plate. that happened to me in my old Accord when I replaced bulbs.
Shiz36 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does the USDM STi have a 7000 RPM redline and not an 8000 RPM redline? Corn-Picker Factory 2.5L Turbo Powertrain 51 10-08-2006 01:24 PM
Power Drop at 4200 rpm thru 5300 rpm???? AScooby4U Factory 2.0L Turbo Powertrain 10 01-22-2006 01:22 PM
Fluctuating RPM at STEADY THROTTLE any RPM mnavarro Factory 2.5L Turbo Powertrain 9 06-21-2005 07:46 PM
800 hp @ 2500 rpm, 2200 lb-ft @ 1800 rpm Reciprocity Off-Topic 34 12-21-2004 12:56 PM
253.2 HP @ 5500 RPM / 264.4 LBS TQ @ 4750 RPM @ 11.7 Lbs of boost Hopper Proven Power Bragging 6 10-04-2004 12:11 PM


All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.