Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-13-2008, 11:57 PM   #1
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default Any 2008 Impreza Recalls Yet?

Hello,
Anyone know/heard of any recalls yet for the 2008 Impreza 2.5i?

I tried to do a search but I came up empty handed. Unless I didn't look hard enough.
* Registered users of the site do not see these ads.
Retribution is offline   Reply With Quote
Old 02-14-2008, 09:44 AM   #2
Shark-a-ru
Scooby Newbie
 
Member#: 171187
Join Date: Feb 2008
Chapter/Region: E. Canada
Location: Ontario, Canada
Vehicle:
2008 Impreza 2.5i SP
SSM

Default

I have done a search as well. Transport Canada doesn't have any recalls for the 2008 Impreza either. There seems to be a few of us with a 2008 Impreza and there doesn't seem to be any major issues. I think a couple of us had a minor problem where our cars were a little difficult to start on a cold morning. (it only happened once to me). I think that most recalls are generally premature wearing of parts or just complete failure of a particular part. Recalls are not normally issued unless there is a lot of them.
Since we haven't heard anything so far, I would call that good news.
Shark-a-ru is offline   Reply With Quote
Old 02-14-2008, 02:32 PM   #3
jtom12
Scooby Newbie
 
Member#: 144987
Join Date: Mar 2007
Chapter/Region: NESIC
Location: Albany, NY
Default

I think that the rust and paint falling off around the rear wheels. While thats due to wear and tear, it definetly should not be that bad on new cars and also shouldnt require mud flaps.
jtom12 is offline   Reply With Quote
Old 02-16-2008, 03:39 PM   #4
SportshiftedSSM508
Scooby Newbie
 
Member#: 170104
Join Date: Jan 2008
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2008 Impreza-5 2.5i
Spark Silver Metallic

Default

I'm sure any recalls that come out will never be as bad as my previous car (05 Suzuki Reno (Chevy Optra/Lacetti))

- Timing belt and water pump pulley replaced at 10K miles
- Headlight wiring redone (people's lights were permanently failing)
SportshiftedSSM508 is offline   Reply With Quote
Old 02-16-2008, 06:54 PM   #5
RLW
Scooby Newbie
 
Member#: 129753
Join Date: Oct 2006
Location: Finger Lakes, NY
Vehicle:
0713 (2) Legacys
Silver and Graphite

Default

Quote:
Originally Posted by jtom12 View Post
I think that the rust and paint falling off around the rear wheels. While thats due to wear and tear, it definetly should not be that bad on new cars and also shouldnt require mud flaps.
Amen to that!
RLW is offline   Reply With Quote
Old 02-16-2008, 10:50 PM   #6
whoosh
Scooby Specialist
 
Member#: 40989
Join Date: Jul 2003
Chapter/Region: Tri-State
Vehicle:
OT vag inspector

Default

i think the roof rails will be recalled/fixed.


they howl at highway speeds
whoosh is offline   Reply With Quote
Old 02-17-2008, 02:51 AM   #7
Bucky92
Scooby Newbie
 
Member#: 108798
Join Date: Feb 2006
Chapter/Region: NESIC
Vehicle:
08 2.5i 5door
Satin White Pearl

Default

Quote:
Originally Posted by whoosh View Post
i think the roof rails will be recalled/fixed.


they howl at highway speeds
AND if the rubber strip is a hair short ..it will rattle and vibrate like mad. Took mine back 3 times for that problem ..replaced the rails twice..but always used the same strip...till I finally pulled it off..( the strip not the whole rail).

There should also be a recall once an update is made to stop the throttle from " hanging" on our manual trannies.
Bucky92 is offline   Reply With Quote
Old 02-17-2008, 04:10 AM   #8
Kostamojen
Scooby Guru
 
Member#: 2272
Join Date: Sep 2000
Chapter/Region: BAIC
Location: haha XD
Vehicle:
2013 Subaru 599 :P
Galaxy Blue Sexy

Default

Recalled? No.

Service Bulletins? Yes, several.
Kostamojen is offline   Reply With Quote
Old 02-18-2008, 03:10 PM   #9
skyrocket101
Scooby Newbie
 
Member#: 159721
Join Date: Sep 2007
Chapter/Region: NWIC
Location: Kirkland, WA
Vehicle:
08 WRX
WRB

Default

Quote:
Service Bulletins? Yes, several.
Do you have a list of them?
skyrocket101 is offline   Reply With Quote
Old 02-18-2008, 04:16 PM   #10
dees421
Scooby Specialist
 
Member#: 156291
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Nampa, Idaho
Vehicle:
2008 Impreza 2.5i
DGM

Default

Quote:
Originally Posted by whoosh View Post
i think the roof rails will be recalled/fixed.


they howl at highway speeds

That funny that you metion this. Mine use to howl, but don't any more and that's at speed for 1 to 80+. I don't know if having 4 boards up there kind of shifted it some how. But after I took off the attachment, I tightened them down (like it says in the direction after xxx miles), nothing anymore. Unless my earing has gotten worse.

Now, with the snowboard attachment on there, it's a howling SOB.
dees421 is offline   Reply With Quote
Old 02-21-2008, 01:02 PM   #11
funyuns101
Scooby Newbie
 
Member#: 172390
Join Date: Feb 2008
Location: MD
Vehicle:
1997 Infiniti I30

Default

Is it possible to add a Yakima or Thule fairing to deflect wind noise to the factory rails on the 08's?
funyuns101 is offline   Reply With Quote
Old 02-29-2008, 03:41 PM   #12
jojomojo
Scooby Newbie
 
Member#: 157989
Join Date: Aug 2007
Default

All lights front and rear got consdensation. For me rear it's not only fog its water in the light.

Subaru answer: We got a service bulletin saying that is normal they don't change it.
jojomojo is offline   Reply With Quote
Old 02-29-2008, 04:18 PM   #13
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default

Quote:
Originally Posted by jojomojo View Post
All lights front and rear got consdensation. For me rear it's not only fog its water in the light.

Subaru answer: We got a service bulletin saying that is normal they don't change it.
Wow, I heard about this issue but I haven't actually saw this first hand on my car. I never really paid any attention to it but I think I saw this once on my vehicle.

That's so stupid of Subaru not fixing this. Maybe it might be due to the winter weather? Lets see what we get in the spring and if this still persists we'll battle it with Subaru.
Retribution is offline   Reply With Quote
Old 02-29-2008, 05:43 PM   #14
dees421
Scooby Specialist
 
Member#: 156291
Join Date: Aug 2007
Chapter/Region: NWIC
Location: Nampa, Idaho
Vehicle:
2008 Impreza 2.5i
DGM

Default

I haven't seen it in mine and I have been in the cold mountains almost weekly. From -2 degree to 30 degree in the same day and no condensation parking out side. But then again I do park in a garage 95% fo the time so maybe that's why I havent seen it.
dees421 is offline   Reply With Quote
Old 03-01-2008, 12:09 AM   #15
shakur45
Scooby Specialist
 
Member#: 165106
Join Date: Nov 2007
Chapter/Region: MAIC
Location: Crunchville, PA
Vehicle:
2008 WRX Stage 1
Obsidian Black Pearl

Default

I had some fog in the beginning. Has not returned yet
shakur45 is offline   Reply With Quote
Old 03-01-2008, 01:36 AM   #16
VolkWRX56
Scooby Newbie
 
Member#: 93083
Join Date: Aug 2005
Chapter/Region: MAIC
Location: WV
Vehicle:
2015 WRX Premium
Crystal White Pearl

Default

I called SOA this morning and they too told me that my headlights fogging up was normal. Everyone needs to call them so they will fix it. Our headlight are going to look like a** in a few years.
VolkWRX56 is offline   Reply With Quote
Old 03-03-2008, 03:11 PM   #17
Emboyoyo
Scooby Newbie
 
Member#: 173455
Join Date: Mar 2008
Location: Carson City, Nevada
Vehicle:
2008 Impreza 2.5i
Satin White Pearl

Default

The only problem im having with my 08 2.5i is when it's cold it takes a while to start up and every once in a while it takes me about 3 or 4 times for my car to start...it sounds like my battery is already dying when I start it up and it takes that many times.
Emboyoyo is offline   Reply With Quote
Old 03-03-2008, 06:03 PM   #18
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default

Quote:
Originally Posted by Emboyoyo View Post
The only problem im having with my 08 2.5i is when it's cold it takes a while to start up and every once in a while it takes me about 3 or 4 times for my car to start...it sounds like my battery is already dying when I start it up and it takes that many times.
I made a thread a while ago about this problem where one morning I wasn't able to start my brand new 2008 2.5i. After the 4th try it started, and it sounded like my battery was dead too or there was no gas in my car. After since that day, I haven't had any problems so far. (I'm hoping it doesn't happen again, scared the crap out of me)

Read up on the thread and maybe you could find something that might help.
Retribution is offline   Reply With Quote
Old 03-22-2008, 04:19 PM   #19
ber93635
Scooby Newbie
 
Member#: 175291
Join Date: Mar 2008
Default creaking/grinding at low speed

H ALL< I am a new member to this forum and I just got the 5 door 2.5i and with less than 100 miles on it I get a creaking/grinding noise at low speed. any ideas what this is?
ber93635 is offline   Reply With Quote
Old 03-23-2008, 12:02 PM   #20
RLW
Scooby Newbie
 
Member#: 129753
Join Date: Oct 2006
Location: Finger Lakes, NY
Vehicle:
0713 (2) Legacys
Silver and Graphite

Default

Anyone experiencing the motor revving when coming to a stop?
Only happens when cold outside and I am applying the brake. Car is fully warmed up and have driven 6-40 miles. And doesn't happen all the time.
RLW is offline   Reply With Quote
Old 03-23-2008, 01:19 PM   #21
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default

I just realized that my center air vent (the driver side) it doesn't stay down when I push the vent down. It would rise back up as if there was a weight problem inside the vent that is causing it to rise up.

I'm going to take it to the dealer on Monday since I have an appointment with an oil change. You guys should check that out too.
Retribution is offline   Reply With Quote
Old 03-23-2008, 02:38 PM   #22
subiegirl21
Scooby Newbie
 
Member#: 175365
Join Date: Mar 2008
Default

i just got my 2008 subaru impreza 4 door, and i LOVE it. so many people seem to have issues with the cars appearance! Personally, this is my first car, so I would've taken anything, but I feel really lucky to have it. So far I'm not having any issues with it, but then again, I've only had it for less than a week. One thing I did notice though was that for the first few days the car made a really funny noise when I pressed the lock button from the inside. Sounded like something metal rolling around in the car. Maybe this is normal..?
subiegirl21 is offline   Reply With Quote
Old 03-23-2008, 06:15 PM   #23
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default

Quote:
Originally Posted by subiegirl21 View Post
i just got my 2008 subaru impreza 4 door, and i LOVE it. so many people seem to have issues with the cars appearance! Personally, this is my first car, so I would've taken anything, but I feel really lucky to have it. So far I'm not having any issues with it, but then again, I've only had it for less than a week. One thing I did notice though was that for the first few days the car made a really funny noise when I pressed the lock button from the inside. Sounded like something metal rolling around in the car. Maybe this is normal..?
Not at all... I hit the lock and unlock button all the time from the inside of my car and I have not heard of any rattling of any kind. You might want to get that checked out. All I notice is that it does the usual, "chirp" and locking/unlocking mechanism noise for all cars.
Retribution is offline   Reply With Quote
Old 03-24-2008, 06:07 PM   #24
hotweiss
Scooby Newbie
 
Member#: 174968
Join Date: Mar 2008
Location: Calgary, AB
Vehicle:
2008 Impreza 5sp
White

Default

Quote:
Originally Posted by Retribution View Post
I just realized that my center air vent (the driver side) it doesn't stay down when I push the vent down. It would rise back up as if there was a weight problem inside the vent that is causing it to rise up.

I'm going to take it to the dealer on Monday since I have an appointment with an oil change. You guys should check that out too.
My vents are fine.
hotweiss is offline   Reply With Quote
Old 03-24-2008, 08:40 PM   #25
Retribution
Scooby Newbie
 
Member#: 163624
Join Date: Nov 2007
Default

Quote:
Originally Posted by hotweiss View Post
My vents are fine.
Thanks, I just went to the dealer this morning and when I started my car it was 28 degrees here in Jersey and the vents were completely fine, until I started putting the heat on the plastic became to give way. Then it happened without problems. When I left my car with the dealer as I waited, they called me in asked me what was I talking about and I hopped in my car along with the service guy and it didn't happen. He assured me that as the weather becomes hotter, since I'm still way under warranty 3years/36k that if it happens again for my next oil change I will be able to get that fixed.
Retribution is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Subaru Recalls 2009 Forester, 2007-'08 Legacy and 2008 Impreza da-chaz General Community 13 09-30-2008 11:29 PM
Any 2008 Impreza wagon springs available? greasebil Brakes, Steering & Suspension 13 05-15-2008 06:47 PM
Any 2008 STI's yet Rodan Texas Impreza Club Forum -- TXIC 33 02-18-2008 05:30 AM
anyone have any 08 impreza problems yet? Tosh North West Impreza Club Forum -- NWIC 2 12-21-2007 08:58 PM
Any Ney Imprezas Junked Yet? nickgomez Texas Impreza Club Forum -- TXIC 14 12-31-2002 02:25 AM


All times are GMT -4. The time now is 04:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.