Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-18-2008, 10:07 PM   #1
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default 2007 2.5i EcuFlash prob reading ECU

I am attempting to read the ECU rom using EcuFlash v 1.34. When i am prompted to select the type of vehicle the only selection with a 2007 model year is the WRX-STi option. So i tried that since Im only doing a read. When i start a read it looks like its doing everything correctly, takes about 2 or 3 mins to download the ROM image and then it says

"Unknown ROM Image - EcuFlash could not recognize this ROM image with any of the current definitions. please choose from the following:"

so i pick to go ahead and save (will not be able to view or edit). And the error i get in the EcuFlash Task Info window is

"Image File is incorrect size"

Maybe its 32bit ECU and 16bit EcuFlash software?

Im pretty descent with computers but very new to ECU logging/flashing/tuning.

So I looked for newer EcuFlash definitions for the 2007 Impreza 2.5i everywhere and cannot find them at all! Am I doing something wrong? Do I just need new/correct EcuFlash def's for my 2.5i? Where can I find them? I can't seem to figure out how to update the def's for EcuFlash even if I had more current ones. My eyeballs are going to implode from staring at this screen forever trying to find new def's. thanks for any help!
* Registered users of the site do not see these ads.
RaceFaceXC is offline   Reply With Quote
Old 02-20-2008, 11:04 PM   #2
watchunglava
Scooby Specialist
 
Member#: 168862
Join Date: Jan 2008
Chapter/Region: NESIC
Location: Portland Maine
Vehicle:
2007 ej253n/a 5speed
Red Sox Nation Lifer

Default hey

im having the same exact problem , guys on ecuflash forums told me it was my defs . you have to hook up the new ones guy.
watchunglava is offline   Reply With Quote
Old 02-21-2008, 12:03 AM   #3
williaty
Scooby Guru
 
Member#: 71092
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Delaware County, Ohio
Vehicle:
2005 2.5RS Wagon
Regal Blue Pearl

Default

Oh, that's a good point. Neither RomRaider nor ECUFlash come with the current defs, you have to download them separately.
williaty is offline   Reply With Quote
Old 02-21-2008, 09:40 AM   #4
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Quote:
Originally Posted by RaceFaceXC View Post
So I looked for newer EcuFlash definitions for the 2007 Impreza 2.5i everywhere and cannot find them at all!
Try http://forums.openecu.org/viewtopic.php?t=3031.
Jon [in CT] is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i speaker probs? K-Dizzle Car Audio, Video & Security 3 03-05-2009 08:43 PM
2007 2.5i intake manifold onto a 2007 EJ255 Davenow Factory 2.5L Turbo Powertrain 3 04-20-2008 04:51 PM
ecu tune on 2007 2.5i? cowboysuby Normally Aspirated Powertrain 21 02-03-2008 12:50 PM
ECU pinout for 2007 2.5i gregp07h4 Normally Aspirated Powertrain 0 11-22-2007 02:18 PM
Canadian 2007 2.5i SE (Sport Edition?) JoeyW News & Rumors 13 09-11-2006 07:05 PM


All times are GMT -4. The time now is 12:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.