Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-21-2008, 06:53 PM   #1
subywuby45
Scooby Newbie
 
Member#: 168078
Join Date: Jan 2008
Default 2006 engine trouble

Hi there fellow subaru owners, I am in desperate need of help, no one I know can determine what is wrong with my subaru. Ill give you some background information first. I bought my car from and older man who drove it gingerly; It is a 2006 2.5rs impreza with right around 60,000 miles. Ive had it for a couple of months now. When I drive her I drive her fairly hard, every shift is around 3000 rpm. I also drive it really hard at least once a day(Ive been doing this for about a week or two), when I do this I go to a windy community and ill run my car (its bone stock) for an hour maybe hour and a half at full out racing speed, shifting past 4000 rpm on every shift, trying to get as much power out of the engine as possible, and cornering very hard. Anyway its time to cut to the chase, hears the problem: One day I start my car to go drive it somewhere and everything seems fine, then I start to speed and drive faster and faster (I live in the middle of nowhere) Its then that I realized that the power seemed to fall off the higher I got in the gear, so everytime Id shift Id look at the rpms and they looked too high for the amount of fall off I was feeling at the middle to end of the gears. I also realized that right after I shifted no matter how high the rpms and how quickly I got back on the gas the engine seemed to pick up and accelerate noticably slower, also the gears feel longer, noticably longer. Please, I need help.
* Registered users of the site do not see these ads.
subywuby45 is offline   Reply With Quote
Old 02-21-2008, 09:32 PM   #2
Subyroo2.5
Scooby Specialist
 
Member#: 168129
Join Date: Jan 2008
Chapter/Region: SCIC
Location: High Desert
Vehicle:
2013 WRX
WRBP

Default

ummm.....yeah....
Subyroo2.5 is offline   Reply With Quote
Old 02-21-2008, 09:40 PM   #3
SilverSubie2.5
Scooby Specialist
 
Member#: 136144
Join Date: Dec 2006
Chapter/Region: RMIC
Location: SLC, UT
Vehicle:
2012 WRX Hatch
Ice Silver

Default

Your gear ratios aren't changing, and shifting at 3k is not driving fairly hard. And 4k isn't "really hard." Other than that, I don't know what to say. Your car is fine.
SilverSubie2.5 is offline   Reply With Quote
Old 02-21-2008, 11:16 PM   #4
jordan s
Scooby Specialist
 
Member#: 122233
Join Date: Aug 2006
Chapter/Region: Tri-State
Location: north jersey
Vehicle:
1997 Legacy GT
Aspen White 5MT

Default

60,000 miles on an 06? jesus my 06 has 27,000 and i thought that was a lot.
jordan s is offline   Reply With Quote
Old 02-21-2008, 11:25 PM   #5
piker28
Scooby Guru
 
Member#: 22664
Join Date: Aug 2002
Location: north nj
Default

my 04 is about to turn 30,000 and i thought it was alot ha
piker28 is offline   Reply With Quote
Old 02-22-2008, 12:15 AM   #6
williaty
Scooby Guru
 
Member#: 71092
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Delaware County, Ohio
Vehicle:
2005 2.5RS Wagon
Regal Blue Pearl

Default

Bad tank of gas pulling timing?

And I'm WOT to fuel cut all day every day. You're babying that damned car.
williaty is offline   Reply With Quote
Old 02-22-2008, 08:36 PM   #7
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

you change gas station/brand? Log it if it keeps up.
RaceFaceXC is offline   Reply With Quote
Old 02-22-2008, 09:55 PM   #8
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

Quote:
Originally Posted by jordan s View Post
60,000 miles on an 06? jesus my 06 has 27,000 and i thought that was a lot.
Weaksauce, I'm about to hit 31k
Counterfit is offline   Reply With Quote
Old 02-23-2008, 07:52 PM   #9
zavier
Scooby Specialist
 
Member#: 141189
Join Date: Feb 2007
Chapter/Region: Tri-State
Location: Philadelphia
Vehicle:
2007 2.5i (NBP)
2014 BRZ (DGM)

Default

Quote:
Originally Posted by Counterfit View Post
Weaksauce, I'm about to hit 31k
psh 2007 just topped 34k


also is this an auto or a manual? just wondering...but could it be your cat? just had to have a cat replaced on a saturn that didn't seem to want to accelerate and the rpms were just to high (auto) turned out the cat was bad/clogged.
zavier is offline   Reply With Quote
Old 02-24-2008, 10:30 AM   #10
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

i was thinking cat also, but thats really bad if the cat is toasted already... maybe driving it so easy isnt good for the cat?
RaceFaceXC is offline   Reply With Quote
Old 02-24-2008, 12:17 PM   #11
dan13
Scooby Specialist
 
Member#: 157726
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Chicago-ish
Vehicle:
hunk of metal

Default

ummm he thinks 4k is hard?
dan13 is offline   Reply With Quote
Old 02-24-2008, 01:38 PM   #12
Tim Sanderson
Scooby Guru
 
Member#: 6486
Join Date: May 2001
Chapter/Region: MWSOC
Location: S.E. wisconsin
Vehicle:
00 Impreza 2.5 RS
Blue Ridge Pearl

Default

Do you think it's possible your clutch is beginning to go? Smell anything?
Tim Sanderson is offline   Reply With Quote
Old 02-24-2008, 03:29 PM   #13
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Quote:
Originally Posted by Tim Sanderson View Post
Do you think it's possible your clutch is beginning to go? Smell anything?
That was my first thought, too.
Jon [in CT] is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP 2006 engine troubles subywuby45 Service & Maintenance 5 02-21-2008 09:38 PM
check engine light, wierd engine trouble? gipoliceman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 01-14-2003 09:04 PM
engine trouble yukon General Community 1 10-17-2002 07:19 PM
WRX Engine troubles subarugt Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 09-19-2002 10:38 AM
'00 Legacy GT engine trouble... Kostamojen Legacy Forum 1 09-13-2002 03:05 AM


All times are GMT -4. The time now is 07:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.