Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-26-2009, 10:13 PM   #301
hystericfox
Scooby Newbie
 
Member#: 108177
Join Date: Feb 2006
Location: NEPA
Vehicle:
04 Wagon
WRB

Default

Where is the EPROM chip on the back of the board? None have the number 93c56 on them. Unless its on the other side of the board. I wanted to try swapping the chips between my 04 WRX cluster and my 04 STI cluster.
* Registered users of the site do not see these ads.
hystericfox is offline   Reply With Quote
Old 02-26-2009, 11:56 PM   #302
jeffcavazos24
Scooby Newbie
 
Member#: 202966
Join Date: Feb 2009
Chapter/Region: TXIC
Location: Texas
Vehicle:
2008 WRX
Black

Default

how do you fix the abs light problem without using tape? i have an 05 wrx with a 05USDM STI cluster. im gonna wire the sensor to eliminate the rear diff light, but there seems to be no fix that actually works for the abs light.
jeffcavazos24 is offline   Reply With Quote
Old 03-01-2009, 09:01 AM   #303
Dutch Devotion
Scooby Newbie
 
Member#: 145985
Join Date: Apr 2007
Default

Hi Guys,

I swapped a 99 type RA driveline into my 04 WRX a while ago.
This gives me the beefier 5MT with DCCD, 180R diff on a FD 4.444
So my topspeed is app 200kmh...........acceleration is groupN style --> very aggresive running app 350crankhp on ron98 pumpgas.......whoehaaa

Now I'm in the process of swapping my cluster for a JDM cluster showing topspeed 180kmh on the dial.
Reading most posts in this very imformative topic (y), is my understanding correct that swapping a 04JDM STI cluster into a 04WRX will be 99% plug and play (besides running wires from my dccd pro deluxe controller to the correct pins) ?

I'm also installing a SpecC ICcooler system so that will solve my IC spray alarm, leaves me with a ABS alarm.............bummer......... already disabled my ABS and hooked the bulb with the oil bulb (alarm is neccesary to pass anual car check here in the Netherlands, stupid regulations)



Pleased to read yr answer(s)

Regards

Erik - The Netherlands
Dutch Devotion is offline   Reply With Quote
Old 03-02-2009, 11:02 PM   #304
crpwrx
Scooby Specialist
 
Member#: 180710
Join Date: May 2008
Chapter/Region: TXIC
Location: Corpus Christi
Vehicle:
2006 Sti WRB
WFC# 229

Default

I looked through this whole thing and cant find a clear answer as to how you would put any year sti cluster into an 02-03 wrx. All i find are mixed up bits and pieces. Can someone clear this up.
crpwrx is offline   Reply With Quote
Old 03-03-2009, 02:04 AM   #305
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Haven, Utah
Vehicle:
02 WRX Sedan
MBP

Default

Quote:
Originally Posted by crpwrx View Post
I looked through this whole thing and cant find a clear answer as to how you would put any year sti cluster into an 02-03 wrx. All i find are mixed up bits and pieces. Can someone clear this up.
buy an 04, its plug and play
the only thing is you will have a couple lights that are on
you can tape over them or unplug them
Jncominco2 is offline   Reply With Quote
Old 03-03-2009, 04:19 AM   #306
Dutch Devotion
Scooby Newbie
 
Member#: 145985
Join Date: Apr 2007
Default

I ordered a JDM V8 STI cluster yesterday and wil hook it up as soon as it's delivered.
Will post findings here immediately.
Also ordered a DCCDpro deluxe controler, will wire the bastard up to the cluster as well......
If that turns out to be working....................almost to nice to be true......
Erik
Dutch Devotion is offline   Reply With Quote
Old 03-04-2009, 01:14 AM   #307
crpwrx
Scooby Specialist
 
Member#: 180710
Join Date: May 2008
Chapter/Region: TXIC
Location: Corpus Christi
Vehicle:
2006 Sti WRB
WFC# 229

Default

Quote:
Originally Posted by Jncominco2 View Post
buy an 04, its plug and play
the only thing is you will have a couple lights that are on
you can tape over them or unplug them

Thanks.
crpwrx is offline   Reply With Quote
Old 03-05-2009, 04:12 PM   #308
Dutch Devotion
Scooby Newbie
 
Member#: 145985
Join Date: Apr 2007
Default

Just did the V8 STI swap into 04WRX
top mleft plug didn;t fit, shaved some off with a potato knife and yes it fits
Strange buzzer zound appeared, just teared the whole buzzerthingbox from the rearpanel
Buzzer solved
Now I have my handbrake light on (any solutions ?)
The DCCD light is on, hope that will be solved by wiring up the DCCDpro ecu
And the rear diff temp signal is on, will tape that.
My ABS alarm doesn't show on start-up and that's a failure in the Dutch periodic car checkup so will swap cluster once a year :-)
Regards
Erik

PS any answers on the handbrake signal welcome
Dutch Devotion is offline   Reply With Quote
Old 03-06-2009, 03:38 PM   #309
turbowgnWHAT
Scooby Newbie
 
Member#: 163362
Join Date: Nov 2007
Chapter/Region: NESIC
Location: Western MA
Vehicle:
'97 Battlewagon II
Flat black and low-n-slow

Default

i have an 02 bugeye, almost positive the ecu is out of an 04. just swapped in an 04 STi cluster and i didnt have any problems that i saw. shift light was functional but the rear diff temp was on (expected) and so was DCCD. Neither of them are a big deal, BUT my radio didnt work...anyone else get this yet? i heard i had to swap a power and a ground or something like that but i just plugged in and no real problems
turbowgnWHAT is offline   Reply With Quote
Old 03-06-2009, 03:53 PM   #310
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

You popped a fuse. Disconnect pin B28. ECU has NOTHING to do with this....the WRX ECU from 02-05 are all the same.
CoolRex is offline   Reply With Quote
Old 03-07-2009, 07:37 PM   #311
turbowgnWHAT
Scooby Newbie
 
Member#: 163362
Join Date: Nov 2007
Chapter/Region: NESIC
Location: Western MA
Vehicle:
'97 Battlewagon II
Flat black and low-n-slow

Default

Quote:
Originally Posted by CoolRex View Post
You popped a fuse. Disconnect pin B28. ECU has NOTHING to do with this....the WRX ECU from 02-05 are all the same.

so if i pull that pin then i will regain my clock and radio? does anyone have the wiring diagram? thanks again

-chris
turbowgnWHAT is offline   Reply With Quote
Old 03-08-2009, 05:59 PM   #312
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Haven, Utah
Vehicle:
02 WRX Sedan
MBP

Default

you also need to replace the fuse for the clock/radio...
Jncominco2 is offline   Reply With Quote
Old 03-08-2009, 06:58 PM   #313
ljaviation
Scooby Specialist
 
Member#: 42270
Join Date: Aug 2003
Chapter/Region: South East
Location: Asheboro, NC
Vehicle:
2003 A&P IA
ww.flyingleafaviation.com

Default

[quote][turbowgnWHATQuote:
Originally Posted by CoolRex
You popped a fuse. Disconnect pin B28. ECU has NOTHING to do with this....the WRX ECU from 02-05 are all the same.


so if i pull that pin then i will regain my clock and radio? does anyone have the wiring diagram? thanks again

-chris /QUOTE]

B28 in your car is part of the radio and light circuit. On the STI cluster, that B28 position is a ground. That is why it pops. It
is a direct short.
L J
ljaviation is offline   Reply With Quote
Old 03-09-2009, 12:40 PM   #314
jdmimprez
Scooby Specialist
 
Member#: 153318
Join Date: Jul 2007
Chapter/Region: South East
Location: Hurlburt Field FL
Vehicle:
08 EVO X GSR

Default

Mods... is this sticky worthy?
jdmimprez is offline   Reply With Quote
Old 03-09-2009, 05:23 PM   #315
circaisdashiat
Scooby Newbie
 
Member#: 96315
Join Date: Sep 2005
Chapter/Region: SWIC
Location: Tucson, AZ
Vehicle:
1995 STi V5 replica
World rally blue

Default

swapped an 04 STi cluster into my 2003 swapped 95 impreza.

everything plugged in fine.

Radio fuse was blowing, so i cut the wire, B29? and now everything is fine.

- Shift light works
- Shift buzzer works
- ABS and Airbag lights were on ( i dont have either), i jsut taped over them.
- Diff light is on
circaisdashiat is offline   Reply With Quote
Old 03-16-2009, 08:53 PM   #316
sleepyS14
Scooby Specialist
 
Member#: 171688
Join Date: Feb 2008
Chapter/Region: Tri-State
Location: SiuLam, NY
Vehicle:
2006 Saabaru 9-2x
Aero Wagon Midnight Black

Default

how do i keep the buzzer? ... i put in an '07 sti cluster into an '06 wrx and i got the buzzing.. i know if i clip the wire or yank the buzzer... ill get rid of it..

but i reallie want to retain the shift light beep !! . i always liked that about STi clusters

what year can i use to keep the shift light beep? .. '04?
sleepyS14 is offline   Reply With Quote
Old 03-16-2009, 09:22 PM   #317
OKR S06
Scooby Specialist
 
Member#: 116105
Join Date: May 2006
Chapter/Region: TXIC
Location: Dallas,TX
Vehicle:
2001 Civic/2006 WRX
Blue/Steel Grey Metallic

Default

Quote:
Originally Posted by sleepyS14 View Post
how do i keep the buzzer? ... i put in an '07 sti cluster into an '06 wrx and i got the buzzing.. i know if i clip the wire or yank the buzzer... ill get rid of it..

but i reallie want to retain the shift light beep !! . i always liked that about STi clusters

what year can i use to keep the shift light beep? .. '04?

That buzzing noise you are hearing is not coming from your cluster. It has to do with the reverse power from the wire you need to cut. Once you cut it, the noise will be gone. But, your beeper for your shift light will remain. Also, there if it is not beeping, then it is off.
OKR S06 is offline   Reply With Quote
Old 03-17-2009, 06:21 AM   #318
choiboi
Scooby Specialist
 
Member#: 126614
Join Date: Sep 2006
Chapter/Region: SCIC
Location: Long Beach, Ca
Vehicle:
2006 WRB WRX TR
OS Stage 2

Default

I have a 06 wrx tr. Which sti cluster would be best. I want to have the ill switch thingy so i need 05 or 04 (and most info on those two). Also will the 04 plug directly to my 06 w/o clipping? Does the 05 have the abs light off when plugged to my 06? Both need trimming/grounding for rear diff and radio correct?
choiboi is offline   Reply With Quote
Old 03-17-2009, 01:21 PM   #319
OKR S06
Scooby Specialist
 
Member#: 116105
Join Date: May 2006
Chapter/Region: TXIC
Location: Dallas,TX
Vehicle:
2001 Civic/2006 WRX
Blue/Steel Grey Metallic

Default

Quote:
Originally Posted by choiboi View Post
I have a 06 wrx tr. Which sti cluster would be best. I want to have the ill switch thingy so i need 05 or 04 (and most info on those two). Also will the 04 plug directly to my 06 w/o clipping? Does the 05 have the abs light off when plugged to my 06? Both need trimming/grounding for rear diff and radio correct?

When putting a cluster in your car (If you read this thread from the beginning). You will find out that matching the year cluster with your car is the best option. So, you need to go with a 2006 STi cluster in your car. Of course you will need to do the necessary modifications and since you have a TR model, your outside temperature is not going to work properly. I believe it is going to show it at 43 degrees all the time.
OKR S06 is offline   Reply With Quote
Old 03-17-2009, 05:31 PM   #320
choiboi
Scooby Specialist
 
Member#: 126614
Join Date: Sep 2006
Chapter/Region: SCIC
Location: Long Beach, Ca
Vehicle:
2006 WRB WRX TR
OS Stage 2

Default

Quote:
Originally Posted by OKR S06 View Post
When putting a cluster in your car (If you read this thread from the beginning). You will find out that matching the year cluster with your car is the best option. So, you need to go with a 2006 STi cluster in your car. Of course you will need to do the necessary modifications and since you have a TR model, your outside temperature is not going to work properly. I believe it is going to show it at 43 degrees all the time.
icic thanx. So if i got an 06 sti cluster for my 06 tr, would be process be exactly the same as putting an 05 sti into an 06 tr (this conversion is all i could find on this thread)? But that i just need to mod the illuminator like with a potentiamenter or something i read aobut in another thread?
choiboi is offline   Reply With Quote
Old 03-25-2009, 06:13 AM   #321
Wopin
Scooby Newbie
 
Member#: 206145
Join Date: Mar 2009
Default

Hi,

I am Spanish boy with a Subaru Impreza 2.0R 2007.
I just bought a 2007 STI cluster to ride to my car.
I have been guided in this post but rather than attempt what can not solve the problem of buzzer.
I am not worth the schema for a 07 WRX.
I believe that my cluster is equal to the Impreza RS 2006-2007
Can someone help me?

Thankyou
Wopin is offline   Reply With Quote
Old 03-28-2009, 04:42 PM   #322
hadi10
Scooby Newbie
 
Member#: 159208
Join Date: Sep 2007
Chapter/Region: International
Location: Egypt
Vehicle:
2007 wrx 2007 Lmtd
grey

Default

ok guys.. i have 2 questions... where exactly is the B20 and B22 pins ??! i need to locate them exactly to make the dimmer work.!!
And , i just bought the 05 STi cluster Canadian..! it works with no problems at all except for only 1 problem. the Tempreture Gauge is actually pointing the other side.! its pointing toward the Fuel gauge..! i opened up the cluster and tried to turn it back to its place. but everytime i do so and run the car it just snaps back towards the Fuel gauge.!
is there a fix ? or is it damaged.!!
hadi10 is offline   Reply With Quote
Old 03-28-2009, 08:25 PM   #323
Subiesaurus Rex
Scooby Specialist
 
Member#: 188552
Join Date: Sep 2008
Chapter/Region: SCIC
Location: RanchoSantaMargarita :banana:
Vehicle:
07 WRX+6spd
Never Finished

Default

i did a few searches but came up with nothing - is there a trick to removing the pins? (b28) - I got the pins accessible but I cant seem to just shove them out - any tips/tricks?

Edit - Duh I was able to remove the pins by sticking a toothpick in the hole above the pin and pulling out the pins ... got a little trigger happy w/the post - but yea I hope this comes up in a search to help anyone else!

Last edited by Subiesaurus Rex; 03-28-2009 at 10:24 PM.
Subiesaurus Rex is offline   Reply With Quote
Old 03-28-2009, 08:28 PM   #324
Subiesaurus Rex
Scooby Specialist
 
Member#: 188552
Join Date: Sep 2008
Chapter/Region: SCIC
Location: RanchoSantaMargarita :banana:
Vehicle:
07 WRX+6spd
Never Finished

Default

Quote:
Originally Posted by hadi10 View Post
ok guys.. i have 2 questions... where exactly is the B20 and B22 pins ??! i need to locate them exactly to make the dimmer work.!!

Here is the pin info you asked for - there are no pins in those slots from the factory (i believe)
Subiesaurus Rex is offline   Reply With Quote
Old 03-29-2009, 05:04 AM   #325
hadi10
Scooby Newbie
 
Member#: 159208
Join Date: Sep 2007
Chapter/Region: International
Location: Egypt
Vehicle:
2007 wrx 2007 Lmtd
grey

Default

Quote:
Originally Posted by Subiesaurus Rex View Post

Here is the pin info you asked for - there are no pins in those slots from the factory (i believe)
i dont get it!! when i count from b15 -> to b30 on the schematic , there are a few pins missing..! where exactly is the b20 and b22 ?!! can someone please point them out..!
hadi10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can we get some mods to start deleting duplicate threads? [27] Political Playground 2 11-05-2008 03:01 AM
STi hare emblem? where can i get one... evoeater8 Interior & Exterior Modification 13 07-12-2006 09:53 PM
can we get something started in RDU???(nc) imprezivSTi04 Mid Atlantic Impreza Club -- MAIC 3 04-04-2006 07:47 PM
02 sti hood scoop?? where can i get one? slaterdrew Private 'Wanted' Classifieds 2 02-06-2004 12:37 PM
lighted keyhole ring, can we get one? makanouchi Interior & Exterior Modification 12 11-22-2002 09:38 PM


All times are GMT -4. The time now is 06:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.