Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2008, 04:42 PM   #151
mattius
Scooby Newbie
 
Member#: 178752
Join Date: Apr 2008
Chapter/Region: South East
Location: Atlanta
Vehicle:
2004 WRX Wagon
JBP

Default

Does anyone know of any issues with the wiring when swapping an 04 STi cluster into an 04 Wagon?
* Registered users of the site do not see these ads.
mattius is offline   Reply With Quote
Old 08-15-2008, 04:44 PM   #152
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

i am about to install a 04 sti cluster into my 05wrx with auto hvac. instead of tapeing the lights you dont want to come on like the ddc and the abs cant you just remove those lights from the cluster.
owencalouro is offline   Reply With Quote
Old 08-25-2008, 01:11 PM   #153
ACrAPPYRS
Scooby Newbie
 
Member#: 121545
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: Bronx, NY/ Bloomington, IN
Vehicle:
2005 Broken RS
Aspen White

Default

Ok after looking through this thread I couldn't find answers to my question.

I have an 05 RS, I want an STi cluster. From what I gathered, an 04 STi cluster will be my best bet. Most of it will be PnP, with a need to ground certain wires to disable DCCD, ABS..ect. (would just taking out those corresponding bulbs work rather then grounding the circuit)


Is all this correct?
ACrAPPYRS is offline   Reply With Quote
Old 08-25-2008, 01:27 PM   #154
Chris05STi
Scooby Specialist
 
Member#: 88248
Join Date: May 2005
Chapter/Region: Tri-State
Location: MD
Vehicle:
2005 Subaru STi
Black

Default

Again, does ANYONE have a pics of that one plug where you have to shave it a lil. I got 2 out of the 3 plugs to go in correctly. I know which wires to cut, etc. I have a 2002 WRX and a 2005 STi cluster. ANYONE have ANY feedback and pics on this?!
Chris05STi is offline   Reply With Quote
Old 08-25-2008, 01:37 PM   #155
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

Quote:
Originally Posted by ACrAPPYRS View Post
Ok after looking through this thread I couldn't find answers to my question.

I have an 05 RS, I want an STi cluster. From what I gathered, an 04 STi cluster will be my best bet. Most of it will be PnP, with a need to ground certain wires to disable DCCD, ABS..ect. (would just taking out those corresponding bulbs work rather then grounding the circuit)


Is all this correct?
You can't take out those bulbs...they are LEDS that are wired into the circuit.
CoolRex is offline   Reply With Quote
Old 08-25-2008, 01:40 PM   #156
ProDriven Auto
Former Vendor
 
Member#: 179000
Join Date: May 2008
Chapter/Region: NWIC
Location: W.WA
Vehicle:
2010 Outback
2007 T4R Sport

Default

Quote:
Originally Posted by CoolRex View Post
You can't take out those bulbs...they are LEDS that are wired into the circuit.
You can de solder them =) but that would probably be more complicated for someone then grounding the wires =)

by the way

I have 05sti and 06sti clusters. 350 each plus shipping.
ProDriven Auto is offline   Reply With Quote
Old 08-25-2008, 04:57 PM   #157
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

Tape it will be then. I have done so much wiring back their i just don't want to mess with it anymore.
owencalouro is offline   Reply With Quote
Old 08-25-2008, 07:39 PM   #158
aznburn210
Scooby Specialist
 
Member#: 84062
Join Date: Mar 2005
Chapter/Region: TXIC
Location: South Austin
Vehicle:
2005 WRX
CGM on obnoxious Greennnn

Default

haha i just put an 05 STi cluster in my 05 WRXZ.. everything working correctly..
outside temp - check
no buzzing ( clips c9) - check
cruise control light still need to fix and move over
DCCD still on i havent had a chance to fix that yet
and rear temp light on ..
aznburn210 is online now   Reply With Quote
Old 08-26-2008, 12:11 PM   #159
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

so you didn't have any problems with blown radio fuse; you just plugged right in, and everything is ok (other than no CC light and 2 lights stuck on) what about the shift light does that all work ok.
owencalouro is offline   Reply With Quote
Old 08-26-2008, 12:43 PM   #160
aznburn210
Scooby Specialist
 
Member#: 84062
Join Date: Mar 2005
Chapter/Region: TXIC
Location: South Austin
Vehicle:
2005 WRX
CGM on obnoxious Greennnn

Default

shift light works perfect.. and no fuses on the radio have blown.. although i have an aftermarket radio though
aznburn210 is online now   Reply With Quote
Old 08-29-2008, 11:49 AM   #161
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

OK so i got the 04 sti cluster in my 05 wrx and almost everything works without modding anything (just plugged right in)

here are my problems, maybe someone can help. The dimmer as described in this post doesn't work ("-Illumination levels are set by pressing the odometer reset until "ill" appears in the odometer display".) I press and hold the trip reset and nothing happens. I know that I can rewire the dimmer switch to work with my wrx, I will try that out later. Also, I am not sure, but should their be a difference in illumination between night and day(lights on and off), cause their is not.

The final problem is the speedo, it seems to be about 10mph slow at 70. This leads me to believe that because its a 160top speed and not 140 it is an inaccurate reading. Anyone else havening this problem and maybe an easy fix.

Other then that everything works great, shift light and beep works; so does the outside temp (I have auto hvac). Although the cruise light doesn't come on when I push the button, the set light does, so that's fine with me.

When I get my maddad gauges in I'll setup some pics, I have blue leds on everything with the red gauges, looks dam good I think
owencalouro is offline   Reply With Quote
Old 08-29-2008, 11:56 AM   #162
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

Quote:
Originally Posted by owencalouro View Post
OK so i got the 04 sti cluster in my 05 wrx and almost everything works without modding anything (just plugged right in)

here are my problems, maybe someone can help. The dimmer as described in this post doesn't work ("-Illumination levels are set by pressing the odometer reset until "ill" appears in the odometer display".) I press and hold the trip reset and nothing happens.
You don't press and hold it. Press it and press it again. Should get Trip A, Trip B, ILL. At ILL use the other knob to adjust.
CoolRex is offline   Reply With Quote
Old 08-29-2008, 12:20 PM   #163
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

ok kool thanks, is it also supose to change from day to night(lights on and off)
owencalouro is offline   Reply With Quote
Old 08-29-2008, 12:30 PM   #164
mattius
Scooby Newbie
 
Member#: 178752
Join Date: Apr 2008
Chapter/Region: South East
Location: Atlanta
Vehicle:
2004 WRX Wagon
JBP

Default

^^ yep, turn the knob like you were changing your shift points. If the illumination is set to "5", you will not see a diff. during night/day. Try again on a lower illum. setting.
mattius is offline   Reply With Quote
Old 08-29-2008, 12:31 PM   #165
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

Quote:
Originally Posted by owencalouro View Post
ok kool thanks, is it also supose to change from day to night(lights on and off)
no it's always the same.
CoolRex is offline   Reply With Quote
Old 08-29-2008, 12:35 PM   #166
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

cool ill go down to the parking garage and try this out.

what about your speedo is that working right, mine seems to be off
owencalouro is offline   Reply With Quote
Old 08-29-2008, 01:00 PM   #167
mattius
Scooby Newbie
 
Member#: 178752
Join Date: Apr 2008
Chapter/Region: South East
Location: Atlanta
Vehicle:
2004 WRX Wagon
JBP

Default

^^^ I think mine is off too. I passed one of those Radar signs and there was a 5-8mph difference.
mattius is offline   Reply With Quote
Old 08-29-2008, 01:07 PM   #168
owencalouro
Scooby Newbie
 
Member#: 172342
Join Date: Feb 2008
Chapter/Region: BAIC
Location: SF, bay area
Vehicle:
2011 WRX
DGM

Default

well maybe ill get pulled over for speeding less now, it's like setting your clock early so your never late..
owencalouro is offline   Reply With Quote
Old 08-29-2008, 01:28 PM   #169
CoolRex
*** Banned ***
 
Member#: 85813
Join Date: Apr 2005
Chapter/Region: South East
Location: Myrtle Beach, SC
Vehicle:
2002 E46 M3
2006 RC51

Default

Mine is off by 4-5 mph but I have 235/40/17 tires.
CoolRex is offline   Reply With Quote
Old 08-29-2008, 11:09 PM   #170
6speedRegime
Scooby Specialist
 
Member#: 172187
Join Date: Feb 2008
Chapter/Region: NWIC
Location: Tacoma, WA
Vehicle:
2012 WRX Limited
02 MBP WRX, 04 WRB STi

Default Radio not working after sti cluster swap

I just installed an 05 wrx sti cluster into an 02 wrx. Everything is working as expected, but my radio no longer works. Its not the fuse, i checked, so what is the problem??
6speedRegime is offline   Reply With Quote
Old 09-10-2008, 01:18 AM   #171
STL WRX
Scooby Specialist
 
Member#: 88304
Join Date: Jun 2005
Chapter/Region: MAIC
Location: Tazewell, Va
Vehicle:
05 VF34 Aspen WRX

Default

Whats the best year cluster to install into my 05 WRX? Will an 06-07 cluster work?
STL WRX is offline   Reply With Quote
Old 09-10-2008, 03:18 AM   #172
02blkwagn19
Scooby Specialist
 
Member#: 146496
Join Date: Apr 2007
Chapter/Region: SWIC
Location: Tempe, AZ
Vehicle:
02 WRX Wagon 2.1L
Built not bought. #0003

Default

03wrxmarine, you need to cut a wire in order for the radio to stop blowing fuses and work properly. i had the same problem when i did mine. i want to say it is the orange wire you need to cut. but it was a while ago and im not 100% sure on that.
02blkwagn19 is offline   Reply With Quote
Old 09-22-2008, 05:18 PM   #173
mattius
Scooby Newbie
 
Member#: 178752
Join Date: Apr 2008
Chapter/Region: South East
Location: Atlanta
Vehicle:
2004 WRX Wagon
JBP

Default

has anyone gotten the OAT sensor to work on a 2004 WRX w/ a 2004 STi cluster?
mattius is offline   Reply With Quote
Old 09-23-2008, 10:18 AM   #174
WagonGGA
Scooby Specialist
 
Member#: 134481
Join Date: Dec 2006
Chapter/Region: Tri-State
Location: Yankee Stadium
Vehicle:
08/4 Subaru
Legacy Spec B/Forester XT

Default

Ok so has anyone apart from prodrivedreams successfully installed a 04 cluster into a 06-07 wrx and switched the polarity of the abs light?? I have tried to contact prodrivedreams but he doesnt answer. He speaks of a relay, is it a standard relay or a special one??
Looking to install my cluster sometime this week.
WagonGGA is offline   Reply With Quote
Old 09-24-2008, 10:43 PM   #175
Norrberrt
Scooby Specialist
 
Member#: 110021
Join Date: Mar 2006
Chapter/Region: SCIC
Location: Socal
Vehicle:
2003 WRXSTi
Silver

Default

Quote:
Originally Posted by BlueSubeDude View Post
I'd leave some room on the connector side when clipping C9 so it can be pulled out and put in B4 to ground (B4 didn't have a wire in my case).

Also, I reprogrammed the STI cluster to match my current mileage. Good luck.
How did u reprogram to get correct mileage?.. i called Tacoma Speedometer.. and they said they cannot set it to what you want.. I want to set mines to Zero.. im installing a new Block.. im going with an 06 STi Block.. so i want my mileage to start off at Zero..

Installation of my 05 STi Cluster USDM in my 03 WRX..


Norrberrt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can we get some mods to start deleting duplicate threads? [27] Political Playground 2 11-05-2008 02:01 AM
STi hare emblem? where can i get one... evoeater8 Interior & Exterior Modification 13 07-12-2006 08:53 PM
can we get something started in RDU???(nc) imprezivSTi04 Mid Atlantic Impreza Club -- MAIC 3 04-04-2006 06:47 PM
02 sti hood scoop?? where can i get one? slaterdrew Private 'Wanted' Classifieds 2 02-06-2004 11:37 AM
lighted keyhole ring, can we get one? makanouchi Interior & Exterior Modification 12 11-22-2002 08:38 PM


All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.