Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-29-2008, 09:42 PM   #1
GeLLo_Boi
Scooby Specialist
 
Member#: 89735
Join Date: Jun 2005
Location: nowhere special
Vehicle:
2005 Subaru STi
WRB

Default clutch pedal clicking noise

as title says im getting a clicking noise everytime i press down on my clutch pedal. noise resembles the clicking sound made when ur turn signal is on. checked it out and cant quite pinpoint the exact location. strange thing is that it only appears after 20+ minutes or so of driving meaning it will go away the next day, not click upon initially driving it but then start clicking after 20 mins or so, then disappears again in the morning or after several hours. anyone have any idea what this could be? im jus hoping its something as simple as greasing up the shaft or joints of the clutch pedal and nothing more complicated than that.
* Registered users of the site do not see these ads.
GeLLo_Boi is offline   Reply With Quote
Old 02-29-2008, 11:28 PM   #2
kimoman
Scooby Newbie
 
Member#: 97476
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NY
Vehicle:
2006 Impreza 2.5i
Aspen white

Default

FWIW: I'd just bring it in to the dealership have them look assuming its under warranty. Sorry can't be more helpful.
kimoman is offline   Reply With Quote
Old 03-01-2008, 12:20 AM   #3
littlewhitewagon
Scooby Guru
 
Member#: 103068
Join Date: Dec 2005
Chapter/Region: SCIC
Location: PM me if I don't answer posts
Vehicle:
11 STI sedan
SWP

Default

I had the same click click sound. I think it was the return assist spring or clutch switch. I rubbed grease all over the moving areas and the noise went away.
littlewhitewagon is offline   Reply With Quote
Old 03-01-2008, 11:39 AM   #4
dru_hill
Scooby Newbie
 
Member#: 67661
Join Date: Aug 2004
Chapter/Region: MWSOC
Location: Chicago, IL
Vehicle:
2004 WRX sedan
Blue

Default

Quote:
Originally Posted by littlewhitewagon View Post
I had the same click click sound. I think it was the return assist spring or clutch switch. I rubbed grease all over the moving areas and the noise went away.
Its the spring or pivot on the clutch pedal. Grease that bad boy up and it should be ok.
dru_hill is offline   Reply With Quote
Old 03-01-2008, 12:56 PM   #5
shakur45
Scooby Specialist
 
Member#: 165106
Join Date: Nov 2007
Chapter/Region: MAIC
Location: Crunchville, PA
Vehicle:
2008 WRX Stage 1
Obsidian Black Pearl

Default

How many mile? Is in still in warranty
shakur45 is offline   Reply With Quote
Old 03-01-2008, 03:41 PM   #6
GeLLo_Boi
Scooby Specialist
 
Member#: 89735
Join Date: Jun 2005
Location: nowhere special
Vehicle:
2005 Subaru STi
WRB

Default

car has 24,521 miles......started clicking around 24,38x.....i was jus hoping itd go away on its own hehe......but yeh ill try greasing it.....hopefully it goes away.....the clicking is super annoying......esp when i turn the music off and roll the windows down so i can jus hear the exhaust notes.....the clicking jus gets irritating
GeLLo_Boi is offline   Reply With Quote
Old 03-01-2008, 08:37 PM   #7
littlewhitewagon
Scooby Guru
 
Member#: 103068
Join Date: Dec 2005
Chapter/Region: SCIC
Location: PM me if I don't answer posts
Vehicle:
11 STI sedan
SWP

Default

Quote:
Originally Posted by dru_hill View Post
Its the spring or pivot on the clutch pedal. Grease that bad boy up and it should be ok.
Yeah, I fixed my noise about 40k miles ago... it wasn't the loud to me, the wife is the one who asked questions about my car making funny noises.
littlewhitewagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Click noise from Clutch Pedal? krinksta Newbies & FAQs 34 11-22-2011 08:03 PM
06 STI Clutch Pedal Whine Noise wil06STI Factory 2.5L Turbo Powertrain 1 06-09-2008 03:30 PM
Clutch pedal ticking noise kenchan Transmission (AT/MT) & Driveline 13 05-12-2004 09:09 PM
Clutch pedal popping noise. profkirby Transmission (AT/MT) & Driveline 24 07-11-2003 02:33 PM


All times are GMT -4. The time now is 11:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.