Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-03-2008, 03:22 PM   #1
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default Ugh another problem with my Subaru

Ok anyone know about these? The dealer says they have never seen this before...so far thats pretty much 3 for 3 on my car heh

paint flying off when you look at it, marbles in a coffee can when you got around 3K rpms in 1st gear and now at 1900 miles a cel/trac control/cruise threesome

The codes they pulled were: (1900 miles on the clock) 2008 wrx

P0340 Camshaft position sensor circuit malfunction
P0341 Camshaft position sensor circuit range/performance problem
P0336 Crankshaft position sensor circuit range/performance problem

What has them scratching their heads was that according to their snapshot (they take one to ensure I am not beating on the car aparently)
shows the cel got thrown when the car was not running. Which i cant 100% verify but it is possible I noticed it a second after I had started the car for a second time today after getting coffee. It wasnt on when i shut the car down to go into the store.


The manager tried to give the car back to me after clearing the codes (is that normal wouldnt they try to actually fix the issue first?) but I didnt think that was prudent. I think given the surging/sputtering while accelerating from time to time and the difficult starts the computer may be on to something (ie the cel)

Anyone else see/fix this? The car runs so poorly i dont even bother to get into boost mostly I just figured it was still breaking in but that may not now appear to be the case.
thanks
dex
* Registered users of the site do not see these ads.
dexion is offline   Reply With Quote
Old 03-03-2008, 04:33 PM   #2
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

Keep all paperwork and request they give you a copy of work done including your description of your problems stated to the service manager. This is a big help if you want to use the lemon law.

Resetting codes without finding the cause and sending you off is not very professional. Your dealer may be cheap and a place the best subaru techs in your area dont want to work at. Some dealers will pay and treat mechanics better meaning the good ones in seattle as an example work at dealer A, while the young and inexperienced sucky ones work at dealer B.
mikeythejew is offline   Reply With Quote
Old 03-03-2008, 07:04 PM   #3
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

I just wish there was a way we/i could see all the technical notes/reports on the cars instead of having to suffer with issues. But then again, i can see a downside to that as well then people will start complaining about things that possibly could (but arent at the moment) be wrong with their cars.
dexion is offline   Reply With Quote
Old 03-03-2008, 11:04 PM   #4
SubeTek
Scooby Specialist
 
Member#: 1714
Join Date: Jun 2000
Chapter/Region: RMIC
Location: Arvada,Co
Vehicle:
1999 RS-T COUPE
Black

Default

Quote:
Originally Posted by dexion View Post
I just wish there was a way we/i could see all the technical notes/reports on the cars instead of having to suffer with issues. But then again, i can see a downside to that as well then people will start complaining about things that possibly could (but arent at the moment) be wrong with their cars.
i see this all the time at our dealership--someone reads something on the internet and takes it out of context, next they are convinced their vehicle has the same problem. the dealer you're working with should get in touch with subaru techline to see if they've seen similar problems. best of luck.
SubeTek is offline   Reply With Quote
Old 03-04-2008, 12:20 AM   #5
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

i did hear back from them. They said the techline said they had one other car so far with the same issue but it was an automatic. Im not sure if that matters in this case, but the manager seemed to think this makes my problem different from that car. They have it tho so im under the impression they will reproduce the issue or troubleshoot it further.
dexion is offline   Reply With Quote
Old 03-30-2008, 09:09 PM   #6
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

well, 24 days later i am finally getting my car back I am to pick it up on monday. (second set of cel (same codes) hit me at 2100 miles so they took it back and tried to troubleshoot it.)

They say its fixed. Aparently all they did though was replace the 3 sensors that were complaining. Not too sure why it took them over 3 weeks to get that done, but im hopping for the best. I'll update after a while in case someone else gets the same issue with their car they will know what fixes it instead of waiting so long like me.
dex

Last edited by dexion; 03-30-2008 at 11:58 PM.
dexion is offline   Reply With Quote
Old 04-04-2008, 07:43 AM   #7
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

ok just an update problem not solved. The dealer has it back again. Anyone else getting
any wierd power loss issue followed by a delayed cel?
dexion is offline   Reply With Quote
Old 04-04-2008, 08:01 AM   #8
Doc Holiday
Scooby Newbie
 
Member#: 171713
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Watertown, MA
Vehicle:
2000 Impreza 2.5RS
Silverthorn Metalic

Default

Call SOA, there is no reason for a brand new car to be giving you this much crap, sounds like a lemon to me.
Doc Holiday is offline   Reply With Quote
Old 04-04-2008, 10:54 AM   #9
leecea
Scooby Guru
 
Member#: 37359
Join Date: May 2003
Vehicle:
2003 WRX

Default

Not sure if it is urban legend or reality, but I thought 3 attempts to fix the same problem did qualify for Lemon status in many states.
leecea is offline   Reply With Quote
Old 04-04-2008, 07:45 PM   #10
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

in michigan its 4 attempts for the same problem or 30 days out of service in the first year.

Its 3 attempts for the same problem but 35 days out of service out of about 65 days owning it (assuming my math is right) its been in the shop A LOT 9 times i believe and the subaru rep is taking it with him this weekend to see if he can reproduce the problem so assuming i get it back monday it would be out of service 37 days. I have a lawyer now and he has all the info/summary of what has happened with the car so far. He asked me to give them this one last chance and see what they say on monday. Then we can do the lemon thing if they still arent going to do the right thing.
dexion is offline   Reply With Quote
Old 04-04-2008, 10:12 PM   #11
surowrxa
Scooby Specialist
 
Member#: 102895
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
'12 Forester
'08 Legacy

Default

This may interest you.

http://forums.nasioc.com/forums/show....php?t=1487482

Marbles in a tin can seem to be happening in other places too.
surowrxa is offline   Reply With Quote
Old 04-04-2008, 10:45 PM   #12
DCales
Scooby Newbie
 
Member#: 131509
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Winchester Va
Vehicle:
2006 Impreza WRX
WRB

Default

Get some info on what tests were done by the techs at the dealer. With the codes that you posted i would be looking at the timing to verify that its not a tooth off or if anything else has skipped or stretched. You can always call SOA direct and record a complaint to help document the situation. I have dealt with customers that have gone through a buyback situation and it takes time.... the last customer i dealt with was a suzuki customer and it took nearly 4 months to get her outta here car and into something new.
DCales is offline   Reply With Quote
Old 04-04-2008, 10:47 PM   #13
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

thank goodness theres possibly some notice on this. it appears I would qualify under the dates they say and my car sure is a basket case. Can anyone confirm i may be misreading this.
I have a 2008 subaru wrx sedan which i bought around 2/1 do I qualify under this? Is it a real bullitin? Is there some number I can give them to look it up tomorrow? The past 2 months have been a horrible experience for me and I just want it to end.
dexion is offline   Reply With Quote
Old 04-05-2008, 04:49 AM   #14
surowrxa
Scooby Specialist
 
Member#: 102895
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
'12 Forester
'08 Legacy

Default

Quote:
Originally Posted by dexion View Post
Can anyone confirm i may be misreading this.
I have a 2008 subaru wrx sedan which i bought around 2/1 do I qualify under this? Is it a real bullitin? Is there some number I can give them to look it up tomorrow?
Qualification will be determined by your Vehicle Identification # that is on a stamped plate attached to your dashboard in front of your steering wheel, near the windshield.

Hope it works out for you.
surowrxa is offline   Reply With Quote
Old 04-05-2008, 08:09 AM   #15
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

so do i thanks
dexion is offline   Reply With Quote
Old 04-05-2008, 10:57 AM   #16
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

well according to the dealer my car was produced before the problem happened. bummer
dexion is offline   Reply With Quote
Old 04-05-2008, 06:38 PM   #17
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

well subaru just extended the range of affected vehicles back 2 more months to 11/01/07 i took delivery around feb 1st but the dealer has the car and i cant verify im on the list
because they are now closed. to be continued i guess heh
dexion is offline   Reply With Quote
Old 04-10-2008, 11:08 AM   #18
dexion
Scooby Newbie
 
Member#: 171676
Join Date: Feb 2008
Chapter/Region: MWSOC
Vehicle:
2008 impreza wrx
silver

Default

Just an update the dealership is buying me out of the car. I have nothing but respect with how the owner handled the situation with me. Im now activly trying to find anything else to drive. I dont feel i can get another subaru wrx at this time with the problems and paint issues. I must say its damn hard i cant find anything I like at all for around 25K. Unless i spend 6K more for an r32 and the evo 10 seems to be plagued with issues as well (from reading their forums) im really bummed out about the whole thing this is my 5th subaru and i dont know what to do heh. Good luck to everyone
dex
dexion is offline   Reply With Quote
Old 04-10-2008, 08:03 PM   #19
surowrxa
Scooby Specialist
 
Member#: 102895
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
'12 Forester
'08 Legacy

Default

Thanks for the update. Glad it worked out (eventually).

You're right, for (new) AWD fun/fury at 25K it's tough to find a replacement. Maybe look into a low miles used 2007?

Good luck.
surowrxa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ugh two problems with Evo2 catback install right now Civ2Sub311 Newbies & FAQs 27 10-13-2009 06:33 PM
Yet another Problem with my aquamist system.. 96convt Water/Methanol Injection, Nitrous & Intercooler Cooling 7 08-22-2009 03:46 AM
I have a serious problem with my subaru alarm. Wheels Car Audio, Video & Security 4 08-22-2006 02:37 PM
im a subaru owner but having problems with my honda 04stiblk Off-Topic 16 02-04-2005 01:26 PM
ATX: remember my problems with Austin Subaru? [27] Texas Impreza Club Forum -- TXIC 19 11-14-2003 03:20 PM


All times are GMT -4. The time now is 02:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.