Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-04-2008, 05:24 PM   #1
Adictwrx
Scooby Newbie
 
Member#: 147668
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Richmond, Va
Vehicle:
2002 WRX
Black

Default Injector issues.

OK, so after having my 02 wrx out of commission for about 6 months now due to a fire from a leaky injector (sti 565 pink) I have acquired most/all of what I need to put it back together, including a new engine wiring harness that got toasted. So this is my delima; with all that happened I ended up having to take the intake manifold off, and though that Ill just get TGV deletes (got them) and Aps inlet (got it).Once I got those things assembled and put back on the manifold I noticed that after I bolted the fuel rail on and seated the new injectors and o-rings I have some up-and-down play on the injectors in between the fuel pipe and the injector location of the TGV assembly. It only moves about.. a quarter inch tho. Im not sure if this is normal on the WRXs/STIs or not? I know that you can turn them a little in a circular motion (most all injectors do that), I just dont want to have another catastrophe again... Car Fires suck.. I would appreciate some insight to my delima.

-Thanks
* Registered users of the site do not see these ads.
Adictwrx is offline   Reply With Quote
Old 03-05-2008, 08:25 AM   #2
Rippen Griffen
Scooby Specialist
 
Member#: 91708
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Chesterfield, VA
Vehicle:
AD Motorsports FTW
06 OBP - Cobb AP Stg 2

Default

Bump for my buddy Rodger
Rippen Griffen is offline   Reply With Quote
Old 03-05-2008, 09:13 AM   #3
AWD4BANGER
Scooby Newbie
 
Member#: 166848
Join Date: Dec 2007
Chapter/Region: MAIC
Location: VA
Vehicle:
05 sti

Default

When I installed mine on my other wrx, the instruction were to push them up into the fuel rail. The movement will decrease with pressure. I was also told to connect the green connector under the dash. This will fire the fuel pump and you can tell if you have a leak before you crank it. Hope this helps.
AWD4BANGER is offline   Reply With Quote
Old 03-05-2008, 10:07 AM   #4
nhat
Scooby Guru
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

both of yous need to set your region/chapter info!

good luck!
nhat is offline   Reply With Quote
Old 03-05-2008, 08:51 PM   #5
Adictwrx
Scooby Newbie
 
Member#: 147668
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Richmond, Va
Vehicle:
2002 WRX
Black

Default

Thanks guys... I need the luck lol.

Oh and Adam, I hope I can make it out to the install meet, work is my only issue. I wanna check out whats happenin out there!
Adictwrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Injector issue DreamEvil Engine Management & Tuning 1 01-03-2010 02:59 PM
Modified Blue Injectors - Issue BlackEyeBugEye Open Source Reflashes 17 07-30-2008 10:37 PM
02 wrx hesitation/ poss fueling/injector issue? 95lwrx Factory 2.0L Turbo Powertrain 1 04-19-2008 08:56 PM
Injector + Turbo Install Issues Help Me Out Milwaukee MustGoFast Mid West Subaru Owners Club Forum -- MWSOC 26 10-15-2003 05:49 PM
Sti Injector issue please help WRC WRX Factory 2.0L Turbo Powertrain 0 03-01-2003 12:45 PM


All times are GMT -4. The time now is 06:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.