Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-22-2008, 11:31 PM   #1
ycatsce
Scooby Newbie
 
Member#: 74896
Join Date: Nov 2004
Chapter/Region: South East
Location: Tennessee
Vehicle:
2003 WRX
WRB

Question Issues after minor collision.

I got into a wreck a few months back. Nothing major, just some front end damage, but I did catch my radiator hose on my belt and cut it in half when attempting to drive away, which caused sudden and severe loss of coolant, after which I only drove around 20 yards in order to get out of the middle of the road.

Well, the car was taken to the body shop and all repairs were done w/o noted issue.

Since receiving the car back, I have noticed several issues which have come about:
1. Overheating at idle.
2. No heater when sitting still.
3. Intermittent rough starting (Only when starting cold, and not every time, it will run extremely rich and idle as though it is about to cut out on me).
4. A/C compressor will not engage.
5. Hesitation when starting to boost.
6. Running extremely rich with poor gas mileage (~15mpg w/o boost).
7. Very slight valve tap.

I have tried flushing the coolant system hoping this was my overheating and heater problem but it did not resolve the issue.

I am w/o a laptop so unable to check the utec logs and see if there is a possible issue with my maps.

I have checked my coolant and overflow tanks and have not seen anything indicating a blown head-gasket and there is no coolant loss, but I have noticed that my oil which was just recently changed (~500 miles before the accident) is extremely runny.

I understand that the body shop will need to be involved, and that will happen on Monday, but I am wondering if, from the symptoms, any of you may have an idea what exactly the problem(s) may be.
* Registered users of the site do not see these ads.

Last edited by ycatsce; 03-23-2008 at 12:28 AM.
ycatsce is offline   Reply With Quote
Old 03-23-2008, 08:13 AM   #2
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

This is ONE rare time I hope your Subaru dealer also has a body shop on the same property, and you took your car there to get it fixed in the first place.
mikeythejew is offline   Reply With Quote
Old 03-23-2008, 09:48 AM   #3
surowrxa
Scooby Specialist
 
Member#: 102895
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
'12 Forester
'08 Legacy

Default

Quote:
Originally Posted by ycatsce View Post
1. Overheating at idle.
2. No heater when sitting still.
3. Intermittent rough starting (Only when starting cold, and not every time, it will run extremely rich and idle as though it is about to cut out on me).
4. A/C compressor will not engage.
5. Hesitation when starting to boost.
6. Running extremely rich with poor gas mileage (~15mpg w/o boost).
7. Very slight valve tap.
Overheating at idle could be your radiator fan is not kicking on. This happened to someone on here a few weeks back, but he never posted back with his solution....

Everything else sounds like your belt/pulley systems in front got tweaked. Some people with front-end collision damage have also jumped a tooth or two on the timing belt.

Good luck with the "shop talk".
surowrxa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Stalling at Idle after minor Mods MaLT Newbies & FAQs 21 01-10-2012 03:58 PM
Tips for Choosing a Body Shop After a Collision Ultimate Collision Center Tri-State Area Forum 6 10-20-2009 02:12 PM
Stalling at Idle after Minor Mods MaLT Factory 2.5L Turbo Powertrain 16 06-17-2006 04:51 PM
Is my clutch stiffer after a collision? Len Transmission (AT/MT) & Driveline 0 02-23-2006 11:01 AM
Fine tuning a dyno tune after minor mods? kharris4 Engine Management & Tuning 0 09-01-2005 09:39 PM


All times are GMT -4. The time now is 06:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.