Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-15-2002, 12:34 AM   #1
Avey
Scooby Newbie
 
Member#: 8211
Join Date: Jul 2001
Location: Mississauga, ON
Vehicle:
2002 Impreza WRX
WR Blue

Unhappy Cyl 3 Misfire

I have had this code three times, the first time the dealer cleared the code, the second time they reflashed my ECU, today I got it again even after the ECU reflash. Supposedly they have seen this on a few cars, has anyone here had this code from a mechanical malfunction? My car is still stock. I am going in next thursday to get it looked at.

Thanks
* Registered users of the site do not see these ads.
Avey is offline   Reply With Quote
Old 02-15-2002, 06:19 PM   #2
CanadianWRB-WRX
Scooby Newbie
 
Member#: 13951
Join Date: Jan 2002
Location: Ottawa, Ontario, Canada
Vehicle:
2002 Imprezza WRX
WRB

Default

Code P0303...ahh, my favorite error. The only one I ever seem to get on my WRX.

I'll give ya the background on mine quickly.
-1st CEL at about 5000km
-dealer reset ECU
-2nd CEL at about 7000km
-dealer reset ECU
-3rd CEL at about 10000km
-dealer reset ECU
-4th CEl at about 20000km
-got a bit mad at dealer, they had their service manger look into it and ordered a new Injector for 3rd cyl. (delivery time about 2 weeks)
- 1 month later...
- anywhere from 20-30 CELs have now come and gone...resets on its own after a few trips each time
- car in for 24k service. SOC rep says injector wont fix prob, instead replaces ECM as per SOC directions.
- next 6-8k km all is good
- 2 days ago (32k) CEL again
-1 day ago (32k) CEL again
- today (32k) CEL again
- car in for 30k oil change/inspection
- dealer replaces 3rd cyl spark plug and installs new injector
- new radiator ordered (leaking seam)


Will let ya know the outcome, but im not holding my breath that this prob is gone yet.

Other odd thing i realized the other day. Since the new ECM was installed some odd things have been happening. Can anyone tell me if these can be related in anyway to the ECM? Wipers no longer funtion like they used to. Used to always complete a full windshield swipe. Now they come to rest about 3 inches up from their home position about 50% of the time. Also had the wipers just do a swipe yesterday wihtout any input from me. hand was nowhere near the wiper stick. Just came on all by themselves.

Chris Steketee
WRB WRX
- Short shifter
- Cusco shifter bushings
- Hella Supertones
CanadianWRB-WRX is offline   Reply With Quote
Old 02-15-2002, 10:20 PM   #3
Avey
Scooby Newbie
 
Member#: 8211
Join Date: Jul 2001
Location: Mississauga, ON
Vehicle:
2002 Impreza WRX
WR Blue

Default

They drove my car to SOC headquarters in Misissauga, which is not far from the dealership. I am guessing that they replaced your ECM because it was easier than sending it away for reprogramming. So the ECM update doesn't really resolve the problem. Well I will also let you know what happens this Thursday when I take it in, one way to know if SOC has actually found a fix is to see if they repair the same part on our cars.

Good luck
Avey is offline   Reply With Quote
Old 02-15-2002, 10:45 PM   #4
wrxracer
Scooby Specialist
 
Member#: 5275
Join Date: Mar 2001
Location: corpus christi texas U.S.
Vehicle:
2002 impreza WRX
WR BLUE

Lightbulb might try this....

well i was having what sounds like the same problem, lets see.. if trying to pass a car on the expressway half throttle i would get this missfire...took car to dealer last week and got it back today, now so gar only 12miles since i got her back but the dealer said the SOA had the dealer order a set of new plugs all around, but they had them go with a set one heat range higher/hotter.. not sure yet if this is the fix, i will try to keep you updated, going to take car out tomorrow to see if runs right...
wrxracer is offline   Reply With Quote
Old 02-20-2002, 08:05 PM   #5
Avey
Scooby Newbie
 
Member#: 8211
Join Date: Jul 2001
Location: Mississauga, ON
Vehicle:
2002 Impreza WRX
WR Blue

Question

Quote:
Originally posted by CanadianWRB-WRX
Code P0303...ahh, my favorite error. The only one I ever seem to get on my WRX.

I'll give ya the background on mine quickly.
-1st CEL at about 5000km
-dealer reset ECU
-2nd CEL at about 7000km
-dealer reset ECU
-3rd CEL at about 10000km
-dealer reset ECU
-4th CEl at about 20000km
-got a bit mad at dealer, they had their service manger look into it and ordered a new Injector for 3rd cyl. (delivery time about 2 weeks)
- 1 month later...
- anywhere from 20-30 CELs have now come and gone...resets on its own after a few trips each time
- car in for 24k service. SOC rep says injector wont fix prob, instead replaces ECM as per SOC directions.
- next 6-8k km all is good
- 2 days ago (32k) CEL again
-1 day ago (32k) CEL again
- today (32k) CEL again
- car in for 30k oil change/inspection
- dealer replaces 3rd cyl spark plug and installs new injector
- new radiator ordered (leaking seam)


Will let ya know the outcome, but im not holding my breath that this prob is gone yet.

Other odd thing i realized the other day. Since the new ECM was installed some odd things have been happening. Can anyone tell me if these can be related in anyway to the ECM? Wipers no longer funtion like they used to. Used to always complete a full windshield swipe. Now they come to rest about 3 inches up from their home position about 50% of the time. Also had the wipers just do a swipe yesterday wihtout any input from me. hand was nowhere near the wiper stick. Just came on all by themselves.

Chris Steketee
WRB WRX
- Short shifter
- Cusco shifter bushings
- Hella Supertones

Any news?
Avey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting cyl 3 misfire code - Why ? Bruce K 2K2 WRX Newbies & FAQs 13 10-09-2007 09:02 PM
Cyl 3 and 4 misfire - 98 RS Bronco Normally Aspirated Powertrain 10 04-25-2006 10:15 AM
Misfire Cyl 3-4 CEL cstyker1111 Newbies & FAQs 1 11-23-2005 11:34 AM
Misfire Cyl 3 What can cause this? SubaruImpreza_power Normally Aspirated Powertrain 20 01-26-2004 11:07 AM
Cyl 1&2 misfire, 4.0 V maf at 3 psi?????? TexRex2002 Factory 2.0L Turbo Powertrain 5 11-16-2003 06:28 PM


All times are GMT -4. The time now is 07:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.