Welcome to the North American Subaru Impreza Owners Club Tuesday April 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 03-22-2008, 06:14 PM   #1
ryanviola
Scooby Newbie
 
Member#: 148445
Join Date: May 2007
Chapter/Region: Tri-State
Location: M.R. Performance Mineola NY
Vehicle:
06 wrx
FP Green 450whps at 22lbs

Default my car sucks

my car wont start..has gas battery is charged... I DUNNO heavly modded not shure wtf is wrong it all started after putting a clutch kit in. Any ideas>? anything i no it can be anything but just an idea from someone...JR where you at i need ur help
* Registered users of the site do not see these ads.
ryanviola is offline  
Old 03-22-2008, 06:30 PM   #2
nhat
Scooby Guru
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

did you think to check the clutch kit you just installed?
nhat is offline  
Old 03-22-2008, 06:48 PM   #3
tux121
Scooby Specialist
 
Member#: 162942
Join Date: Oct 2007
Location: MN
Vehicle:
2006 STi Black&Gold
Stage 2

Default

Obviously something was not put back together when the clutch was installed
tux121 is offline  
Old 03-23-2008, 09:27 PM   #4
ryanviola
Scooby Newbie
 
Member#: 148445
Join Date: May 2007
Chapter/Region: Tri-State
Location: M.R. Performance Mineola NY
Vehicle:
06 wrx
FP Green 450whps at 22lbs

Default

Quote:
Originally Posted by tux121 View Post
Obviously something was not put back together when the clutch was installed
it drove fine for alittle so its not like the clutch was installed n it just didnt drive rite it was alittle after...and now wen i try n start it the ecu clicks
ryanviola is offline  
Old 03-23-2008, 09:52 PM   #5
Ranatsu
Scooby Specialist
 
Member#: 87314
Join Date: May 2005
Chapter/Region: TXIC
Location: San Antonio
Vehicle:
2013 BRZ
Crystal Black Silica

Default

I'm pretty sure that the ecu does not click... at any point in time.
Ranatsu is offline  
Old 03-23-2008, 10:10 PM   #6
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Your profile isn't filled out so we have no idea what to do. Fill it out and repost.

P.S. And repost in the RIGHT forum.
Unabomber is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Car Sucks...anyone Have An Ignition Coil??? SpamMansXe Mid Atlantic Impreza Club -- MAIC 10 02-11-2003 10:15 PM
OK, my car sucks trhoppe South East Region Forum 11 11-11-2002 09:35 AM
my car sucks... ellinopedo182 Transmission (AT/MT) & Driveline 28 03-02-2002 10:30 AM
My car sucks now! RyanC New England Impreza Club Forum -- NESIC 19 08-24-2001 09:45 PM
why does my car suck?? spunky General Forum Archive 4 11-27-2000 11:19 PM


All times are GMT -4. The time now is 08:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.