Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-25-2008, 02:00 PM   #1
jon6682
Scooby Newbie
 
Member#: 85954
Join Date: Apr 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 2.5RS
Crystal Gray Metallic

Default OK to use Bosch O2 sensor instead of Subaru sensor?

I am getting a check-engine-light related to my o2 sensor - bank 1. I'm not sure what the exact code was... I had the guy at Schucks auto supply get the code and he told me i needed to replace the o2 sensor. He also thought it would be fine to use the BOSCH universal 02 sensor he sold me for $70.

I called the subaru dealership and they said it would be $315 to replace with an OEM sensor.

Does anyone know if it is OK to use the BOSCH universal o2 sensor instead of going to the dealership for the OEM part?

Thanks!
* Registered users of the site do not see these ads.
jon6682 is offline   Reply With Quote
Old 03-25-2008, 02:34 PM   #2
Not-EWRX
Scooby Specialist
 
Member#: 158043
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2013 Wrx Hatch
SWP

Default

Yeah, It's the same thing. You just have to find the right wiring schematic and splice it in with the old sensor.
Not-EWRX is offline   Reply With Quote
Old 03-25-2008, 02:44 PM   #3
jey
Scooby Specialist
 
Member#: 32503
Join Date: Feb 2003
Chapter/Region: TXIC
Location: Johnson City, TX
Vehicle:
2011 Tribeca
1995 Legacy Wagon

Default

Holy cow $315? Dealership "only" charged me like $120 for my sensor, it was for a 98 Legacy but this sounds like robbery for newer car owners!
jey is offline   Reply With Quote
Old 03-25-2008, 04:18 PM   #4
JamesWilson
Former Vendor
 
Member#: 124833
Join Date: Sep 2006
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2000 Legacy Wagon
Mystic Mountain Blueberry

Default

Bought mine at SparkPlugs.com , NTK sensors are very good. Zero issues in the last 60K miles.
JamesWilson is offline   Reply With Quote
Old 03-25-2008, 05:45 PM   #5
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Quote:
Originally Posted by jon6682 View Post
I am getting a check-engine-light related to my o2 sensor - bank 1. I'm not sure what the exact code was... I had the guy at Schucks auto supply get the code and he told me i needed to replace the o2 sensor. He also thought it would be fine to use the BOSCH universal 02 sensor he sold me for $70.

I called the subaru dealership and they said it would be $315 to replace with an OEM sensor.

Does anyone know if it is OK to use the BOSCH universal o2 sensor instead of going to the dealership for the OEM part?

Thanks!
You need to know whether the problem is with Bank 1 Sensor 1 or with Bank 1 Sensor 2. I'm pretty sure a universal O2 sensor won't work as a replacement for Sensor 1.
Jon [in CT] is offline   Reply With Quote
Old 03-26-2008, 02:38 AM   #6
birukun
Scooby Newbie
 
Member#: 52801
Join Date: Jan 2004
Chapter/Region: SCIC
Location: San Diego, CA.
Vehicle:
1999 Legacy Wagon L
Green 30th Anniv.

Default

Is this for your 2005? Powertrain warranty?

On another note, the O2 sensor in my Subaru (and maybe yours) is actually an Air/Fuel Ratio meter - 4 wires, the generic Bosch did not work. Best to go with OEM on the O2 sensor unless someone out here has already tested one successfully.
birukun is offline   Reply With Quote
Old 04-07-2008, 06:55 PM   #7
jon6682
Scooby Newbie
 
Member#: 85954
Join Date: Apr 2005
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2005 2.5RS
Crystal Gray Metallic

Default

Warranty will not cover this as it is deemed an electric problem and I have over 36K miles on the car.

I'm still hoping to use the BOSCH sensor but I'm not sure if it will work. This is for my 2005 Impreza RS...

Thanks!
jon6682 is offline   Reply With Quote
Old 04-08-2008, 11:19 AM   #8
Greenbeast
Scooby Newbie
 
Member#: 176457
Join Date: Apr 2008
Default O2 Sensor

I used a Bosch on my 95 BD 2.2NA with no problems. It was the pre-cat sensor and the older style (not a four-wire one).
Greenbeast is offline   Reply With Quote
Old 04-08-2008, 11:31 AM   #9
Doc Holiday
Scooby Newbie
 
Member#: 171713
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Watertown, MA
Vehicle:
2000 Impreza 2.5RS
Silverthorn Metalic

Default

300 for just the sensor? Or is that the whole process of replacing it with labor (still high)
Doc Holiday is offline   Reply With Quote
Old 04-08-2008, 11:33 AM   #10
Greenbeast
Scooby Newbie
 
Member#: 176457
Join Date: Apr 2008
Default O2 Sensor

I used a Bosch on my 95 BD 2.2NA with no problems. It was the pre-cat sensor and the older style (not a four-wire one).
Greenbeast is offline   Reply With Quote
Old 04-08-2008, 05:49 PM   #11
Acostafan
Scooby Specialist
 
Member#: 67398
Join Date: Aug 2004
Chapter/Region: South East
Location: Chattanooga, TN
Vehicle:
2002 Now with 100%
RDA of 2.5l Goodness!!!

Default

Isn't the factory sensor made by Denso?
Acostafan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to use a DC adapter instead of a battery pack... Cjchaps Off-Topic 11 04-09-2009 09:59 AM
Ok to remove rear O2 sensor? kumaWRX Factory 2.0L Turbo Powertrain 20 11-19-2007 01:42 PM
Is this o2 sensor ok to use? jeff1872t Southern California Impreza Club Forum -- SCIC 2 10-17-2007 03:08 AM
A/F gauge: Ok to install wideband o2 sensor in this location? Force Electrical & Lighting 19 01-19-2007 02:23 AM
aluminum crush washer ok to use instead of copper whiterabbit Factory 2.0L Turbo Powertrain 2 11-16-2003 07:57 AM


All times are GMT -4. The time now is 09:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.