Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2008, 11:36 PM   #1
deathskrye
Scooby Newbie
 
Member#: 153471
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2002 Impreza WRX
Midnight Pearl Black

Default Power steering noise but maybe not the power steering pump.....?

Ok heres my deal. All of a sudden i startee hearing the usualy power steering almost screeching/ screaming noise. Only right when i turn my car on and te first few turns usually when im going slow. But neway the fluid is at the right spot. Is it possible that a bad alternator would effect the power going to the power steering pump and cause this. They both started happeneing together. I know my alternator is bad and i need to get a new one before it kills my battery. But could the alternator and the steering be related or do i just have another problem now?
* Registered users of the site do not see these ads.
deathskrye is offline   Reply With Quote
Old 03-27-2008, 08:41 AM   #2
gto7419
Scooby Specialist
 
Member#: 44256
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2002 WRX Wagon

Default

Unless the alternator bearing being dead and off center has somehow damaged your power steering bearing, the two are completely seperate systems... (I highly doubt this happened as well)

I would think you just have another problem now... The fluid being there has nothing to do with the bearing in the pump dying... It has just passed its useful life.... That being said, my power steering pump is dying too, and makes the same noise - only on cold starts though... I have fluid at the right level as well.... Its just time for a replacement!!!
gto7419 is offline   Reply With Quote
Old 03-27-2008, 01:52 PM   #3
Loyale93
Newbie Moderator
Moderator
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

Why do you think it's the power steering pump? Are you having trouble steering (more than normal) in the morning?

My guess is that it's the idler pulley. If it goes away after a little bit, that sounds like exactly what problem I had, and at least 3 of my friends have had. relatively cheap fix.
Loyale93 is offline   Reply With Quote
Old 03-27-2008, 03:09 PM   #4
deathskrye
Scooby Newbie
 
Member#: 153471
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2002 Impreza WRX
Midnight Pearl Black

Default

Well it used to be only on like cold mornings. but now its like almost every time. I also have an aftermarket alternator pulley and new belt on. Ive elt it like twice this month where it got hard to steer for a second
deathskrye is offline   Reply With Quote
Old 03-27-2008, 05:40 PM   #5
Loyale93
Newbie Moderator
Moderator
 
Member#: 91347
Join Date: Jul 2005
Chapter/Region: NESIC
Location: Moscow, Russia
Vehicle:
'13 XV Crosstrek,
1050 Triumph Speed Triple

Default

In the case of my idler pulley, it was most every time I started up the car. and it would be a squealing noise that I could just hear over the engine (cold morning start up). but that would go away by the time I got to work.

I also replaced my power steering pump, because it was on its way out. It was making a whining noise, most notably in the morning. I had steering shudder, due to air in the lines. I had complete loss of PS at some points. Yea, it needed to go.
Loyale93 is offline   Reply With Quote
Old 08-29-2008, 11:56 PM   #6
frederik
Scooby Specialist
 
Member#: 64405
Join Date: Jun 2004
Chapter/Region: E. Canada
Location: St-Georges, QC, Canada
Vehicle:
2003 WRX Sedan
WRB - Cobb Stg 2

Default

Sorry this is an old thread, but my gf 2006 2.5i steering was noisy, leaked once on the floor during last winter, and had a couple of very loud but short noise occurence recently. The loud noise did not happen when the steering was full left nor right.

Never noticed hard steering, juste steering noise. We did'nt want to take the chance of losing the power steering completely (for a girl might not be cool hehe)
The guy who sold the car (repaired car, car was hit rear right side) suggested that it might be the power steering pump.

Problem is he replaced but the noise is lower, but still there, maybe at 60% of what it was before. I have an 03 wrx with the original pump at 100k+ miles and never noticed any steering noise (and i'm running larger 235 tires which should put more load on the steering...)

I am interested too to know what might cause steering noise (really a kind of hydraulic pump noise) besides the pump itself. and if you have any idea of what can cause

Fred
frederik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got the clunk but its not the strut help!! brranger Brakes, Steering & Suspension 22 01-22-2009 12:46 PM
I'm not racist, but ugh... OR "Race won't affect my vote, but maybe my neighbor's" Paraskass Off-Topic 73 06-11-2008 08:45 PM
Could use some help removing the power steering pump bracket.. Physics Junkie Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 1 01-12-2005 07:40 PM
How many bolts hold on the power steering pump on an STi? Physics Junkie Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 1 01-09-2005 01:07 PM
cute but maybe not so cute... yzfrone Off-Topic 101 06-06-2003 12:31 AM


All times are GMT -4. The time now is 03:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.